none
SCCMクライアントエージェントのインストールエラーについて RRS feed

  • 質問

  • こんにちわ。haru1banと申します。

    現在、SCCM2007の社内導入を行っております。

    そこで、いくつか不明点がありますので、お分かりになるかた、ご教授ください。

     

    1.クライアントエージェントのインストールでのエラー

     クライアントへのエージェントですが手動で行おうと思っています。

     TechNetなどでは、SCCMに関して参考になるような資料を見つけられず、一般書籍を確認したところ

     WindowsServerWorld特別編集号「システム運用&管理の手引き2008」に SCCMの導入手順などが載せられて

     いました。

     

      それを参照して、ドメインユーザの端末から、以下コマンドでインストールを行おうとすると

     権限がないといってインストール用プログラムにアクセスできません。

     サイトサーバ上の共有フォルダ(SMS_サイトコード)¥client¥ccmsetup.exe /mp:<管理ポイント> /Logon /SMSSITECODE=AUTO

     

      しかたないので、該当する共有フォルダの権限を変更(Domain Userでも読み取り、実行を許可)してコマンドは実行することができました。

     

     質問:このように共有フォルダの設定は手動で変更する必要があるのでしょうか?

     

     

    2.クライアントエージェントのインストール後の問題

     コマンドが実行されたあと、コントロールパネルに4つのアイコンが追加されていました。

     ・ConfigurationManager
     ・SCCMプログラムウィザードの実行
     ・プログラムダウンロードモニタ
     ・リモートコントロール

    SMSのV4の導入ドキュメントを参照すると、 上記4つが追加されるということなので

    クライアントエージェントのインストールが完了できたと思い、SCCMサーバ側でクライアントの

    インストール状態を確認したところ、コレクションでは以下のような状態になっておりました。

     

     名前: ホスト名が記載されている

     リソースの種類: システム

     ドメイン: ドメイン名が記載されている

     サイトコード: 空欄

     クライアント:いいえ

     承認済み: N/A

     割り当て: いいえ

     ブロック済み: 空欄

     クライアントの種類: 空欄

     不使用: 空欄

     アクティブ: 空欄

     

     どうやらサーバ側とエージェントでの通信が行われていないようです。

    クライアント側のログには以下のような記載がありました。

    スキーマがどうだ、という記載ありましたので、スキーマの拡張をしていないのが原因なのかとおもいました。

     

     

     

    <![LOG[Getting Assigned Site]LOG]!><time="19:18:31.574+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="2400" file="smsclientclass.cpp:922">
    <![LOG[Getting Assigned Site]LOG]!><time="19:23:48.552+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="2488" file="smsclientclass.cpp:922">
    <![LOG[Autodiscover Site]LOG]!><time="19:23:54.599+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="2488" file="smsclientclass.cpp:1310">
    <![LOG[Setting Assigned Site]LOG]!><time="19:24:44.067+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="2040" file="smsclientclass.cpp:473">
    <![LOG[Assigning client to site サイト名'']LOG]!><time="19:24:44.067+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="2040" file="smsclientclass.cpp:485">
    <![LOG[Unable to verify the sitecode 'サイト名', AD schema is not extended or SLP is not present. Cannot continue site assignment.]LOG]!><time="19:25:11.364+000" date="07-28-2008" component="ClientLocation" context="" type="3" thread="2040" file="smsclientclass.cpp:544">
    <![LOG[Getting Assigned Site]LOG]!><time="19:25:58.161+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="3920" file="smsclientclass.cpp:922">
    <![LOG[Getting Assigned Site]LOG]!><time="19:28:25.135+000" date="07-28-2008" component="ClientLocation" context="" type="1" thread="2496" file="smsclientclass.cpp:922">

     

    質問: クライアントエージェントのインストール手順、サーバ側でのクライアント登録などの手順を教えて欲しい。

    また、スキーマの拡張はどのような手順で行うのか教えてほしい。

     

    以上です。

    何卒宜しくお願いいたします。

     

     

     

     

     

    2008年7月31日 3:30

回答

  •  

    わたしもsccm2007の導入を担当しており、正直資料が無いのでやむなくヘルプに書かれている内容を熟読して作業に望んでおります。

    ヘルプだけではかなり作業が難航しており、HYPER-V上の仮想サーバで現在試験環境を構築しております。

    お互いがんばりましょう・・・。

     

    質問1についてですが、わたしの環境でもAdminsとLocalService、System、インターネットゲストアカウント(ネイティブモードで実行しているためかと思いますが・・・)が表示されていまして、DomainUsersのアカウントはありませんでした・・・。

    わたしは、SCCMからのプッシュインストールを行うため、質問にあった手段をとっていないためわからないですが、手動でアクセス権を付け直すしかなさそうですね。

     

    質問2についてですが、ヘルプ(インストールCD-ROMのssmsetup\help\smsv4.chm)で以下のタイトルを検索したら出てくると思います。

     

    ConfigrationManagerに対してActiveDirectoryスキーマを拡張する方法

     

    ただ、厄介なことにスキーマ拡張を行うだけではなく、ADSIというツールを使ってコンテナの作成、コンテナへのアクセス権付与という作業が必要なようです。

     

    それ以外にもかなり手動でいろいろと手を加えなければ思ったとおりに動いてくれないようで、TRY&ERRORを繰り返して勘を働かせながらインストールしていくという方法しかなさそうです。

     

    ほかの製品にはたいていある日本語の自習書があるとかなり作業イメージがつくので、まだ比較的楽に構築できるんですが・・・。

    皆さん苦しんでらっしゃるんでしょうか。

     

    がんばっていきましょう。

    2008年8月21日 6:48
  •  

    >前回の投稿同様、エージェントのインストールされたクライアントがサーバ側に認識されていないようです。

     

    わたしも同じところで同様の症状に悩まされております。

     

    SCCMのコンソール内の[コレクション]-[すべてのシステム]にActivedirectoryに参加しているコンピュータが認識された状態になるのですが、手動インストールを行ってもプッシュインストールを行ってもその項目の「クライアント」が「いいえ」になったままです。

    この項目について、ヘルプには何の記載も無いので、勝手にクライアントがインストールされたかどうか?のフラグと思い込んでいますが、違うのでしょうか・・・。

     

    クライアント側の以下の場所にccmsetup.exeとクライアントインストールのログがあるのですが、クライアントのインストールに成功したという記述は残っていません。BITS等のプログラムコンポーネントはSCCM管理ポイントからダウンロードできているようですが・・・。

     

    一応、Logには[Successfully created the ccmsetup service]という文言があり、それで終わっているのですが、これでインストールが完了しているのかよくわかりません・・・。

     

    <クライアントインストールログはクライアント上の、以下のフォルダにあります。

    %windir%\system32\ccmsetup\ccmsetup.txt

     

    クライアントインストールが完了しているのなら、エージェントの設定等も行っているので、インベントリ収集などを行ってくれそうなものですが、まったく動作していません。はてさてこまった・・・。

     

    ちなみに、もし、haru1banさんがお使いのSCCMのバージョンがわたしの検証環境のものと違っていたら、

    わたしの情報はあまり意味が無い可能性もあるため、環境を記載します。

    MSアップデートを常時行っていますので、このバージョンでの最新状態だと思います。

     

    sccm2007評価版 Version 4.0.5931.0001→server2003StandardEdition

    AD&証明機関→server2003EnterpriseEdition

     

     

    >pentium1000mhzさんはどの情報ソースを参照されたのでしょうか。

     

    ヘルプはSCCMの管理コンソールの中にあるヘルプを利用しています。

    ただ、バグなのか仕様なのか、キーワード検索をしてもMicrosoft管理コンソールのヘルプのキーワード検索しかしてくれません。

    なんちゅう仕様・・・。

     

    仕方ないので、ヘルプファイルの実体を探しましたが見つからないため、評価版のプログラムを解凍すると出てくるこのファイルを使っています。(実際のヘルプと同じものです。)

    configmgr07_rtm_jpn_5931_eval\smssetup\help\smsv4.chm

     

    スキーマ拡張に関してはこのヘルプドキュメントを読んで参考にしました。

    「スキーマを拡張する方法」でヘルプの検索をかけると4番目に出てきました。

     

    「Configuration Manager に対して ActiveDirectory スキーマを拡張する方法」

     

    >このSMS v4がSCCM2007に該当するのではないかという、まったくの個人的な推測をもとに作業を進めています。

     

    SMSV4はsccm2007のことです。ただ、SMSV4はベータ版等の古いものである可能性があるので、新しいものを使われたほうがよさそうです。

    ちょっと違う内容ですが、現に最近でもこのようなことが・・・。

    http://bbs.hotfix.jp/ShowPost.aspx?PostID=7736

     

    誤植が直っていたりすることもあるかもしれません。新しいものを使ったほうがいいですよ。

     

    >プッシュインストール時に何か気をつけることなどございますでしょうか?

     

    これまたヘルプに詳しく書かれています・・・が、このとおりやってもクライアントが動いてくれることはありませんでした・・・。

    「クライアント プッシュを使用したクライアントのインストール方法」

    それ以外にも、「クライアント展開の概要」で詳しくクライアント展開を見たほうがよさそうです。

    もしかしたら、サーバ側の設定(インベントリ情報収集機能を動かすための設定がまだほかにもあるとか・・・。)何でしょうか。

    困ったもんです。

     

    それにしても、わからないことだらけで、困ってしまうくらい日本語ドキュメントは無いですね。

    構築請負をしてくれるSIベンダさんは皆さんどうやって勉強してらっしゃるんでしょうかねぇ・・・。

    高額なセミナーなんかを受講されているんでしょうか・・・。

    それとも、皆さん英語が堪能で英語ドキュメントがへっちゃらだとか・・・。(笑)

     

    sccmにひと月がかりでここまできましたが、わたしの場合、まだまだ道は遠そうです。

    2008年8月27日 8:20
  • ひとまず、こちらはネイティブモードですべての機能が動作するようになりました。

     

    しかし、クライアント展開時にPKIがらみのトラブルが発生し、社内ヘルプデスクのかたに迷惑かけそうな気がします。

    たぶん自動クライアント証明書インストールのポリシーが動作しないクライアントが出てくるのかなぁ。

    わたしたちがPKIを理解しても彼らに複雑なPKIを理解しろというのも難しく、セキュリティ的には落ちますが、混在モードで動作させることにしました。

     

    後からネイティブモードにすることも可能なので、まずはランディングすることを目標にしたほうが現実的と判断いたしました。

     

    簡易なものですが、構築の流れを別スレであげておきます。

    構築時にわたしがはまったポイントも書き記しておきますね。

     

    それでは、がんばってください。

    2008年10月1日 1:20

すべての返信

  •  

    わたしもsccm2007の導入を担当しており、正直資料が無いのでやむなくヘルプに書かれている内容を熟読して作業に望んでおります。

    ヘルプだけではかなり作業が難航しており、HYPER-V上の仮想サーバで現在試験環境を構築しております。

    お互いがんばりましょう・・・。

     

    質問1についてですが、わたしの環境でもAdminsとLocalService、System、インターネットゲストアカウント(ネイティブモードで実行しているためかと思いますが・・・)が表示されていまして、DomainUsersのアカウントはありませんでした・・・。

    わたしは、SCCMからのプッシュインストールを行うため、質問にあった手段をとっていないためわからないですが、手動でアクセス権を付け直すしかなさそうですね。

     

    質問2についてですが、ヘルプ(インストールCD-ROMのssmsetup\help\smsv4.chm)で以下のタイトルを検索したら出てくると思います。

     

    ConfigrationManagerに対してActiveDirectoryスキーマを拡張する方法

     

    ただ、厄介なことにスキーマ拡張を行うだけではなく、ADSIというツールを使ってコンテナの作成、コンテナへのアクセス権付与という作業が必要なようです。

     

    それ以外にもかなり手動でいろいろと手を加えなければ思ったとおりに動いてくれないようで、TRY&ERRORを繰り返して勘を働かせながらインストールしていくという方法しかなさそうです。

     

    ほかの製品にはたいていある日本語の自習書があるとかなり作業イメージがつくので、まだ比較的楽に構築できるんですが・・・。

    皆さん苦しんでらっしゃるんでしょうか。

     

    がんばっていきましょう。

    2008年8月21日 6:48
  •  

    pentium1000mhz さん

    はじめまして、haru1banです。

     

    投稿へのレス、誠にありがとうございます。

    私はSCCMとの格闘を始めてほぼ2ヶ月になり、サーバインストール、エージェントのインストールまで行えているつもりですが

    前回の投稿同様、エージェントのインストールされたクライアントがサーバ側に認識されていないようです。

    この製品はドキュメントがなく本当に困っています。そのためこのフォーラムを頼っています。

     

    今後も何か情報ございましたら、情報の共有などお願いいたします。

     

    質問1について

     対象フォルダのACLを手動で付け直しをしました。

     また、プッシュインストールも試しております。

     プッシュインストール時に何か気をつけることなどございますでしょうか?

     

    質問2について

     SCCMの前身のSMS V4のMS社製のドキュメント(”システム管理とSMS v4”で検索するとトップにでます)を参照して

     CDROM内にある、extadsch.exeを実行して、拡張しました。その結果、インストール時「スキーマが拡張されていません」

     というエラーは出なくなりましたので、手順的にこれでよいようです。ありがとうございました。

     

     このSMS v4がSCCM2007に該当するのではないかという、まったくの個人的な推測をもとに作業を進めています。

     そこにはADSIなどの説明はないのです。pentium1000mhzさんはどの情報ソースを参照されたのでしょうか。

     

    ※ちなみに、SystemCenterEssentials2007では、このような面倒な作業はなく、簡単にエージェントを

    インストールされたマシンを認識できていました。

     

    すみませんが、お時間のあるときに回答お願いいたします。

     

     

     

     

    2008年8月25日 4:46
  •  

    >前回の投稿同様、エージェントのインストールされたクライアントがサーバ側に認識されていないようです。

     

    わたしも同じところで同様の症状に悩まされております。

     

    SCCMのコンソール内の[コレクション]-[すべてのシステム]にActivedirectoryに参加しているコンピュータが認識された状態になるのですが、手動インストールを行ってもプッシュインストールを行ってもその項目の「クライアント」が「いいえ」になったままです。

    この項目について、ヘルプには何の記載も無いので、勝手にクライアントがインストールされたかどうか?のフラグと思い込んでいますが、違うのでしょうか・・・。

     

    クライアント側の以下の場所にccmsetup.exeとクライアントインストールのログがあるのですが、クライアントのインストールに成功したという記述は残っていません。BITS等のプログラムコンポーネントはSCCM管理ポイントからダウンロードできているようですが・・・。

     

    一応、Logには[Successfully created the ccmsetup service]という文言があり、それで終わっているのですが、これでインストールが完了しているのかよくわかりません・・・。

     

    <クライアントインストールログはクライアント上の、以下のフォルダにあります。

    %windir%\system32\ccmsetup\ccmsetup.txt

     

    クライアントインストールが完了しているのなら、エージェントの設定等も行っているので、インベントリ収集などを行ってくれそうなものですが、まったく動作していません。はてさてこまった・・・。

     

    ちなみに、もし、haru1banさんがお使いのSCCMのバージョンがわたしの検証環境のものと違っていたら、

    わたしの情報はあまり意味が無い可能性もあるため、環境を記載します。

    MSアップデートを常時行っていますので、このバージョンでの最新状態だと思います。

     

    sccm2007評価版 Version 4.0.5931.0001→server2003StandardEdition

    AD&証明機関→server2003EnterpriseEdition

     

     

    >pentium1000mhzさんはどの情報ソースを参照されたのでしょうか。

     

    ヘルプはSCCMの管理コンソールの中にあるヘルプを利用しています。

    ただ、バグなのか仕様なのか、キーワード検索をしてもMicrosoft管理コンソールのヘルプのキーワード検索しかしてくれません。

    なんちゅう仕様・・・。

     

    仕方ないので、ヘルプファイルの実体を探しましたが見つからないため、評価版のプログラムを解凍すると出てくるこのファイルを使っています。(実際のヘルプと同じものです。)

    configmgr07_rtm_jpn_5931_eval\smssetup\help\smsv4.chm

     

    スキーマ拡張に関してはこのヘルプドキュメントを読んで参考にしました。

    「スキーマを拡張する方法」でヘルプの検索をかけると4番目に出てきました。

     

    「Configuration Manager に対して ActiveDirectory スキーマを拡張する方法」

     

    >このSMS v4がSCCM2007に該当するのではないかという、まったくの個人的な推測をもとに作業を進めています。

     

    SMSV4はsccm2007のことです。ただ、SMSV4はベータ版等の古いものである可能性があるので、新しいものを使われたほうがよさそうです。

    ちょっと違う内容ですが、現に最近でもこのようなことが・・・。

    http://bbs.hotfix.jp/ShowPost.aspx?PostID=7736

     

    誤植が直っていたりすることもあるかもしれません。新しいものを使ったほうがいいですよ。

     

    >プッシュインストール時に何か気をつけることなどございますでしょうか?

     

    これまたヘルプに詳しく書かれています・・・が、このとおりやってもクライアントが動いてくれることはありませんでした・・・。

    「クライアント プッシュを使用したクライアントのインストール方法」

    それ以外にも、「クライアント展開の概要」で詳しくクライアント展開を見たほうがよさそうです。

    もしかしたら、サーバ側の設定(インベントリ情報収集機能を動かすための設定がまだほかにもあるとか・・・。)何でしょうか。

    困ったもんです。

     

    それにしても、わからないことだらけで、困ってしまうくらい日本語ドキュメントは無いですね。

    構築請負をしてくれるSIベンダさんは皆さんどうやって勉強してらっしゃるんでしょうかねぇ・・・。

    高額なセミナーなんかを受講されているんでしょうか・・・。

    それとも、皆さん英語が堪能で英語ドキュメントがへっちゃらだとか・・・。(笑)

     

    sccmにひと月がかりでここまできましたが、わたしの場合、まだまだ道は遠そうです。

    2008年8月27日 8:20
  •  pentium1000mhz さん

     

    ご無沙汰しております。haru1banです。

    色々情報いただきまして、ありがとうございます。

     

     pentium1000mhz さんからいただいた情報をもとに一歩すすみました。

    ADのスキーマ拡張を実施することができたためかと思います。

    (サイトコードが認識され、割り当てが”はい”になりました)

     

    名前: ホスト名が記載されている

     リソースの種類: システム

     ドメイン: ドメイン名が記載されている

     サイトコード: サイトコードが記載されています。

     クライアント:いいえ     

     承認済み: N/A

     割り当て: はい

     ブロック済み: 空欄

     クライアントの種類: 空欄

     不使用: 空欄

     アクティブ: 空欄

     

    ただし、クライアントのプッシュインストールはできていません(クライアントは”いいえ”のままです。トホホ)。

    また、日本語のインストールドキュメントなるものも発見しましたので、ご報告します。

     

     

    http://www.crie-illuminate.jp/techinfo/sccm_install.aspx

     

    別のスレッドを見ると、pentium1000mhz さんはクライアントのプッシュインストールまで成功されたのですね。

    おめでとうございます。

     

    もう少しがんばってみます。

     

     

    2008年9月19日 11:41
  • ひとまず、こちらはネイティブモードですべての機能が動作するようになりました。

     

    しかし、クライアント展開時にPKIがらみのトラブルが発生し、社内ヘルプデスクのかたに迷惑かけそうな気がします。

    たぶん自動クライアント証明書インストールのポリシーが動作しないクライアントが出てくるのかなぁ。

    わたしたちがPKIを理解しても彼らに複雑なPKIを理解しろというのも難しく、セキュリティ的には落ちますが、混在モードで動作させることにしました。

     

    後からネイティブモードにすることも可能なので、まずはランディングすることを目標にしたほうが現実的と判断いたしました。

     

    簡易なものですが、構築の流れを別スレであげておきます。

    構築時にわたしがはまったポイントも書き記しておきますね。

     

    それでは、がんばってください。

    2008年10月1日 1:20
  • こんにちは、フォーラムオペレータ大久保です。

     

    pentium1000mhz さんが情報提供してくださったスレッドのリンクをはっておきますね。

    (すんばらしい情報です!)

     

    【情報】SCCM構築手順の概要

    http://forums.microsoft.com/technet-ja/ShowPost.aspx?PostID=3944955&SiteID=36

     

     

    haru1ban さんの状況が気になるところですが、ひとまず pentium1000mhz さんの投稿に「回答済み」チェックをつけさせていただきました。

    動きがありましたら、その後の状況等追加でご投稿いただければと思います。

     

    それでは

    2008年10月14日 5:33