none
Exchange Server 2010でSSL証明書がインストールできない RRS feed

  • 質問

  • Windows2008R2std sp1+Exchange Server 2010 sp1の環境にて

    EMCより「Exchange証明書の新規発行」をすると通常は自己証明が「いいえ」で「これは保留中の証明書の著名要求(CSR)です」

    と検証環境では表示されるのですが、別環境では自己証明「はい」「証明書がExchange Serverの使用に対して有効です」

    と表示されてしまいます。

    そして証明書を右クリックすると「保留中の要求の完了」は選択できますが同じドメイン内にある別サーバーを認証機関にして保留中の要求の完了をするとExchange証明書の一覧に表示されなくなってしまい使う事ができません。

    環境は2008R2のDC 2台、Hyper-V環境の2008R2が認証機関、Exchangeは1台に全機能入れています。

    他はトラブル無く快調に動作しています。ExchangeマシンはWindows Update最新にしました。

    Outlook Anywhereで使いたいので、何かおかしい事をしていないかご教授お願いいたします。

    シェルはまだ使っていません。

    4/17追記

    問題の環境はExchange Server 2010 sp1を入れていませんでした。
    バックアップが終わらないので数日後にsp1やロールアップ3を入れて再度試みてみます。

    2011年4月16日 4:04

回答

  • 自己解決しました。

    証明書のテンプレートを「Exchange登録エージェント(オフライン要求)」にしていました。

    Exchangeに証明書を入れるときに下記のlogが証明書サーバーに出ていました。
    ======================
    ログの名前:         Application
    ソース:           Microsoft-Windows-CertificationAuthority
    日付:           
    イベント ID:       77
    タスクのカテゴリ:      なし
    レベル:           警告
    キーワード:         クラシック
    ユーザー:          SYSTEM
    ======================

    証明書テンプレートを
    「webサーバー」
    にしたら正常にExchangeに入りました

    無印とsp1で自己証明書の表示が異なるなどしていて混乱していたようです。

    お騒がせしました。

    • 回答としてマーク z432 2011年5月9日 23:59
    2011年5月9日 23:59

すべての返信

  • z432 さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    追記の情報、ありがとうございます。
    もし事象が解決されないようであればTecNet ライブラリの証明書の作成に関するページの
    手順を確認して、そちらの詳細をお知らせいただければと思います。

    ・新しい Exchange 証明書の作成:
    http://technet.microsoft.com/ja-jp/library/dd351057.aspx

    Outlook Anywhere に関してのTechNet ライブラリの情報を参考までにご紹介します。

    ・Outlook Anywhere での SSL について
    http://technet.microsoft.com/ja-jp/library/dd351177.aspx#valid

    お役にたちましたら幸いです。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    2011年4月21日 8:18
  • 星 様

    返信ありがとうございます。

    そのtechnetのライブラリは何度も確認し手順通り実行しています。

     

    現在バックアップが終わりません。

    OSと別HDDにメールDBを置いてありサイズは500G強/メールboxは100弱の本番環境です。

    OS標準のWindows Server Backupでは「アプリケーション Exchange の整合性チェックを実行しています」が4日間かかっても終わりません。

    これはメールボックスをオフラインにして実行する必要があるのでしょうか?何日も時間がかかるのは正常なのでしょうか?

    メールDBを除くと短時間でバックアップは正常終了します。

    MAPIlab POP3 Connectorを入れているのですがこちらのバージョンが2.2.1です。

    最新は2.3.1/Exchange2010sp1対応は2.3.0からとあるのでこちらもアップデートしてみます。

    event viewerにエラーはありません。

    2011年4月21日 13:22
  • メールボックスDB は 1つ で 500GB強でしょうかね?

    でかすぎて時間かかってる可能性も有るような気がします。

    HDD空き容量に余裕があるようでしたら、

    4つほど新規にメールボックスDBを設けて

    元DB → メールボックスDB2,3,4,5 にそれぞれ容量が均等になる感じにメールボックス移動して振り分けてみてはいかがでしょうか。

    1DBあたり 100GB程度までにするのが推奨と思われます。

     

    2011年4月22日 0:34
  • SHIMSOFT様

    返信ありがとうございます。

    すみません。確認するとdbファイル本体(.edb)は120G程度で

    残りは1Mづつのlogファイルが多数あり320G程度ありました。HDDの使用容量で500Gと書いてしまいました

    HDDはSASの15000回転4台でRAID5です。

    一度MailBox DBをオフラインにしてバックアップしてみます。

     

    2011年4月22日 15:46
  • バックアップは解決しました。SSL証明書が入らない事象はまだ未解決です。

    DBをアンマウントしてlogファイルを移動したら常識的な速度でバックアップが進行しました。

    注意点:
    ・通常logファイルはバックアップされると削除されるがデフォルトではバックアップをしないと永遠にlogを溜め込み続ける。
    ・logはデータファイルの2倍程度の容量になるのが正常。
    ・logデータはDBをアンマウントしてから移動や削除する。

    バックアップ時の整合性チェックはlogファイルと合っているか全チェックしているようです。長期間バックアップしてないとlog莫大な量になりチェックに時間がかかる。サーバーの性能にもよるだろうがDB100G/LOG300Gでは現実的な時間で整合性チェックが終わらない。
    logファイルにDBの全情報が入っているようなので削除するとデータ保護の担保が一つなくなる。http://technet.microsoft.com/ja-jp/library/ee832796.aspx

    長期間バックアップをしない人なんていないでしょうが、、

    2011年4月22日 17:25
  • 自己解決しました。

    証明書のテンプレートを「Exchange登録エージェント(オフライン要求)」にしていました。

    Exchangeに証明書を入れるときに下記のlogが証明書サーバーに出ていました。
    ======================
    ログの名前:         Application
    ソース:           Microsoft-Windows-CertificationAuthority
    日付:           
    イベント ID:       77
    タスクのカテゴリ:      なし
    レベル:           警告
    キーワード:         クラシック
    ユーザー:          SYSTEM
    ======================

    証明書テンプレートを
    「webサーバー」
    にしたら正常にExchangeに入りました

    無印とsp1で自己証明書の表示が異なるなどしていて混乱していたようです。

    お騒がせしました。

    • 回答としてマーク z432 2011年5月9日 23:59
    2011年5月9日 23:59