none
Windows7 IE9 保護モードの動作を確認する方法をお教えください。 RRS feed

  • 質問

  • いつも大変お世話になっております。

    木村と申します。

     

    質問:特定のPCにおいて、ユーザアカウントで保護モードを有効にしたIE9を使用すると、Webページ読込中にIEがフリーズします。

        保護モードの動作を確認する方法をお教えください。

     

    この度富士通製デスクトップPC ESPRIMO D582/Eを顧客へ6台、ほぼ同一設定で導入いたしました。

    Windows7 64bit版のIE9です。

    設定作業はAdministratorアカウントを有効にし、

    必要ソフトのインストール(Office2010Pro、VisioPro、XPmode、ATOK、筆まめ、プロアトラス、ホームページビルダー、AdobeReader&Flash)、

    WindowsUPdate、プリンタ設定、電源設定などの環境設定を行っております。固定IPでインターネットはプロキシ経由です。

     

    その後顧客先へ納入、顧客にてドメイン参加を行いましたが、6台中2台のPCにおいて

    ドメインユーザーでログオンした際にインターネットが接続できないという現象が発生いたしました。

    YahooやGoogleなどのトップページを開くことはできますが、その後リンクをたどったり検索したりすると

    IEがフリーズし、強制終了するしかなくなってしまいます。(トップページの時点でフリーズすることも多いです)

    他のサイトでもフリーズが発生してしまい、ほぼ使用が不可能な状態です。

     

    現地にて検証したところ、現象発生の条件としては以下の2点でした。

    ①Administrator以外のユーザ名でログインした場合

    (ローカルadmin、ドメインadminの場合は保護モード有効でも接続OK。

     ローカルユーザ・ドメインユーザではNG(admin権限があってもなくても))

    ②IEの保護モードが有効になっている(インターネット)

    (ユーザアカウントでも保護モードを無効にした場合や、イントラネット・信頼済みサイトは接続OK)

     

    Administratorでログオンした場合や、保護モードを無効にした場合では接続に問題はないため、

    ネットワーク関係の障害ではないと思います。(現象が発生しないPCとのLANケーブル入れ替えも試しています)

     

    他、以下の検証を行っております。いずれも現象は改善されませんでした。

    ・セキュリティソフト(Symantec Endpoint Protection)を無効

    ・IEの設定リセット・ゾーンのリセット

    ・IE9の再インストール(IE8でも同一現象発生)

    ・IE9をアドオンなしで起動

     

    富士通の担当者へも問い合わせましたが、IEやOSに関してはMicrosoft標準設定のまま出荷しているとのことでした。

    現象から見て、ユーザアカウントでログオンした際に保護モードの動作がおかしく、

    ほとんどのサイトを制限してしまっているような印象です。

    保護モードを有効にした上での運用としたく、保護モードの動作を確認できるような方法があればお教えいただきたく思います。

     

    よろしくお願いいたします。

     

    追記

    ・現象が出ている状態で他ブラウザ(google clome)を使用した場合、接続OKです。

    ・YahooやGoogleのトップページが開くのはキャッシュの効果かと思いますので、インターネットはほぼ不可のようです。

    • 編集済み 星 睦美 2012年10月12日 1:33 PI一部削除しました
    • 編集済み skimura 2012年10月14日 23:57
    2012年10月11日 7:32

回答

  • 時間を掛けて調査すればもしかしたら何か有効な事項が見つかるかもしれませんが、例えば専門家がオンサイトで調査するというような非常にコストの高い方法を使わない限り、あまり大きな期待は持てないかもしれません (オンサイトしても分からない、という可能性だってある訳で)。またもし原因が分かったとしても、環境再構築が一番適切な対処方法になる可能性も少なくありません。

    運用を継続し続け、時間が経過すればするだけエンド ユーザーさんとしては初期化・再構築に抵抗感が強くなると思いますので、早めに決断してしまった方がお互いに幸せなのではないかという気はします。


    hebikuzure

    • 回答としてマーク 星 睦美 2012年11月1日 8:48
    2012年10月15日 17:44

すべての返信

  • 保護モード無効では動作するという事ですから、保護モードの動作と互換性のない何か(アドオンとか常駐プログラムとか)が原因というのが一番最初に思いつきますが....。

    6台中2台のPC」で問題が起きているが、残りの4台と同じ機材で同じように構成したはず、という事になると

    A. 「同じ」はずの手順がどこかで違っていた
    B. 偶発的に発生したトラブル

    のいずれかの可能性がまず考えられ、そうなると第三者が検証したり動作確認したりするのは困難ですよね。

    ビジネス的には問題の起きている2台についてもう一度最初から(工場出荷時への初期化から)構成し直して、それで現象が起きなければ上のいずれかだったという事で、そうでなければハードウェア的に何か問題がある可能性の方向で(機材を交換するとか)対処すれば良いかと思います。

    あまりに再現性が高いようであれば、機材の工場出荷時点から構成の1ステップずつで動作検証をして、トリガーを見つける事も必要でしょうが、今そこまでやるかどうかの判断は第三者にはできませんね。


    hebikuzure

    2012年10月12日 8:54
  •  
    保護モードを有効にした上での運用としたく、保護モードの動作を確認できるような方法があればお教えいただきたく思います。

    ってなんでしょね。普通にトラブルシュートすればよいのでは。

    初心者でもわかる! IE トラブル おすすめ対処法

    とかで。

      
    2012年10月13日 16:52
  • Hebikuzure様

    ご回答ありがとうございます。

     

    対象PCはすでに顧客先へ導入し、運用が始まっているため、初期状態に戻して再設定という事が難しい状態です。

    顧客へは現状を説明し、保護モードを無効にして運用して頂いております。

    (顧客側は、現状でも特に不便はないので、わざわざ再設定することもないという考えです)

     

    しかしインターネットへの接続が頻繁なPCではないとはいえ、他のPCよりセキュリティレベルが低下してしまうのは避けたく、初期状態に戻す以外の方法を模索している次第です。

    保護モードの有効/無効で現象が再現するのは確実ですので、保護モードの動作内容がわかれば解決に向かうかと考え、質問をいたしました。

     

    IEに関しては、設定のリセットや再インストールを行い、IEが初期状態のままでも現象が発生いたします。(IE8でも)

    インストールした他のソフトがIEのセキュリティ機能に影響を及ぼすのも考えにくいですし、保護モードを無効にした場合は何の問題も起こりませんので、設定手順に不備があるという可能性も除外しました。

     

    また何か心当たりなどあれば、お教え頂けますようお願いいたします。

    2012年10月14日 23:32
  • ウィンドウズスクリプトプログラマ様

    少なからずトラブルシュートも行った上での質問ですので、ご理解ください。

    (正常PCとの設定の比較、IEのリセットや再インストールなども行っております)

    保護モードの有効/無効で現象が再現するのは確実ですので、保護モードの動作内容がわかれば解決に向かうかと考え、質問をいたしました。

    無効にすれば運用は可能ですが、少しでもセキュリティレベルが落ちるのは避けたいと考えております。

    よろしくお願いいたします。

    2012年10月14日 23:50
  • 時間を掛けて調査すればもしかしたら何か有効な事項が見つかるかもしれませんが、例えば専門家がオンサイトで調査するというような非常にコストの高い方法を使わない限り、あまり大きな期待は持てないかもしれません (オンサイトしても分からない、という可能性だってある訳で)。またもし原因が分かったとしても、環境再構築が一番適切な対処方法になる可能性も少なくありません。

    運用を継続し続け、時間が経過すればするだけエンド ユーザーさんとしては初期化・再構築に抵抗感が強くなると思いますので、早めに決断してしまった方がお互いに幸せなのではないかという気はします。


    hebikuzure

    • 回答としてマーク 星 睦美 2012年11月1日 8:48
    2012年10月15日 17:44
  • sho.kimura さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    私のほうでHebikuzure さんのアドバイスに[回答としてマーク] させていただきました。
    フォーラムでの回答も難しいように思いますので、問題の解決を急がれる場合にはよろしければマイクロソフトのサポート窓口へのご相談を検討いただければと思います。

    sho.kimura さんの質問の環境で設定されているかどうかわかりませんが、質問に書かれている検証内容以外でIE の設定に影響する点があるとすればグループポリシーの設定も可能性のひとつかも知れません。

    ・Internet Explorer 9 のグループ ポリシー:
    http://technet.microsoft.com/ja-jp/library/gg699401.aspx

    今後ともTechNetフォーラムをよろしくお願いします。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美

    2012年11月1日 8:59