none
Setting up a PPP connection using "Communications cable between two computers"

    全般的な情報交換

  • Hello,

    I have a special hardware device that requires me to establish a PPP connection using a serial cable to communicate with the PC

    I have a few problem with this in Windows 7 Enterprise evaluation version.


    I have used the "Phone and Modem" dialog in control panel to create a modem entry for "Communications cable between two computers"


    Now I go to the "Network and Sharing Center" in Control Panel, and select "Set up a new connection or Network".

    Then I choose the "Set up a dial-up connection"

    Here is my first problem: It insists that I enter a phone number otherwise the Connect button will not enable. But I since I choose the direct serial cable connection, I don't think it should require a phone number.
    My workaround is to just enter a dummy number and then delete it again later the connection properties. Then press "Connect" and then "Skip"

    Now in "Network and Sharing Center", I go to "Change Adapter Settings", open properties for the new dial-up connection and click "Configure" on the "General" tab. This opens the "Modem Configuration" dialog. Here I deselect the three "Hardware feature" settings.

    Here is my second problem: If I click OK in "Modem Configuration" and in "Dial-up connection properties" and then open them again, the "Enable hardware flow control" setting is back on.
    I have verified that the setting is correctly written to the file rasphone.pbk: HwFlowControl=0
    But opening "Dial-up connection properties" and clicking OK sets it back to HwFlowControl=1 in the file, unless I go to "Modem Configuration" and deselect it again.


    Here is my third problem: The dial-up connection will not work.
    I have tracked the cause down by comparing the "rasphone.pbk" file to a working one from Windows XP.
    The field "Type" is set to 1 but it should be 3.

    As far as I can see from the RAS API (look up the RASENTRY data structure)
    1=RASET_Phone (Phone line, for example, modem, ISDN, X.25)
    3=RASET_Direct (Direct serial or parallel connection.)

    Manually editing the rasphone.pbk file and changing the value from 1 to 3 fixes the problem and my dial-up connection works OK.


    So my last question : Are these bugs, or is there a different way to set up a PPP connection like this, that does not use a modem and a phone number to dial.
    2009年9月24日 14:07

すべての返信

  • Hi,

    Based on my knowledge, I suspect
     this may be related to this specific device.

     

    I would also like to share the following documents with you:

     

    Point-to-Point Protocol

     

    RASENTRY Structure

     

    I am also very glad to know that the connection works with your efforts. We are sure that what you experienced will help other users who meet this issue. Thanks again for your information.


    Nicholas Li - MSFT
    2009年9月25日 10:25
    モデレータ
  • I'm trying to follow the same steps to create a PPP connection over a serial cable using Windows 7.  I have the same situation where some special hardware requires a PPP connection over a direct serial connection. Here are the steps:

    1) from "Network and Sharing Center", choose "Set Up A Connection or Network"

    2) Choose "Set Up A Dial Up Connection"

    3) Fill in "dummy" dial up phone number to enable "Connect". However, there is no option for Direct Serial Cable Connection on this dialog.

    4) click "Connect", then "Skip", then go to Connection Properties

    5) In connection properties, the "Connect Using" field is filled in with a Conexant modem. I cannot change it to COM1.

     

    Question - how did you access the direct serial connection when creating the connection?

     

     

    2010年8月23日 22:08
  • Try this.  Go to phone and modem in control panel.  Add a modem and check Don't detect my modem.  Click next and select Communucation cable between two computers.  Click next and select the Com port you want to use.

     

    Now set up the network.  Network and Sharing Center --> Set up a connection or network --> Set up dial up connection and click next.  Now select communucation cable betweem two computers and click next.  Fill in a dummy phone number and click connect then skip.  Click close.

    From Network and sharing center click change adapter settings.  Right click Dial up Connection and select properties.  Click on the Networking tab.  Click install and select protocol.  Click add and select the file for ppp protocol. ;)  That seems to be the catch.

     

    Ideas anyone?

    2011年1月5日 5:17
  • The only way you can set this up is loading Windows Virtual PC XP Mode and setting it up from there.

    Once Virtual PC is loaded, start it and click on settings on the top bar.  Associate the Virtual PC serial port with a serial port on Windows 7.  Just follow your nose.

    Then set up a direct ppp connection to another computer just as you would on any Windows XP machine.  Tested and works great!

    2011年1月5日 11:47
  • Hard to find but here it is.... (unlikely source huh?)

     

    http://phsw.110mb.com/nw-w7ppp.html

     

     

    2011年7月19日 1:20
  • Thanks! I stumbled upon the same issue.
    2012年7月9日 8:58
  • Yeees, you £$*@! hacker!!! ;) 

    Genius: "rasphone.pbk change type = 3" 

    How you got to that I will never know but for me, after fruitless attempts to get my COM connection to CX500 working with Dial-Up connection on windows 10 and windows 2012, for a full working day, and subconscious voices of defeat echoing in my head, implying I might best give up this quest, this hack pumped up my mana and led me to victory!!!! 

    I was resorting to doing an IP subnet scan across the WHOLE IP range (as IP was unknown), but even with 100,000 execution threads I was not able to scan faster than 255 addresses in about 3 seconds, meaning it would have taken a loooooooooong time. (And then even if IP found, I wasn't sure what the password would be) 

    My serial-USB dongle and extended null-modem cable also added variables that I could not eliminate. 

    Thanks a million! 

    K28.5 

    2018年5月18日 15:20