none
The username or password is incorrect when attempting login to remote computer running Windows 7 Ultimate via TS Web Access

    質問

  • I previously routinely logged into my daughters computer (running Vista Business X64 behind the firewall at her university's network) via TS Web Access.

    She upgraded the system to Windows 7 Ultimate to solve a video card issue and now the Remote Desktop login fails.  I can get to the machine through the gateway but it gives the "The username or password in incorrect message" on every attempt.

    I can have someone log using Remote Desktop from the internal network just fine using the absolute same username/password.

    I have had her check all of the remote settings multiple times (I have seached this one extensively).  Can anyone suggest what the problem may be and a solution.  Or even a method to diagnose would be helpful.

    This is a critical issue for me since she is near clueless.

    2010年3月3日 2:43

回答

  • I found my own answer to this issue after I got acces to the machine physically and was able to view the security logs for the failed login attempts.  For some reason windows seven required that I use the entire computer name \\computer name\account name\ to get to the machine whereas Vista did not require full name.  Problem solved as long as I use the full name convention for the computer as expectedf behind the ts gateway.  Also don't pass the ts gateway credentials on to the remote computer as this causes it to want to log on with those creditials at the machine.    
    • 回答としてマーク pjwilso 2010年3月31日 3:47
    2010年3月31日 3:47

すべての返信

  • Hi,

     

    Please adjust the following setting of the computer which you establish the RDP connection to:

     

    1.    Open System Properties.

    2.    In the Remote tab, select the following option:

     

    Allow connections from computers running any version of Remote Desktop

     

    If the issue persists, please also collect the MPS Report on the computer which you establish the RDP connection to (the target computer) for our further research:

     

    1.     Download the MPS Report Tool.

     

    2.     After the download is complete, double-click this "MPSRPT_PFE.EXE" file. When you are prompted "Include the MSINFO32 report?", please input Y to continue. After a while, a CAB file will be generated.

     

    3.   Open My Computer, browse to the "%systemroot%\MPSReports\PFE\CAB" folder. You can find the CAB file above.

     

    If there is a TS gateway on your network, please also collect MPS Report on it.

     

    For your convenience, I have created a workspace for you. You can upload the screenshot via the following link.  (Please choose "Send Files to Microsoft")

     

    https://sftasia.one.microsoft.com/choosetransfer.aspx?key=a4fbd1e7-d13f-4cc5-92ad-040b008ad7e5

    Password is “4e@y{B[mbFah” (without quotations).

     

    Thanks.


    Nicholas Li - MSFT
    2010年3月4日 9:56
    モデレータ
  • I did check the remote desktop settings several occations and checked to make sure user accounts are added to remote access.

    I will have to see if I can get someone to do this at her computer.  I am ~700 miles away!  It is onthe university  network with a gateway (TS Web Access running on a windows 2008 server platform)  Not sure how successfull I will be at getting them to run the utility.  May take a few days.

    I can get to the computer, it just will not accept the username/password.   This all worked correctly before updating to Windows 7 (Vista Business before update).  I was hoping for a simpler (even if brute force) solution like uninstall/reinstall components.

    Thanks for the assistance!

    Peter Wilson



    2010年3月5日 2:12
  • I'm having a very similar problem.... I'm trying to connect to a vista computer from a windows 7 computer.

    It worked fine all along until suddently, after one login. The next login (2 minutes later) failed saying it was wrong username/password.... and it's 100% sure not to be wrong.


    It works fine if I use the local IP e.g. http://192.168.0.122/tsweb/Default.htm but if I use http://94.145.xx.xx/tsweb/Default.htm it says wrong username/password. also if I'm using the microsoft remote desktop client (so it's not just in tsweb... I've check keyboard layout and lord knows what... I*M TYPING THE RIGHT THING...but it isn't letting me in! PLEASE HELP!
    2010年3月11日 2:09
  • Not sure if you've managed to resolve this or not, but I had a similar problem which is now resolved.

    Here is my scenario:

    - the username on Win7 target is changed (allegedly - and you know why I say allegedly later) by choosing "change your account name" through clicking on user picture in start menu or "user accounts" in control panel.

    - you try logging in to win7 remotely (from server 2k3 in my case) using the new uname/password and it fails: incorrect uname/passw.

    - another pc in the network (xp in my case) is able to login using the new uname.

    If you're in similar situation, then the reason is that changing the username as said above didn't actually change the username and seems to only set a full name for the same username. to change the actual username, you need to run "netplwiz " (start menu, then just type netplwiz and enter) which shows a different looking "user accounts" window similar to "control userpasswords2" in older versions of windows. You need to have all "user account" windows closed before running this. Then select your current username, then click on properties and change the "User Name" to the new value. Notice the full name being reported as what you were expecting to be the new username.

    • 回答としてマーク pjwilso 2010年3月31日 3:36
    • 回答としてマークされていない pjwilso 2010年3月31日 3:36
    • 回答の候補に設定 johnnypatras 2010年12月25日 19:32
    2010年3月29日 21:01
  • I found my own answer to this issue after I got acces to the machine physically and was able to view the security logs for the failed login attempts.  For some reason windows seven required that I use the entire computer name \\computer name\account name\ to get to the machine whereas Vista did not require full name.  Problem solved as long as I use the full name convention for the computer as expectedf behind the ts gateway.  Also don't pass the ts gateway credentials on to the remote computer as this causes it to want to log on with those creditials at the machine.    
    • 回答としてマーク pjwilso 2010年3月31日 3:47
    2010年3月31日 3:47
  • This doesn't seem to be the fix for me.  My Windows 7 machine is a member of an SBS 2003 domain.  I have added two domain accounts with the domain specified in the listing in "allow remote access".  I can either attempt this using remote web workplace or directly using remote desktop from another PC on the local network/domain, and I get the same results.  By the way, at the login screen I do specify the  domain\"user name".  It doesn't work. I know these credentials are correct.  I can login locally with no problem.  I thought there might be a problem with the firewall settings but this doesn't seem to be the case because I can't login on the local lan and the local domain either.  In firewall settings there is a place to allow or disallow access from various places such as locally, or public network.  At any rate, I would have thought that if it were a firewall issue I wouldn't have been able to get to a login screen from within  my remote desktop session at all.  I would really like to get an answer on this, I need to get remote access to this machine quickly.

    Thanks


    • 編集済み sasgad 2012年6月15日 14:53
    2012年6月15日 14:49
  • After fighting this problem for two nights (I was able to RDP into our server with no problem, but not my desktop even though both use the same username and password), I finally figured it out. 

    When you enter your user name from the computer you are using remotely, make sure the format is \computer name\account name\ BUT MAKE SURE YOU INCLUDE EVERY BACK-SLASH, INCLUDING AT THE END!!!!

    I did this over and over, and once I added the last back-slash, it worked. 

    Hope that helps you!

    2012年9月8日 2:55
  • I've been having a similar problem for which this fix seems to apply.

    We've been using rdesktop to connect to a Win7 laptop from a Win XP laptop.

    When we replaced the Win XP laptop with another new Win7 laptop, we could no longer connect using rdesktop.   We'd get as far as the login screen, but it would always report "user name or password is incorrect."

    After reading this thread, I recalled that the username on the original Win7 laptop had been changed some time ago.   We tried connecting with the original username, which no longer exists for login directly on the laptop, however that's what worked when connecting via rdesktop.

    I haven't tried usnig netplwiz yet to fix the internal username, but I think that will allow us to connect with the new user name once completed.

    2013年1月19日 23:24
  • Sahand, Thanks! I don't know how the hell you figured out that it was using the computer name instead of the user name, but it is greatly appreciated. I didn't feel like creating a new user name.
    2013年2月9日 1:50
  • If you're in similar situation, then the reason is that changing the username as said above didn't actually change the username and seems to only set a full name for the same username. to change the actual username, you need to run "netplwiz " (start menu, then just type netplwiz and enter) which shows a different looking "user accounts" window similar to "control userpasswords2" in older versions of windows. You need to have all "user account" windows closed before running this. Then select your current username, then click on properties and change the "User Name" to the new value. Notice the full name being reported as what you were expecting to be the new username.

    this worked ^

    • 編集済み suburbano 2014年7月2日 6:21
    2014年7月2日 6:20
  • Holy cow, that worked for me. WTF? LOl! Who woulda thunk you had to use the slashes. Windows strikes again!
    2015年6月19日 0:27
  • That Backslash at the end worked for me.  Thanks
    2016年2月1日 23:43
  • Just wanted to give you some props on sharing this. I never knew this and it works like a charm. Thanks!
    2016年6月23日 13:54
  • ^^^^ This Worked Great!  

    I renamed the original User name to some other name, and trying to log in to Windows Remote Desktop fails. 

    First I did this at https://support.microsoft.com/en-us/help/2454362/renaming-a-user-account-does-not-automatically-change-the-profile-path

    and still could not get Windows Remote Desktop to work, but then using netplwiz did WORK!!

    Thank You!

    2017年2月2日 3:25
  • It worked for me....Thanks a lot.... 
    2017年5月25日 5:19
  • Very old thread, but kudos to Sahand for providing the only correct answer. Windows is made by Msft so OF COURSE the user name you enter and log in with is not the actual user name. How silly of us not to figure this out...Another typical example of Msft bs that leads every pc user around the world to hope they go away and get replaced by a co that actually has a clue about user experience.


    2017年6月24日 23:55
  • Fantastic, just adding the backslash after my username worked. I am using a Mac and don't know why this started happening but this fixed it. Thank you
    2017年9月8日 20:21
  • Thanks a lot, it helped in my case
    2018年6月14日 8:20