none
Windowsインストーラが繰り返し表示される RRS feed

  • 質問

  • ウィルス対策ソフトのアップグレードを検証しています。

    Windows Vista SP1です。

    以前のバージョンのソフトに、グループポリシーオブジェクトを使用して新しいソフトを上書きインストールしています。

    コンピュータ起動時に「管理されているソフト[ソフト名]をインストールされています」と表示され、インストールが終わるとログオンします。

    ログオンすると通常はそれで完了するのですが、以下のような現象が発生しました。

    ・ログオン後、Windowsインストーラ画面が起動し、

      「windowsで[ソフト名]を設定しています。しばらくお待ちください。」

      というメッセージが表示されたまま進まない。キャンセルボタンを押しても、また出てくる。

    ・それが収まると、マイコンピュータを右クリックする度にWindowsインストーラが起動し、同じメッセージが表示される。

    ・Windows Installerサービスを停止しようとしたが、停止できない(ボタンが押せない)

    ・プログラムの追加と削除からソフトをアンインストールし、再インストールしようとしたができない。

    インストーラが常に起動して業務の邪魔になるため、非常に困っております。

    Windowsインストーラは何をしようとしているのでしょうか。確か、グループポリシーでのインストールはログオンしてから完了するので、最後にインストーラが何か残作業をしようとして失敗しているのでしょうか。XPでも同じ現象が発生しております。

    どなたかお分かりになる方はおりませんでしょうか。よろしくお願いいたします。

    2010年3月24日 11:48

回答

  • Nakatetsu さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ご質問の件に関しまして、問題の発生している環境では、イベント ログにエラーは記録されていませんでしょうか?
    もし記録されていましたら、その内容を詳しく教えていただけますと、何か手掛かりがつかめるかもしれません。 (^^)

    また、Nakatetsu さんが使用されているセキュリティ ソフトに関する具体的な情報をいただくことは可能でしょうか?
    もしかすると、「そのセキュリティ ソフトが更新プログラムの無人インストールに対応しているかどうか?」 といった点がカギになる可能性も考えられます。
    この可能性に関しましては、購入元にご確認いただくのが一番かと思われますが・・・

    まずは、上記の2点から確認されてみてはいかがでしょうか?
    こちらの情報がお役に立てることを願っています。
    それでは、また! (^_^)/


    _______________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2010年3月26日 6:32

すべての返信

  • Nakatetsu さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ご質問の件に関しまして、問題の発生している環境では、イベント ログにエラーは記録されていませんでしょうか?
    もし記録されていましたら、その内容を詳しく教えていただけますと、何か手掛かりがつかめるかもしれません。 (^^)

    また、Nakatetsu さんが使用されているセキュリティ ソフトに関する具体的な情報をいただくことは可能でしょうか?
    もしかすると、「そのセキュリティ ソフトが更新プログラムの無人インストールに対応しているかどうか?」 といった点がカギになる可能性も考えられます。
    この可能性に関しましては、購入元にご確認いただくのが一番かと思われますが・・・

    まずは、上記の2点から確認されてみてはいかがでしょうか?
    こちらの情報がお役に立てることを願っています。
    それでは、また! (^_^)/


    _______________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2010年3月26日 6:32
  • こんにちは、フォーラムオペレーターの三沢健二です。

    Nakatetsu さん、その後いかがでしょうか?

    今回、弊社 服部 のアドバイスが、多少でも参考になられたのではないかと思いましたので、勝手ながら [回答としてマーク] を付けさせていただきました。

    服部からもコメントがありましたように、インストーラーがどのような構成になっているかが分からないと的確なアドバイスは難しいと思われますので、もしよろしければメーカー等へご相談いただいた方が良いかもしれませんね。
    (複数の OS で同じ現象との事ですので、その構成のままでは自動インストールは難しいのかもしれません、、、)


    それでは、今後とも TechNet Forum をよろしくお願いします。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    2010年4月5日 1:50
    モデレータ