none
VMM2016 Permissions to access resource.

    全般的な情報交換

  • Hello

    I have a strange problem with VMM2016 U4.
    This is a all fresh installed setup, with only a few VM's running.. 
    I have a Cluster of two 2016 Hyper-V nodes with two CSV's with ReFS, everything is working fine in the Failover Cluster "Live Migration / Storage Migigration" and so forth.
    Problem is when I add the cluster to SCVMM2016, everything is good, no errors, i'm not able to create VM's or Migrate VM's and get the following error everytime.
    I have tryed adding the VMM User and Computer account as Local Administrator on Both Hyper-V servers, and on the Cluster, i have tryed setting permissions on the clusterstorage symlinks aswell, still no go.. 
    Allso checked CredSSP/WMI and i see no problem here.. 

    Hope someone can help me out.. :)

    Error (20552)
    VMM does not have appropriate permissions to access the resource 'C:\ClusterStorage\Volume1\' on the Hpvxxx server.


    Recommended Action
    Ensure that Virtual Machine Manager has the appropriate rights to perform this action. 

    Also, verify that CredSSP authentication is currently enabled on the service configuration of the target computer HpvTestClu01.hpv.local. To enable the CredSSP on the service configuration of the target computer, run the following command from an elevated command line: winrm set winrm/config/service/auth @{CredSSP="true"} 

    2018年4月5日 18:19

すべての返信

  • Hi Ez_henrik,

    First make sure that the password used by the VMMAgent Service Account is not expired and make sure the service account does not have the "User must change password at next logon" checked.

    How have you set up the VMM hosts management account?


    1. Create a VMM host management account in AD.
    2. Add that AD account to the local admin group on all your Hyper-V hosts.
    3. Add that AD account to your VMM as a Run As Account.
    4. Then while adding a new host to VMM, specify that run as account as the account to be used to add that hyper-V host.

    Kind regards,
    Leon


    Please remember to mark the replies as answers if they help.

    2018年5月4日 7:32