none
Exchange Server 2007 SP1の環境に SP2をインストールするも上手くいかない RRS feed

  • 質問

  • 初めて質問させていただきます。

    本番環境は Windows Server 2003 R2 x64 SP2 + Exchange Server 2007 SP1 Rollup9 なのですが、
    テスト用環境に Windows Server 2008 x64 SP2 + Exchange Server 2007 SP1 Rollup9 を準備し、
    Exchange 2007用の Service Pack2 の適用検証を行っております。

    が、上手くいかなくて困っております。
    なお、テスト用環境の サーバは MBXの役割のみ、別途HTとCASの役割は別のサーバに居ます。

    多分、SP2用のスキーマ拡張が必要っぽいので、 管理ユーザを Schema Admins / Enterprise Admins / Domain Admins などのメンバに加えてみました。
    ※ 最初に Exchange Organization Administrator の権限のみでしたが、エラーが出てしまったので、、、(権限不足というエラーではなかったかも)
      ServerManagerCmd  -i  RSAT-ADDS でADDS管理ツールも入れて(別のWin2008に入れていて、SP2テストしたサーバに入れていませんでしたので)

     揚句 多分初回のインストール失敗のせいか、レジストリ値に Watermarkと Actionが ついて「BuildToBuildUpgrade」はできないとも言われたので
     regiedit.exeで キーを削除して、、、

     ようやくセットアップが動き出したか と思ったのですが、、、
     メールボックスの役割の更新メータがほぼ完了に近づいたころ、「管理ツールのバージョンが最新ではないので役割の更新ができませんでした」という旨の
     メッセージが出てSP2摘要出来ませんでした。

     SP2に含まれる setup.com を使って
     setup.com  /mode:install  /role:ManagementTools
     とすると 旧いのがあるので出来ません、と怒られ、
     setup.com  /mode:uninstall  /role:ManagementTools
     とすると、メールボックスの役割があるので管理ツールをアンインストールできませんと怒られました。
     setup.com  /mode:upgrade  /role:ManagementTools
     もダメ元でやってみましたがやはり、そんなオプションは無く、、、

     このメールボックスの役割には既に有効なメールボックスがあります(テスト用ですが)
     これを残したまま SP2を上手く適用するには どうすればよいのでしょうか?

     何かご存じ方アドバイス頂けますと幸いです。
     よろしくお願いします。
    2009年9月1日 10:08

回答

  • どうも。
    なんだか上手く行きました。

    何度も何度も何度も何度も スナップショットを戻して Exchange Server 2007 SP1 の状態にして、再度SP2のセットアップを行って、、、
    ようやくそれらしき手順になりました。

    SP2 を うまく入れるには・・・と言いつつ 以下の手順は全て上手く行くことを保証するわけではないのでご注意ください。
    以下の手順に沿って実施した結果 環境が壊れた と言われても 私には何もすることが出来ません。
    保証できません。ご了承ください。

    1. SP2用のスキーマ拡張も やっぱりコマンドラインでやらないとダメっぽい。
       セットアップウィザード(GUI)で更新されているっぽいのですが、どうもこれも丁寧にコマンドラインでやらないと
       他のステップでエラーが出やすい模様。

       Enterprise Admins; Schema Admins; の権限を持つユーザで、 SP2に含まれる setup.com を使って

       setup.com /PrepareSchema  /DomainController:<FSMOのドメインコントローラ>
       setup.com /PrepareAD  /DomainController:<FSMOのドメインコントローラ>
       setup.com /PrepareDomain  /DomainController:<FSMOのドメインコントローラ>

       ※ これ以外は Enterprise Admins; Schema Admins; は不要で Exchange Oragnization Administratorと ローカルの Administrators で実施出来ました。

    2. Windowsファイアウォールのサービスは動かすけど無効にしとく。
      ※ Windows Server 2003は初期状態でWindowsファイアウォール動作していないので不要かも。
        Windows Server 2008では初期状態でWindowsファイアウォール動作しているので、動かしておかないとsetupに怒られます。

       > sc config mpssvc stgart= demand
       > sc start mpssvc
       > contol     ※ コントロールパネルの Windowsファイアウォールから 無効 にしておく。
       ※ Win2008 なら  firewallsettings で起動できるっぽい ついでにコマンドから変更方法分かれば良かったが 未確認。

       SP2のセットアップが Windows ファイアウォールの例外に Exchange関連のモジュールを追加する為、
       サービスが動いていないと前提条件確認で失敗し、 且つ 有効のままにすると レジストリ変更がファイアウォールにブロックされると言う
       間抜けっぷり、、、自分の設定が足りないだけかもしれませんが がっくりきました。

    3. レジストリエディタでレジストリを確認する。
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0
      AdminTools、ClientAccessRole、HubTransportRole、MailboxRole 以下にそれぞれ
      文字列 キー:ConfiguredVersion   値: 8.1.240.6
      文字列 キー:UnpackedVersion   値: 8.1.240.6
      があるのを確認する。無かったら作る。 ※ 8.1.240.6は Exchange 2007 SP1のバージョン表記なので、SP1も未適用なら数字が異なるはずである。
      SP1適用済み環境で間違いないなら、上記の値を入れる。 ※ SP1入れたのに別の値(例えばSP1無しの値になっているなら)この値に書き換える。
      ※ 念のため元の値をメモして取っておいてくださいね。ダメだったときに必要かもしれないですしね。
        v8.0以下のレジストリをエクスポートして避けておくのも良いでしょう。でも うっかり更新後に取り込まないでね、、、 拡張子.txtにしとけば安心。

      また、それぞれに キー Action または キー Watermark があったら、値が何であれ 削除する。

    4.HT / CAS から更新し、MBXは最後 (ここの記載には CCRやら SCCやらの構成は考慮していません。これらは別途手順が必要そうです)
      SP2に含まれていた setup.comを使います。

      setup.com /mode:upgrade /DomainController:<FSMOのドメインコントローラ>

      ちなみにこのタイミングで、
      ・「AdminToolsRoleが最新版ではない」 と怒られた場合、もしかしたら、レジストリを再度見直し、
       残ってしまった ActionとWatermarkを削除し、ConfiguredVersionを再設定して
       再度 setup.com 実行すると良いかも知れませんが、、、 検証環境中はなんだかダメでした。

      ・上記エラー後か、そうでないか、で「既定のグローバルアドレス一覧は既にあります」的な
       エラーが出てしまったら、解決方法は不明です。
       正味回避できなかったので、 スナップショット戻して環境戻してしまいました。
       本番環境で遭遇したくないな、、、、
       一説には ADSIEditとかで見れる 既定のグローバルアドレス一覧のオブジェクトに対する
       アクセス権が何か不足になっていて、セットアップ実行しているマシンから見えなくなってて
       無いと勘違いし、作成しようとしたら既にあるというエラーが検知されて出ているのかも?
       この説が本当なら、ADSIEditでセットアップ中のユーザアカウントか何かにアクセス権を
       付与したら回避できるのかもしれません。

    5.正常に完了したら、レジストリエディタで確認する。
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0
      AdminTools、ClientAccessRole、HubTransportRole、MailboxRole 以下にそれぞれ
      文字列 キー:ConfiguredVersion   値: 8.2.176.2
      文字列 キー:UnpackedVersion   値: 8.2.176.2
      となっていて、Action や Watermark が無い。

      ※ MBXに対して Upgradeがなかなかスムーズにいかない感じです。
        MBXの役割を持つサーバへのUpdateは十分なバックアップを取得してからが良いでしょう。

        一応この手順で、 私の検証環境中 MBX1は ついにエラーなしで更新完了。
        MBX2は残念ながら途中でエラーが出ましたが、 MSExchangeSA (System Attendant)が開始できない という
        サービス開始まで来ていたので、管理ツールのサービスで 関連サービスを確認し、Upgrade中に 無効 にされてしまう
        サービスが 自動 になっているのを確認し、サーバ再起動を実施しました。
        ※ サービスを手動で開始のみでは System Attendantがどういうわけかどうしても開始しない。
        サーバ再起動で 正常に全てのサービスが機能し、管理コンソールに表示されるバージョンも 8.2 (Build 176.2)
        となっていたのでOKなのだと思います。
        レジストリ的には AdminTools、MailboxRole 以下が
        文字列 キー:ConfiguredVersion   値: 8.1.240.6
        文字列 キー:UnpackedVersion   値: 8.2.176.2
        となっていまいた。きっとサービス開始までうまく行ってから ConfiguredVersionの書き換えが発生するのだと思うのですが。
        取りあえず動いているので、 手動で ConfiguredVersionを 8.2.176.2 に書き換え。
        また、途中停止のせいで Actionと Watermark が残ってしまったので手動削除。


    6.管理コンソールを起動し、サーバーの構成 を選択して中央ペインのサーバ一覧を確認する。
      バージョン表記が 8.2 (Build 176.2) になっていればOK。 のはず。

    7.必要に応じて Windows ファイアウォールを無効化。
      CASとMBX間、 MBXとクライアント間にファイアウォールあると良くないらしいので、私は無効化しました。
       > sc stop mpssvc
       > sc config mpssvc stgart= disabled

    8.メール疎通テスト


    そんな感じで なんとか再インストールとか 作業用サーバとかは取りあえず不要で済みそうです。

    2009年9月25日 11:47

すべての返信

  • 英語Forumも覗いてみますと、同様のエラーで Exchange 2007 SP2 インストールできないというスレが立っていますが、
    どうやら未解決の様子 orz...

    整理すると
     Windows 2003 または Windows 2008 に Exchange 2007  / SP1 がインストール済みの既存環境があり、
     これに SP2をインストール(インプレースアップグレード)する というのが上手くいかないっぽい。

     Exchange 2007が全くインストールされていない Windows Server 2003/2008 (R2除く) に
     Exchange 2007 SP2 をクリーンインストールするのは問題なさそう。

     有償サポートに問合せしたところ 「まず既存のExchange 2007をアンインストールして、 Exchange 2007 SP2をインストールする」
     というアクションが提示された模様であるが、、、かなり無理難題な気がしますね。
     新規導入ならまだしも、既存で本番運用中のサーバのアンインストールなんて論外な気がします。

     まさかのまさかで、 移行用のサーバを1台準備 (仮に WorkServer)して、以下のようなアクションが必要になるのでしょうかね、、、

     既存環境
     Mail-HTCAS-Svr    (Windows 2008 + Exchange 2007 SP1 HT+CAS)
     Mail-MBX-Svr    (Windows 2008 + Exchange 2007 SP1 MBX)

     これに
      WorkServer (Windows 2008 + Exchange 2007 SP2 HT+CAS)
     を入れて、何らかの手段で クライアント・ユーザに必要に応じて WorkServerを参照させる。

     Mail-HTCAS-Svr の Exchange 2007 SP1をアンインストール (HT+CAS+ManagementTool)
     Mail-HTCAS-Svr の Exchange 2007 SP2をインストール(HT+CAS+ManagementTool)
      結果として以下の構成にする
     Mail-HTCAS-Svr    (Windows 2008 + Exchange 2007 SP2 HT+CAS)
     何らかの手段で クライアント・ユーザに必要に応じて Mail-HTCAS-Svrを参照するように戻す。

      WorkServer の役割を入れ替える HT+CAS をアンインストール、 MBXをインストール
      WorkServer (Windows 2008 + Exchange 2007 SP2 MBX)の構成にする。
     メールボックスを Mail-MBX-Svrから WorkServerに移動する。

     Mail-MBX-Svr の Exchange 2007 SP1をアンインストール (MBX+ManagementTool)
     Mail-MBX-Svr の Exchange 2007 SP2をインストール(MBX+ManagementTool)
     メールボックスを WorkServerからMail-MBX-Svrに移動する。

     WorkServerの Exchange 2007をアンインストールして完了。

     メールボックス移動のアクションの段階で無い気がしますね、、、

     データベースのバックアップを取っといて、
     アンインストール & リストア
     Move-Mailbox -ConfigureOnly ?
     危険な感じがしますね、、、
     どうなのでしょう????
     
    2009年9月2日 10:49
  • 私は以下の環境

    ・2008 ActiveDirectory(GC)(A)
    ・2008 ドメインメンバーサーバー(B) + MBX
    ・2008 ドメインメンバーサーバー(C) + HUB + CAS

    という3台構成です。
    Exchange SP1 Rollup9 に対して、SP2 にアップグレードしてみました。
    Exchange のアップグレードでは、CAS、HUB の方を先に行うという方針がありますので
    (C)の方から SP2 へのアップグレードを行いました。
    Exchange SP2 ではスキーマ拡張(というか、Exchange 属性の変更)が一部あるようで
    (C)で SP2 の setup を実行すると、確かに、

    ServerManagerCmd -i RSAT-ADDS

    で Active Directory 管理ツールをインストールせよと言われます。
    それに従い、(C)にActive Directory 管理ツールをインストール(リブート必要)してから
    setup を実行すると、無事に SP2 にアップグレードできました。
    続いて、(B)で setup を実行すると、すでに(C)の SP2 へのアップグレードで
    スキーマ変更ができているので、Active Directory 管理ツールをインストールせよと言われることもなく
    無事に SP2 へのアップグレードができました。
    ...というわけで、私の環境では問題もなく SP2 へのアップグレードができました。

    SHIMSOFTさんの対策方法で、移行用のサーバーを経由するってことになると、少し厳しいですね。
    ただ、移行用サーバーを用意するなら、その 1 台に CAS、HUB、MBX の役割をインストールした後、
    ユーザーメールボックスを移行してから、既存の環境を切断して、SP2 で構築し直した方が手間が少ないです。
    あと、サーバー回復モード(setup /mode:recoverserver)を使うこともできるかもしれないです。

    有償サポートは、MS 内で再現環境ができないと、細かな部分を調べることができないので
    うまく回答がもらえないことがあります。(再現環境や条件がはっきりすれば、きちんと回答してもらえます)

    あまり役立つ情報ではなくてすみませんです。

    2009年9月7日 4:47
  • artglassさん、
     コメントありがとうございます。

    その後いくつか 思う節は有るものの都合により検証環境の電源が入れられない状態なので
    テスト継続できていなかったりなんかしています。

    再度検証環境利用可能となった時点で 今一度トライしてみます。
    2009年9月7日 6:56
  • ざっくり 続報 兼 状況整理 です。

    ・ Win2008 SP2 + Exchange 2007 HT+CAS SP1 Rollup 9
    ・ Win2008 SP2 + Exchange 2007 MBX SP1 Rollup 9

    検証環境内に 上記構成のサーバが 2セットあります。
    仮に HTCAS1, HTCAS2, MBX1, MBX2 と呼びます。

    1. HTCAS1 にて SP2用スキーマ拡張実施 ...ok
    2. HTCAS1 にSP2を適用 ...ok  ※ セットアップウィザードを使用して更新実施。
    3. MBX1 にSP2を適用 ...NG  ※ セットアップウィザードを使用して更新実施。
      前回と同じ「次の役割が最新ではないため、この役割をインストールすることはできません。AdminToolsRole 」が出て更新失敗。
       VMWareのスナップショットを復元して 2の状態に戻しました。

    3b. HTCAS2 にSP2を適用 ...ok  ※ セットアップウィザードを使用して更新実施。
    4. MBX1 にSP2を適用 ...NG  ※ セットアップウィザードを使用して更新実施。
      前回と同じ「次の役割が最新ではないため、この役割をインストールすることはできません。AdminToolsRole 」が出て更新失敗。

    5. MBX1で、レジストリエディタで Action と Watermark キーを削除。
      AdminTools のサブキー(ツリー)を AdminToolsOld に変更。

    6. setup.com /mode:upgrade
      構成がおかしいのでダメと怒られた。
       VMWareのスナップショットを復元して 3bの状態に戻しました。

    7. MBX1で、レジストリエディタで Action と Watermark キーを削除。
      setup.com /mode:recoverserver
      現在のインストールバージョンが古い(SP1)ので、このセットアップ(SP2)では出来ないと怒られた。
       VMWareのスナップショットを復元して 3bの状態に戻しました。

    8. MBX1で、レジストリエディタで Action と Watermark キーを削除。
      AdminTools のサブキー内のを ConfiguredVersion キーを ConfiguredVersionOld に変更。
      setup.com /mode:upgrade
      AdminToolsRoleで怒られず先に進んだ・・・ だがしかし

      「エラーが発生しました。エラー コードは 3221684226、メッセージは 指定されたファイルが見つかりません。 です。」
      と言うのがでました。
      レジストリを見ると、Mailbox Roleのバージョンを示すキーは新しくなっている・・・が
      AdminToolsRoleの ConfiguredVersion が設定されていないのでやはりだめなのだろう。

      setup.com /mode:install  /role:managementtools
      エラーが出てインストール失敗。

      このままもう一回、
      setup.com /mode:upgrade
      やっても同じエラーで止まり、
      setup.com /mode:RecoverServer
      やったら、MSFTE.MSIのバージョンとインストール済みモジュールのバージョンが異なるので
      操作続行できないと怒られた。
      setup.com /mode:upgrade
      やったら、 既に「既定のグローバルアドレス一覧」はあります。 というエラーになった。
      英語のフォーラムで 同じ表示出て困っている人がいるらしいが、結局これは現時点で回避手順不明なので
       VMWareのスナップショットを復元して 3bの状態に戻しました。

    9. そういえばセットアップログ見てない、、、という肝心な事を今さら思い出し、
       MBX1で、レジストリエディタで Action と Watermark キーを削除。
      AdminTools のサブキー内のを ConfiguredVersion キーを ConfiguredVersionOld に変更。
      setup.com /mode:upgrade
      「エラーが発生しました。エラー コードは 3221684226、メッセージは 指定されたファイルが見つかりません。 です。」
      と言うのがでました。
      ここで、セットアップログを確認しますと、

    [2009/09/17 2:26:49] [2] インタープリタ実行中: 行 <OpenMachineKey:SYSTEM\CurrentControlSet\Services\MSExchangeSA> -- ID:31259 --
    [2009/09/17 2:26:49] [2]  CInsParser::ScProcessLine (f:\08.02.0176\sources\dev\admin\src\libs\exsetup\hiddenw1.cxx:1199)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] ファイル 'C:\Program Files\Microsoft\Exchange Server\Setup\data\sa_reg.ins' の 64 行目またはその近くの行を処理しています (OpenMachineKey:SYSTEM\CurrentControlSet\Services\MSExchangeSA) -- ID:31111 -- CInsParser::ScProcessLine (f:\08.02.0176\sources\dev\admin\src\libs\exsetup\hiddenw1.cxx:488)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] Registry file name: 'C:\Program Files\Microsoft\Exchange Server\Setup\data\sa_reg.ins' CRegistryManager::ScProcessFile (f:\08.02.0176\sources\dev\admin\src\udog\setupbase\tools\regmgr.cxx:125)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] Filename = 'C:\Program Files\Microsoft\Exchange Server\Setup\data\sa_reg' CBaseAtom::ScRunRegistryFile (f:\08.02.0176\sources\dev\admin\src\udog\setupbase\basecomp\baseatom.cxx:1379)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] Leaving CBaseAtom(システム アテンダント サービス)::ScRunRegistryFile
    [2009/09/17 2:26:49] [2] Filename = 'C:\Program Files\Microsoft\Exchange Server\Setup\data\sa_reg' CBaseAtom::ScAddRegistryKeys (f:\08.02.0176\sources\dev\admin\src\udog\setupbase\basecomp\baseatom.cxx:1249)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] Leaving CBaseAtom(システム アテンダント サービス)::ScAddRegistryKeys
    [2009/09/17 2:26:49] [2]  CAtomSystemAttendant::ScAdd (f:\08.02.0176\sources\dev\admin\src\udog\exsetdata\components\server\a_systemattendant.cxx:217)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] mode = 'インストール' (61953) CBaseAtom::ScSetup (f:\08.02.0176\sources\dev\admin\src\udog\setupbase\basecomp\baseatom.cxx:535)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2]  ScSetupAtom (f:\08.02.0176\sources\dev\admin\src\udog\exsetdata\exsetds.cxx:897)
               Error code 0XC0070002 (2): 指定されたファイルが見つかりません。
    [2009/09/17 2:26:49] [2] Leaving ScSetupAtom
    [2009/09/17 2:26:49] [2] [ERROR] An error occurred. The error code was 3221684226. The message was The system cannot find the file specified..
    [2009/09/17 2:26:49] [1] The following 1 error(s) occurred during task execution:
    [2009/09/17 2:26:49] [1] 0.  ErrorRecord: エラーが発生しました。エラー コードは 3221684226、メッセージは 指定されたファイルが見つかりません。 です。
    [2009/09/17 2:26:49] [1] 0.  ErrorRecord: Microsoft.Exchange.Management.Deployment.ExsetdataException: エラーが発生しました。エラー コードは 3221684226、メッセージは 指定されたファイルが見つかりません。 です。
    [2009/09/17 2:26:49] [1] [ERROR] An error occurred. The error code was 3221684226. The message was The system cannot find the file specified..
    [2009/09/17 2:26:49] [1] Setup is halting task execution because of one or more errors in a critical task.
    [2009/09/17 2:26:49] [1] Finished executing component tasks.

    となんだか System Attendant関連のファイルが見当たらんと怒られているようですが、
    これってどうなんでしょうね、、、、、、、SP2のインストーラに含まれているファイルですよね、、、多分。

    というわけで、今一度 MSサイトから SP2をダウンロードし直しました。
    ・・・ 日本語サイトから落とすのと 英語サイトから落とすのと違っていたりするかしら?
    まだ英語サイトからダウンロードは試していないな、、、

    取りあえず日本語サイトから落とし直した SP2でもう一回やってみます。





    2009年9月17日 9:58
  • どうも。
    なんだか上手く行きました。

    何度も何度も何度も何度も スナップショットを戻して Exchange Server 2007 SP1 の状態にして、再度SP2のセットアップを行って、、、
    ようやくそれらしき手順になりました。

    SP2 を うまく入れるには・・・と言いつつ 以下の手順は全て上手く行くことを保証するわけではないのでご注意ください。
    以下の手順に沿って実施した結果 環境が壊れた と言われても 私には何もすることが出来ません。
    保証できません。ご了承ください。

    1. SP2用のスキーマ拡張も やっぱりコマンドラインでやらないとダメっぽい。
       セットアップウィザード(GUI)で更新されているっぽいのですが、どうもこれも丁寧にコマンドラインでやらないと
       他のステップでエラーが出やすい模様。

       Enterprise Admins; Schema Admins; の権限を持つユーザで、 SP2に含まれる setup.com を使って

       setup.com /PrepareSchema  /DomainController:<FSMOのドメインコントローラ>
       setup.com /PrepareAD  /DomainController:<FSMOのドメインコントローラ>
       setup.com /PrepareDomain  /DomainController:<FSMOのドメインコントローラ>

       ※ これ以外は Enterprise Admins; Schema Admins; は不要で Exchange Oragnization Administratorと ローカルの Administrators で実施出来ました。

    2. Windowsファイアウォールのサービスは動かすけど無効にしとく。
      ※ Windows Server 2003は初期状態でWindowsファイアウォール動作していないので不要かも。
        Windows Server 2008では初期状態でWindowsファイアウォール動作しているので、動かしておかないとsetupに怒られます。

       > sc config mpssvc stgart= demand
       > sc start mpssvc
       > contol     ※ コントロールパネルの Windowsファイアウォールから 無効 にしておく。
       ※ Win2008 なら  firewallsettings で起動できるっぽい ついでにコマンドから変更方法分かれば良かったが 未確認。

       SP2のセットアップが Windows ファイアウォールの例外に Exchange関連のモジュールを追加する為、
       サービスが動いていないと前提条件確認で失敗し、 且つ 有効のままにすると レジストリ変更がファイアウォールにブロックされると言う
       間抜けっぷり、、、自分の設定が足りないだけかもしれませんが がっくりきました。

    3. レジストリエディタでレジストリを確認する。
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0
      AdminTools、ClientAccessRole、HubTransportRole、MailboxRole 以下にそれぞれ
      文字列 キー:ConfiguredVersion   値: 8.1.240.6
      文字列 キー:UnpackedVersion   値: 8.1.240.6
      があるのを確認する。無かったら作る。 ※ 8.1.240.6は Exchange 2007 SP1のバージョン表記なので、SP1も未適用なら数字が異なるはずである。
      SP1適用済み環境で間違いないなら、上記の値を入れる。 ※ SP1入れたのに別の値(例えばSP1無しの値になっているなら)この値に書き換える。
      ※ 念のため元の値をメモして取っておいてくださいね。ダメだったときに必要かもしれないですしね。
        v8.0以下のレジストリをエクスポートして避けておくのも良いでしょう。でも うっかり更新後に取り込まないでね、、、 拡張子.txtにしとけば安心。

      また、それぞれに キー Action または キー Watermark があったら、値が何であれ 削除する。

    4.HT / CAS から更新し、MBXは最後 (ここの記載には CCRやら SCCやらの構成は考慮していません。これらは別途手順が必要そうです)
      SP2に含まれていた setup.comを使います。

      setup.com /mode:upgrade /DomainController:<FSMOのドメインコントローラ>

      ちなみにこのタイミングで、
      ・「AdminToolsRoleが最新版ではない」 と怒られた場合、もしかしたら、レジストリを再度見直し、
       残ってしまった ActionとWatermarkを削除し、ConfiguredVersionを再設定して
       再度 setup.com 実行すると良いかも知れませんが、、、 検証環境中はなんだかダメでした。

      ・上記エラー後か、そうでないか、で「既定のグローバルアドレス一覧は既にあります」的な
       エラーが出てしまったら、解決方法は不明です。
       正味回避できなかったので、 スナップショット戻して環境戻してしまいました。
       本番環境で遭遇したくないな、、、、
       一説には ADSIEditとかで見れる 既定のグローバルアドレス一覧のオブジェクトに対する
       アクセス権が何か不足になっていて、セットアップ実行しているマシンから見えなくなってて
       無いと勘違いし、作成しようとしたら既にあるというエラーが検知されて出ているのかも?
       この説が本当なら、ADSIEditでセットアップ中のユーザアカウントか何かにアクセス権を
       付与したら回避できるのかもしれません。

    5.正常に完了したら、レジストリエディタで確認する。
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0
      AdminTools、ClientAccessRole、HubTransportRole、MailboxRole 以下にそれぞれ
      文字列 キー:ConfiguredVersion   値: 8.2.176.2
      文字列 キー:UnpackedVersion   値: 8.2.176.2
      となっていて、Action や Watermark が無い。

      ※ MBXに対して Upgradeがなかなかスムーズにいかない感じです。
        MBXの役割を持つサーバへのUpdateは十分なバックアップを取得してからが良いでしょう。

        一応この手順で、 私の検証環境中 MBX1は ついにエラーなしで更新完了。
        MBX2は残念ながら途中でエラーが出ましたが、 MSExchangeSA (System Attendant)が開始できない という
        サービス開始まで来ていたので、管理ツールのサービスで 関連サービスを確認し、Upgrade中に 無効 にされてしまう
        サービスが 自動 になっているのを確認し、サーバ再起動を実施しました。
        ※ サービスを手動で開始のみでは System Attendantがどういうわけかどうしても開始しない。
        サーバ再起動で 正常に全てのサービスが機能し、管理コンソールに表示されるバージョンも 8.2 (Build 176.2)
        となっていたのでOKなのだと思います。
        レジストリ的には AdminTools、MailboxRole 以下が
        文字列 キー:ConfiguredVersion   値: 8.1.240.6
        文字列 キー:UnpackedVersion   値: 8.2.176.2
        となっていまいた。きっとサービス開始までうまく行ってから ConfiguredVersionの書き換えが発生するのだと思うのですが。
        取りあえず動いているので、 手動で ConfiguredVersionを 8.2.176.2 に書き換え。
        また、途中停止のせいで Actionと Watermark が残ってしまったので手動削除。


    6.管理コンソールを起動し、サーバーの構成 を選択して中央ペインのサーバ一覧を確認する。
      バージョン表記が 8.2 (Build 176.2) になっていればOK。 のはず。

    7.必要に応じて Windows ファイアウォールを無効化。
      CASとMBX間、 MBXとクライアント間にファイアウォールあると良くないらしいので、私は無効化しました。
       > sc stop mpssvc
       > sc config mpssvc stgart= disabled

    8.メール疎通テスト


    そんな感じで なんとか再インストールとか 作業用サーバとかは取りあえず不要で済みそうです。

    2009年9月25日 11:47
  • こんにちは、フォーラムオペレーターの三沢健二です。

    artglass さん、アドバイスありがとうございます。

    SHIMSOFT さん、詳細な検証報告ありがとうございます (^^)

    ご投稿された内容について、少し私の方でも調べてみましたが、残念ながら明確な情報は見当たりませんでした。。。

    ただ、こちらのスレッドは、同じような情報をお探しの方に、大変参考になるのではないかと思いましたので、勝手ながら私の方で [回答としてマーク] のチェックを付けさせていただきました。
    もし不適当であると思われた場合は、遠慮なくチェックを解除してくださいね。


    他にも何か情報をお持ちの方がいらっしゃいましたら、引き続き投稿いただければと思います。

    それでは、また何かありましたら、ぜひ TechNet フォーラムをご利用ください!
    今後ともよろしくお願いします。

    ______________________________________
    マイクロソフト株式会社 フォーラムオペレーター 三沢健二

    2009年10月7日 6:00
    モデレータ