none
Windows Process Activation Service がハングし、IISなど依存サービスが起動しない RRS feed

  • 質問

  • SharePoint 2010をインストールするべく、クリーンインストールした2008R2 STD(VMWare ESX上)にIISの役割と、
    アプリケーションサーバーの役割を追加したところ、
    役割のインストール時も再起動時も常にWindows Process Activation Serviceが「起動中」のままハングアップしてしまいます。

    イベントビューアのシステムログのエラー:「Windows Process Activation Service サービスは開始時にハングしました。」

    放置しておくと起動し、「Windows Process Activation Service サービスは 実行中 状態に移行しました。」となるまでおよそ20分前後かかります。
    該当の役割、役割サービス、機能をそれぞれ再インストールしても状況はかわりません。
    また、同一環境の別の2つのホストでもまったく同じ症状が出ています。

    Webを検索したものの該当の症状に対する方策は見つけられませんでした。
    考えられる原因や対策はありますでしょうか?

    • 移動 Robin_Ren 2012年10月2日 21:24 merge forum (移動元:Windows Server 2008 R2 全般)
    2010年8月18日 12:59

回答

  • ウイルスバスターコーポレートエディションが影響していました。

    Trend Micro WFP Callout Driver(tmwfp.sys)を無効にして再起動すると正常起動。
    ただし、デバイスドライバでこのドライバだけを無効にしても、再起動時に自動起動に戻ってしまうため、再起動の都度無効にする必要がある。

    バッチなどで以下の値を無効[4]に設定する。
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\tmwfp]
    "Start"=dword:00000002

    [PowerShell]
    Set-ItemProperty "HKLM:\SYSTEM\CurrentControlSet\services\tmwfp" -name "Start" -type DWORD -value 4

    これで当面の回避はできそうです。

    2010年8月19日 6:37

すべての返信

  • ウイルスバスターコーポレートエディションが影響していました。

    Trend Micro WFP Callout Driver(tmwfp.sys)を無効にして再起動すると正常起動。
    ただし、デバイスドライバでこのドライバだけを無効にしても、再起動時に自動起動に戻ってしまうため、再起動の都度無効にする必要がある。

    バッチなどで以下の値を無効[4]に設定する。
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\tmwfp]
    "Start"=dword:00000002

    [PowerShell]
    Set-ItemProperty "HKLM:\SYSTEM\CurrentControlSet\services\tmwfp" -name "Start" -type DWORD -value 4

    これで当面の回避はできそうです。

    2010年8月19日 6:37
  • かき さん、こんにちは。
    フォーラムオペレーターの三沢健二です。

    調査結果のご報告ありがとうございます!

    質問者さんご自身からの返信された内容ですが、同様のトラブルに遭遇された方に参考になる情報と思いましたので、勝手ながら [回答としてマーク] のチェックを付けさせていただきました。


    それでは、今後とも TechNet Forum をよろしくお願いします。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    2010年8月20日 1:23
    モデレータ