none
windows 2012 R2の”ProxySettingsPerUser”について RRS feed

  • 質問

  • こんにちは。

    どなたかご存知の方教えていただけないでしょうか。

    レジストリを操作して、Proxyサーバの指定をサーバ単位で設定し、ユーザ単位で操作できないようにしたいと考えております。

    具体的に以下の設定をしましたが、設定後にログインしてIE11で試してみるとプロキシにアクセスせずに、

    直接インターネットのサイトにアクセスしてしまいます。

    設定に間違いや足りない部分はありますでしょうか。ご存じの方ご連絡お願いいたします。

    ---------------------------------------------------------------------------------------------------------------------------

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\ProxySettingsPerUser

    を"0"

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet SettingsProxyEnable
    を"1"

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServer
    を'プロキシサーバ名:ポート番号',

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet SettingsAutoDetect
    を"0"

    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet SettingsProxyEnable
    を"1"

    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServer
    を'プロキシサーバ名:ポート番号',

    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet SettingsAutoDetect
    を"0"

    ---------------------------------------------------------------------------------------------------------------------------

    よろしくお願いいたします。

    ---------------------------------------------------------------------------------------------------------------------------
    ---------------------------------------------------------------------------------------------------------------------------
    ---------------------------------------------------------------------------------------------------------------------------
    2016年11月21日 8:21

回答

すべての返信

  • ProxySettingsPerUser を 0 に構成して再起動して、IE を「管理者として実行」して、プロキシを構成してみると良いでしょう。


    hebikuzure

    2016年11月21日 13:15
  • hebikuzure様

    ご返信ありがとうございます。

    いただいた説明通り、

    1. ProxySettingsPerUser を 0 に構成

    2. OSを再起動

    3. IEをAdministratorで開きプロキシを構成

    をしたところ、プロキシを利用しております。ありがとうございました。

    ただ、最初にお伝えしてなくで申し訳ないのですが、私としてはこの設定を

    PowerShell DSC経由でレジストリを設定して実現したいと思ってます。

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServerを設定してもプロキシを使ってくれなく、

    IEをAdministratorで開きプロキシを構成」するとプロキシを使ってくれるのは何故か知りたいと考えております。

    もし可能でしたらご教授いただけないでしょうか。

    以上、よろしくお願いいたします。

    2016年11月22日 4:31
  • > IEをAdministratorで開きプロキシを構成
    と、HKLM 配下のレジストリの構成とが同等ではないからでしょう。
    情報を調べれば出てくるかもしれませんが、「IEをAdministratorで開きプロキシを構成」の際の挙動を Process Monitor などで調べてみるという方法も考えられます。
    ご参考まで。


    hebikuzure


    2016年11月22日 6:38
  • hebikuzure様

    ご返信ありがとうございます。

    Process Monitorなどで調べてみます。


    2016年11月22日 7:52