none
WHS2011 -「ファイルまたはフォルダの復元」が81%で止まる- RRS feed

  • 質問

  • H340-S4にWHS2011をインストールして5台のPCのバックアップを行っています。

    WHS2011上で正常にバックアップされたクライアントPCの「ファイルまたはフォルダの復元」を試みたところ、メインで使っているPCのダッシュボードからアクセスした時のみ81%で止まってしまいます。問題のPCは、Windows7 Professional 64bitで、CPUはCore-i7 3770 3.40GHz, RAM 16GBです。 サーバー側の不具合を疑い、他のクライアントPC(Windows7 Professional 64bit, Windows7 Professional 32bit, Windows7 Home Premium 32bit, WindowsXP Professional 32bit)からも復元を試してみたところ、どれも1分かからずに成功します。あちこちのサイトで情報を探してみたのですが解決には至らず、こちらで質問させていただくことにしました。どのような原因が考えられるのか、そして、どのような対策が可能なのか、アドバイスいただけると幸いです。

    81%で停止

    なお、81%の状態で最大で半日放置しましたが、進捗はありませんでした。また、WHS2011上のどのクライアントPCでも決まって81%で止まるので、バックアップファイルが壊れているとか、そういう問題ではないと思います。ボリュームをマウントする段階でのエラーのような気がします。(Diskpart→AUTOMOUNT ENABLE等の措置も試してみましたがNGです。)よろしくお願いいたします。

    2013年3月26日 13:29

回答

  • すみません、事象を再度確認して良いですか?

    ・メインで使っているPCのダッシュボードからアクセスした時のみ81%で止まってしまいます。

    ・他のクライアントPCからも復元を試してみたところ、どれも1分かからずに成功します。

    ・また、WHS2011上のどのクライアントPCでも決まって81%で止まるので、

    とありますが、3点目は「メインPCのダッシュボードからリストアを試行した場合だけ、どのクライアントPCのイメージのリストアをしても81%で止まる」ということでしたでしょうか?「どのクライアントPCからメインPCのリストアを試行しても、81%で止まる」と勘違いをして受け取っていました。

    上記が正しいと、確かにクライアント側が疑わしいですね。追加で確認ですがメインPCではドライブレター Z は他のドライブ等で使われていますか?


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    • 回答としてマーク Masa_kyoto 2013年3月30日 4:03
    2013年3月29日 23:43
    モデレータ
  • ださっちさん:

    お問い合わせにお答えする前に……。ださっちさんの書き込みをヒントにいろいろいじっていましたら、ふとしたことから原因(らしきもの)が見つかり、バックアップが、これまで問題の出ていたクライアントPCでもマウントできるようになりました。解決したようです! 以下、顛末を書きます。

    まず、お尋ねの件ですが、その通りです。3点目は、1点目と2点目を補足するつもりで書いたのですが、かえって分かりにくくしてしまっていたようで、申し訳ありません。『・また、WHS2011上のどのクライアントPC【のバックアップ】でも【問題のある1台のクライアントPCから復元しようとすると】決まって81%で止まるので、』というふうに書くと、明確だったかも知れません。

    今日は、ださっちさんご指摘の「メインPCではドライブレター Z は他のドライブ等で使われていますか?」で思い当たる節があったので、調べました。

    まず、Zは使われてはいませんでしたが、Virtual Clone Driveという仮想CD/DVDマウント用ソフトが6つのドライブレターを使っていました。それを2つに減らしたり0にしたりして、バックアップの復元を試しました。結果はNGでした。

    次に、内蔵のカードリーダーが4つのドライブレターを使っていましたので、一度これを止めようと思いました。コントロールパネルの「デバイスとプリンター」を見た時、ふと気づいたのが、メインPCに「!」マークがついていたことです。「ハードウェア」で「!」のついていたのは「不明なデバイス Windows Server Solutions コンピュータ復元ドライバー」でした。「このデバイスのドライバーがインストールされていません。(コード28)」と表示されます。そこで、「ドライバーの更新」を試みました。オンラインではダメで、Cドライブを参照してドライバーを検索する設定にしたところ、無事ドライバーがインストールされました。その後、バックアップの復元をしますと、100%まで処理が終了し、無事Zドライブにバックアップイメージが復元されました。

    結局、復元に使われるドライバーが、何らかの理由で正常にインストールされていなかったことが今回の現象の原因だったようです。ださっちさん、MVPという称号をお持ちですが、フォーラムによるユーザー支援は全くのボランティアであると思います。ここまで懇切丁寧にお付き合い下さいましたこと、感謝しております。また、記述が至らなくて多大なお手間を取らせてしまったこと、お詫び申し上げます。

    今回は、大変ありがとうございました。

    • 回答としてマーク Masa_kyoto 2013年3月30日 4:03
    2013年3月30日 4:03

すべての返信

  •  お手数ですが、ログファイルをアップして頂けますか。

    ログファイルは、クライアントPCの C:\Users\All Users\Microsoft\Windows Server\Logs に保存されている MountBackup.log ファイルになります。

    ファイルは、私のSkyDriveフォルダーにアップして頂ければ、週末には見る時間が取れると思います。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2013年3月27日 13:18
    モデレータ
  • ださっち様:

    いつもお世話になります。大変基本的なことで申し訳ないのですが、……

    バックアップの復元で問題が起こるクライアントPCはWindows7 Professional 64bitなのですが、このPCのC:\Usersの中にはAll Usersというフォルダがありません。また、「MountBackup」でPC内を検索しましたところ、mountbackup.dllやMountBackupWizard.exe等は見つかるのですが、MountBackup.logというファイルは見つかりません。

    どうすればよいでしょう? お忙しいところ、お手数をおかけします。

    2013年3月27日 14:50
  • Masa_kyoto さま よろしく。

    補足します。

    %ProgramData%\Microsoft\Windows Server\logs のフォルダに保存されています。
    %ProgramData% は環境変数で、一般的には C:\ProgramData で設定されています。
      cmd.exe の set コマンドで確認できます。

    従って、以下のファイル名が フルパス名になります。

    C:\ProgramData\Microsoft\Windows Server\Logs\MountBackup.log

    注:C:\Users\All Users\Microsoft\Windows Server\Logs は私の Win7 HP x64 にも見当たりません。 

      しかし、どこかに接合ポイントがあるらしく、Dir "C:\Users\All Users\Microsoft\Windows Server\Logs" や

       C:\Users\All Users\Microsoft\Windows Server\Logs\MountBackup.log で Explorer 検索すると出てきます。

      フォルダ中の空白が検索の邪魔をしているようです。

    • 編集済み ShiroYuki_Mot 2013年3月27日 16:22 注釈を追補
    2013年3月27日 15:59
  • ShiroYuki_Motさん:

    補足の投稿をありがとうございます。お陰様でMountBackup.logを見つけることができ、ださっちさんのSkyDriveに無事アップロードできました。ださっちさん、ご査収よろしくお願いいたします。

    2013年3月27日 16:25
  • ログを確認しました。

    バックアップイメージを展開してボリュームを作成するところでこけているようです。作成完了すればマウントにいくのですが、マウントするところまで至っていませんので、バックアップデータベースの破損が疑われます。まず、バックアップデータベースの修復を試してみてください。

     これでだめならば、米国のフォーラムで公開されているTips(クライアントコンピューターバックアップフォルダー内の、Index.xxxx.dat ファイルを削除してから、上記の手順を実施する)を試してみてください。ただし、この場合はバックアップDBを破損する怖れがありますので、必ず事前にバックアップDBをバックアップしてから試してみてください。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2013年3月28日 13:33
    モデレータ
  • ださっち様:

    アドバイスいただいた「バックアップデータベースの修復」を実行する前に、質問させてください。

    1)「バックアップデータベース」は、サーバー上にあるものだと思います。5台あるクライアントPCのうち、1台のみでこの現象が起こっている(他のクライアントPCからは正常にバックアップが復元できる)ことから、私は、原因がクライアントPC側にあるものと考えていました。それでも「バックアップの修復」をすることで現象の解決が期待できますでしょうか。

    2)Index.xxxx.datファイルを削除することなくバックアップの修復を行う場合には、バックアップDB破損の怖れはありませんか。

    3)事前にバックアップDBをバックアップしてから……とのことですが、その具体的な方法は。

    以上の点を理解してから、試してみたいと思っています。サーバーに関して未熟者故、お手数をおかけいたしますが、よろしくお願いします。

    2013年3月28日 17:29
  • 1) バックアップデータベースはサーバー側にあるご認識は正しいですが、サーバー側には各クライアント毎にデータベースが作成されています。従って、サーバー上のバックアップデータベースのうち、特定のクライアントPCにおけるデータが不正となっている可能性があるため、アドバイスをしています。

    2)当該動作はWindows Home Server 2011 の標準的な操作です。これによるバックアップDB破損の怖れは非常に小さいと考えますが、担保は出来ません。不安であれば、バックアップをとってから行ってください。

    3) 具体的な方法は、他のHDD等にサーバー上の[クライアント コンピューター バックアップ]フォルダーをコピーするのみです。または、Windows Home Server 2011 の機能で、サーバーのバックアップ機能がありますから、[クライアント コンピューター バックアップ]フォルダーをバックアップする方法もあります。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2013年3月29日 10:58
    モデレータ
  • ださっちさま:

    毎回丁寧なご説明をいただき、ありがとうございます。今日、ご提案いただいた操作をしてみました。

    1)バックアップの修復・・・「何も問題は見つかりませんでした」ということで、1分もかからずに終了します。

    2)Index.xxxx.dat ファイルを削除してからバックアップの修復・・・この場合、処理に数時間かかりましたが、結果は「修復は正常に完了しました」ということで、詳細を見ると全てのコンピュータバックアップに緑のチェックマークが付いています。データを失うことなく、作業は終了したようです。

    1,2の後、「ファイルまたはフォルダーの復元」を試してみました。このお返事を書き始める前から放置していますが、やはり81%で止まっています。さらにできることがあるようでしたら、アドバイスをお願いします。

    2013年3月29日 16:59
  • すみません、事象を再度確認して良いですか?

    ・メインで使っているPCのダッシュボードからアクセスした時のみ81%で止まってしまいます。

    ・他のクライアントPCからも復元を試してみたところ、どれも1分かからずに成功します。

    ・また、WHS2011上のどのクライアントPCでも決まって81%で止まるので、

    とありますが、3点目は「メインPCのダッシュボードからリストアを試行した場合だけ、どのクライアントPCのイメージのリストアをしても81%で止まる」ということでしたでしょうか?「どのクライアントPCからメインPCのリストアを試行しても、81%で止まる」と勘違いをして受け取っていました。

    上記が正しいと、確かにクライアント側が疑わしいですね。追加で確認ですがメインPCではドライブレター Z は他のドライブ等で使われていますか?


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    • 回答としてマーク Masa_kyoto 2013年3月30日 4:03
    2013年3月29日 23:43
    モデレータ
  • ださっちさん:

    お問い合わせにお答えする前に……。ださっちさんの書き込みをヒントにいろいろいじっていましたら、ふとしたことから原因(らしきもの)が見つかり、バックアップが、これまで問題の出ていたクライアントPCでもマウントできるようになりました。解決したようです! 以下、顛末を書きます。

    まず、お尋ねの件ですが、その通りです。3点目は、1点目と2点目を補足するつもりで書いたのですが、かえって分かりにくくしてしまっていたようで、申し訳ありません。『・また、WHS2011上のどのクライアントPC【のバックアップ】でも【問題のある1台のクライアントPCから復元しようとすると】決まって81%で止まるので、』というふうに書くと、明確だったかも知れません。

    今日は、ださっちさんご指摘の「メインPCではドライブレター Z は他のドライブ等で使われていますか?」で思い当たる節があったので、調べました。

    まず、Zは使われてはいませんでしたが、Virtual Clone Driveという仮想CD/DVDマウント用ソフトが6つのドライブレターを使っていました。それを2つに減らしたり0にしたりして、バックアップの復元を試しました。結果はNGでした。

    次に、内蔵のカードリーダーが4つのドライブレターを使っていましたので、一度これを止めようと思いました。コントロールパネルの「デバイスとプリンター」を見た時、ふと気づいたのが、メインPCに「!」マークがついていたことです。「ハードウェア」で「!」のついていたのは「不明なデバイス Windows Server Solutions コンピュータ復元ドライバー」でした。「このデバイスのドライバーがインストールされていません。(コード28)」と表示されます。そこで、「ドライバーの更新」を試みました。オンラインではダメで、Cドライブを参照してドライバーを検索する設定にしたところ、無事ドライバーがインストールされました。その後、バックアップの復元をしますと、100%まで処理が終了し、無事Zドライブにバックアップイメージが復元されました。

    結局、復元に使われるドライバーが、何らかの理由で正常にインストールされていなかったことが今回の現象の原因だったようです。ださっちさん、MVPという称号をお持ちですが、フォーラムによるユーザー支援は全くのボランティアであると思います。ここまで懇切丁寧にお付き合い下さいましたこと、感謝しております。また、記述が至らなくて多大なお手間を取らせてしまったこと、お詫び申し上げます。

    今回は、大変ありがとうございました。

    • 回答としてマーク Masa_kyoto 2013年3月30日 4:03
    2013年3月30日 4:03
  • WHS_V1でも過去に何度か同様のドライバーの事例があったので、Zドライブが使用されていなければ次はドライバーの確認かなと思っていました(^_^;)
    [ソフト]Windows Home Serverのバックアップがマウントできません

    解決されて何よりです。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2013年3月30日 4:25
    モデレータ