none
[WHS2011] Lights-Outで久しぶりに起動したPCがずっと稼働中と認識されてしまう RRS feed

  • 質問

  • 1ヶ月ほど使用していなかったクライアントPCを起動すると、シャットダウン後もサーバー側でずっと起動中と認識され、Lights-Outによるスリープに移行しません。

    Lights-Outの稼働時間グラフを見ると、シャットダウンしているはずなのに、ずっと稼働中になっています。サーバーをRDPで再起動 or シャットダウンすると、クライアントPCの稼働時間グラフもその時点で終了扱いになります。ただ再度クライアントPCを立ちあげると、ずっと起動中の表示なります(連続してやると普通に動くこともあります)。

    やったこと

    クライアントPCのシャットダウン後、LANケーブルを抜いてみる。駄目でした。

    クライアントPCのLights-Outのアンインストールと再インストール。駄目でした。

    サーバー側からクライアントPCを削除。バックアップも削除。PCの名前を変更して、再登録。コネクタの再インストール。うまくいったように見えたのですが、また1ヶ月くらい後にクライアントPCを起動すると駄目でした。

    以前、日を開けずに使用してる分には問題なかったのですが、いつからか1ヶ月近くぶりに使用すると、Lights-Out or サーバーがうまく連動しません。連続して使用していると普通に動作することもあります。

    問題はどこら辺にあるのでしょうか?

    2012年10月12日 23:47

すべての返信

  • Lights-Outの最新バージョンは1.5.3.1805です。最新に更新されているか確認してください。
    http://www.homeserversoftware.com/

    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年10月13日 0:04
    モデレータ
  • Lights-Outのバージョンはサーバー・クライアントともに、1.5.3.1805になっています。ださっちさんのブログでアップデートの記事が掲載された日に更新しました。

    今、問題のクライアントPCを起動し、最近あったwindows updateを適用、再起動後、シャットダウンをしましたが、やはりLights-Outでの稼働時間グラフおよび、コンピューターで確認すると起動したままになっています。

    更にサーバーを再起動、Lights-Outで件のクライアントPCがOFFになっているのを確認後、再度クライアントPCを起動。手動でバックアップを実行後、シャットダウンしましたが、やはりLights-Outでは起動したままの認識になっています。

    Lights-Outはフリー版です。ちなみに別の年に2.3度しか電源を入れないような予備PCでも同じ現象が起きています。週に何度か使用するPCでは普通にLights-Outが動いています。

    サーバー内でのPC認識の問題なのか?Lights-Outの問題なのか?不明な状態です。


    • 編集済み ばらと 2012年10月13日 1:14
    2012年10月13日 1:10
  •  それでは、該当のクライアントでプログラムの追加と削除から、一度Lights-Outクライアントをアンインストールしてみて頂けますでしょうか。

    再起動後、自動でクライアントソフトがインストールされます。自動でインストールされない場合は、WHS2011の C:\ProgramData\Microsoft\Windows Server\Data\addins\msi\11f4bf0d-5474-4067-a24f-31b8805f3ee9 にクライアントインストーラーが保存されていますので、クライアントにコピーしてインストールしてください。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年10月13日 1:35
    モデレータ
  • Lights-Outクライアントをアンインストールしました。その時点で、サービスでLights-Outサービスがなくなっているのを確認し、シャットダウンしました。その状態で、別のクライアントPCからLights-Outを確認しましたが、コンピューター項目で、問題のクライアントPC(以下問題PC)はLights-Outが入ってると認識され、さらに稼働時間グラフも稼働し続けていると表示されています。

    その後、問題PCを再起動しましたが、自動でLights-Outがインストされないようなので、ご指示通りRDPして、そこからファイルを持ってきてx86版をインスト。サービスも再度追加されているのを確認しました。その後、シャットダウンしましたが、やはり稼働状態と認識されています。結局、サーバーを再起動しないと、問題PCの稼働の認識が解除されない状態です。逆に言うと、サーバーを再起動すると、稼働認識が解除されます。

    ちなみに問題PCはDELLのノートで、全く同じPC(CPUクロックがちょっとだけ違う)がもう1台あり、そちらは毎日使用していますが、問題なくLights-Outは動いています。

    以前、サーバー側からクライアントPCを削除。バックアップも削除。PCの名前を変更して、再登録。コネクタとLights-Outの再インストールをしたすぐ後は、一時的にうまくいきました。ただ、うまくいったように見えたのですが、また1ヶ月くらい後にクライアントPCを起動すると駄目でした。

    お手数おかけします。
    • 編集済み ばらと 2012年10月13日 2:25
    2012年10月13日 2:22
  • 追記

    今思い出したのですが、関係あるか分からないのですが、マスタブラウザというのでしったけ?それの設定がON(マスタブラウザになれる)にしてあります。理由はONにしないとBUFFALOなどが出しているメディアプレイヤーが使えなかったのでONにしました。毎回割り振り先?接続先?が変わって使い物にならなかったので。

    IPアドレスやPC識別に関係する項目なので、もしかしたら関係あるのでしょうか?

    前の起動から、次の起動までにかなり時間を空けたPCだと、どうもみんな同じ状態になっているようなので・・・


    • 編集済み ばらと 2012年10月13日 2:34
    2012年10月13日 2:33
  • 色々やってみたのですが、どうも駄目なようです。マスタブラウザの設定も、設定後も頻繁に使用していたときは普通に連動していたので、違いそうです。

    ただ気づいたのは、ダッシュボードの「コンピューターとバックアップ」の項目の一番左のPCアイコンでクライアントの稼働状況が分かりますが、あのアイコンもずっと稼働中と認識されていました。なのでLights-Outの問題ではなく、サーバーPC自体がクライアントを稼働中と認識し続けてしまっているようです。サーバー側でクライアントの切断を適切に行えていないようです。

    クライアント側も、最近はテストのため起動・終了を繰り返してみましたが、改善できませんでした。時間が空いて起動すると認識がおかしくなっているのではなく、どこか根本的におかしい部分があるのかもしれません。


    • 編集済み ばらと 2012年10月19日 22:50
    2012年10月19日 22:48
  •  Lights-Outをアンインストールした状態でも、WHS2011側のクライアントのオフライン/オンラインの認識が正しくない状態が再現しますでしょうか?

    クライアント側の日付と時刻は正しく合っていますでしょうか?試しにNTPサーバーと同期させて様子をみて頂けますでしょうか。

    オフラインのまま認識しない事例は結構あるのですが、ずっとオンラインのままという事例がなかなか見つからなくて、糸口を見いだせずにいます。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年10月20日 1:13
    モデレータ
  • 返信ありがとうございます。

    再度Lights-Outをアンインストールして、他のクライアントPCと問題のPC両方でダッシュボードを開いてみましたが、

    Lights-Outのコンピュータータグで、問題PCの「サーバーを常に監視」「グラフに表示」などにチェックが入ったままで、バージョン情報も出ておりLights-Outが未だにインストールされたままの状態として認識されているようです。また再起動後も再インストールをしていない状態で、Lights-Outがインストールされたままだと認識されています。

    NTPの方ですが、ちゃんと時間の同期は出来ていました(こちらはもともと同期用のフリーソフトを導入してました)。またBIOSの時刻もちゃんとあっていました。

    2012年10月20日 1:55
  • 追記

    サーバー側を再起動してみましたが、やはり問題PCのLights-Outはインストールされたままだと認識されっぱなしになっていました。

    2012年10月20日 2:02
  •  そうですか。サーバーとクライアントの間の認証に証明書を使っているので、日付がずれていると問題があるかと疑ったのですが。

    サーバー側のLights-Outがバージョンアップした際のアップデートは普段どのようにされていますか?一度アンインストール後に再度インストールされていますでしょうか?


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年10月20日 2:35
    モデレータ
  • サーバー側のLights-Outがバージョンアップした際のアップデートは、今回(一番最近の)はクライアントPCで実行すると出来るというのを初めて知ったので、クライアントPCでダブルクリックして、サーバー側のバージョン更新しました。それ以前はRDPで接続、サーバーPCのデスクトップに置き、実行したと思います。

    ただアンインストールは前回・今回のバージョン更新時に二度とも実行しなかったと思います。今回分はしていません。上書きではなく、アンインストールはした方が良かったのでしょうか?

    ちなみに今回のアップデート以前から問題は出ていました。


    • 編集済み ばらと 2012年10月20日 7:13
    2012年10月20日 7:12
  • Lights-Outのアップデートは、必ずサーバー側で従来のバージョンをアンインストールしてから行うようにしてください。
    そうしないと、クライアント情報を定義しているxmlファイルの古いバージョンなどが残って悪さをしてしまう場合があります。

    公式HPに記載してある通り、

    • クライアントとサーバー双方から古いバージョンをアンインストール
    • サーバーのダッシュボードを閉じる
    • サーバーに新しいバージョンをインストールする
    • ダッシュボードを開く
    • クライアント側にクライアントソフトをインストールする

    の順に実施してください。

    http://www.homeserversoftware.com/lo/whs2011/help/en/installation_updating_lightsout.htm

     これで改善されるか様子を見てみて頂けませんでしょうか。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年10月20日 7:30
    モデレータ
  • 教えていただいたようにやってみました。結果は3台ほどのPCでやってみましたが、クライアント側をアンインストしているのにダッシュボードで確認すると、Lights-Outがインストされたままと認識されてしまっているようです。具体的にはLights-Outの「コンピューター」タブにバージョン情報やらが残ったままになっています。稼働時間グラフにも、コンピューター名が残っていて、過去の稼働時間が表示されています。Lights-Outが完全にアンインスト出来ていないのか・・・それとも別な要因なのか。

    疑問

    1.サーバー側削除後のクライアント側削除というのは、全てのクライアントのLights-Outを削除してから、サーバー側を再インストすると言うことなのでしょうか?それともとりあえず、操作用のPCだけで良いのでしょうか?最終的には全てのPCのものをアンインストしますが・・・

    2.サーバーに新しいバージョンをインストするときは、クライアント側でLights-Outの実行ファイルをダブルクリックで実行で良いのでしょうか?それともRDPでサーバーに入ってサーバー内で実行が良いのでしょうか?

    3.Lights-Outは完全にアンインストールはできないのでしょうか?具体的にはLights-Outタブ内の最近記録されたイベントや稼働時間グラフ、コンピューターのIPアドレスなどが残ったままになっていて、アンインスト後、再インストするとそれらが復活します。これで正しいのでしょうか?

    わかりにくい状況で申し訳ありません。

    2012年10月20日 13:02
    1. 操作用だけで構いません。
    2. クライアント側からの操作で構いません。
    3. アドインのアンインストール完了後にサーバー側の C:\Documents and Settings\All Users\Application Data\LightsOut フォルダーを削除して下さい。

    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年10月21日 1:26
    モデレータ
  • 時間がたってしまって済みません。上記方法教えていただきありがとうございます。

    結局、普通に動いていたPC、問題のPC、半年間全く動かしていなかったPCと試してみました。

    サーバーからLights-Out削除、クライアントから削除。サーバーに再インストール、クライアントに再インストールの順で3台のPCでやってみたのですが。

    普通に動いていたPCはLights-Outがちゃんと連動。

    問題のPCと半年間全く動かしていなかったPCはLights-Outが連動せず、シャットダウン後も稼働中の認識のままでした。

    やはりコンスタントに起動させていないPCで現象が起こっているようです。

    結局、理由が全く分からなかったです。再インストしかないのかと・・・思い始めました。

    ださっち様、色々ありがとうございました。

    2012年10月27日 0:46
  • その後、問題PCでLights-Outの削除、サーバーから該当の問題PCを削除、同時にバックアップも削除しました。

    新たに問題PCのコンピュター名変更をしながらクライアントソフト・Lights-Outの再インストールを試みたところ、1週間試してみましたが、普通にLights-Outが連動するようになりました。しばらく放っておくとどうなるか分かりませんが、PCの削除まで行えば元に戻るようです。



    • 編集済み ばらと 2012年11月6日 14:03
    2012年11月6日 14:02