none
SharePoint Online クラシックUI環境でのCSS適用について RRS feed

  • 質問

  • SharePoint Online クラシックUI環境で注目のリンクへCSSを適用して、2段になるよう編集しようとしましたが、

    保存する前までは正しく反映されているのですが、保存後は適用される前の状態に戻ってしまい、正しく適用がされません。

    何か解決方法があれば教えてください

    2018年1月28日 23:54

回答

  • こちらの問題は、スクリプトエディタの埋め込みよりCSSを記述した後、Webパーツプロパティより適用行うことで正しく反映されました。

    2018年2月2日 7:10

すべての返信

  • こんにちは。

    内容からすると、Wikiページに直接CSSを記述しているように見受けられるですが合っていますでしょうか。
    その場合、保存時に自動的にタグが除去されてしまいますので、代わりにスクリプトエディターWebパーツを使用すればいけるのではないかと思います。

    2018年1月29日 0:39
  • anikizerosiki13 さん、こんにちは。
    フォーラム オペレーターの立花です。

    マイクロソフト コミュニティーでは情報がなかったためご投稿いただいたのですね。

    SharePoint Online クラシックUI環境でのCSS適用について
    https://answers.microsoft.com/ja-jp/msoffice/forum/msoffice_sharepoint-mso_winother-mso_o365b/sharepoint-online/c7bed8e3-4717-462d-acdb-ddb1b8a0ca65

    すでに Takashi Shinohara さんからご返信をいただいておりますので、
    ご参考いただき、ぜひお試しください。

    フォーラム利用時の注意点のお知らせです。

    ご利用の際は、下記内容をお守りいただきますと
    情報が寄せられやすくなりますので、ぜひご一読ください。
    ・フォーラムでご質問頂くにあたっての注意点
    ・フォーラムへの回答に関するガイドラインおよびフォーラム運営について(再掲)
    ご意見、ご要望はこちらのフォーラムまで。
    各種設定方法はフォーラム内を [かんたん フォーラム ガイド] で検索してみてください。


    参考になった投稿には回答としてマークの設定にご協力ください
    MSDN/TechNet Community Support 立花楓

    2018年1月29日 2:17
    モデレータ
  • 回答ありがとうございます。

    アドバイス通りスクリプトエディタを追加してこの中に記述しましたが、残念ながら変化がありませんでした。

    スクリプトエディタorコンテンツエディタのWebパーツを追加

    スクリプトエディタWebパーツを選び、埋め込みよりコード記述→同じく、正しく保存されない(保存後コードが消えているようです。

    スクリプトエディタWebパーツを選び、埋め込みよりライブラリにアップしたCSSファイルのリンクを記述→テキストでリンク名が記述されるだけで反映されない

    2018年1月30日 8:04
  • こちらの問題は、スクリプトエディタの埋め込みよりCSSを記述した後、Webパーツプロパティより適用行うことで正しく反映されました。

    2018年2月2日 7:10