none
フォーム認証にて500内部エラーが発生 RRS feed

  • 質問

  •  

    この度、sharepoint foundation 2010でActive Directoryユーザーをフォーム認証したいのですが

    web.configファイルを書き換え、サーバーの全体管理にアクセスする際ブラウザに500内部エラーと表示されてしまいます。

    イベントビューアにはエラーについて何も出力されておらず、インシデントを使用して技術サポートに問い合せても分からず仕舞いでございます。

    そこで以上のような事象に遭遇したことある方にお伺いしたいのですが、どのように対処しましたか?

    お知恵をお貸しいただきますよう、よろしくお願い致します。

     

    【環境】

    OS:windows server 2008 R2

    Sharepoint foundation 2010

    Active directory名:sharepoint-test

    ドメインコントローラ名:sharepoint-ad

     

    【ソースコード】

     

     

        <membership defaultProvider="AspNetSqlMembershipProvider">

          <providers>

            <add name="membership" type="Microsoft.Office.Server.Security.LdapMembershipProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" server="sharepoint-ad" port="389" useSSL="false" userDNAttribute="distinguishedName" userNameAttribute="sAMAccountName" userContainer="CN=Users,DC=sharepoint-test" userObjectClass="person" userFilter="(ObjectClass=person)" scope="Subtree" otherRequiredUserAttributes="sn,givenname,cn" />

          </providers>

        </membership>

        <roleManager enabled="true" defaultProvider="AspNetWindowsTokenRoleProvider">

          <providers>

            <add name="rolemanager" type="Microsoft.Office.Server.Security.LdapRoleProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" server="sharepoint-ad" port="389" useSSL="false" groupContainer="CN=Users,DC=sharepoint-test" groupNameAttribute="cn" groupNameAlternateSearchAttribute="samAccountName" groupMemberAttribute="member" userNameAttribute="sAMAccountName" dnAttribute="distinguishedName" groupFilter="((ObjectClass=group)" userFilter="((ObjectClass=person)" scope="Subtree" />

          </providers>

        </roleManager>

     

      </system.web>    ← *一番最初の"</system.web>"です

    【わかっていること】

    <membership>~</membership>を書いても正常に表示されます

    <roleManager >~</rolemanager>の<add>を書かないと正常に表示されます

    <roleManager>の<add   ~ />を書くと500内部エラーが起きます。

     

    以上、よろしくお願いいたいます

     

    2011年2月25日 11:01

すべての返信

  • takuro147 さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    投稿ありがとうございます。

    「HTTP 500 内部サーバー エラー」を経験された方は多いと思うのですが、原因もさまざまなので
    これがという情報を提供できないのではないでしょうか。
    よろしければ可能な範囲で、takuro147 さんがサポートに問い合わせた際に確認した事項をお知らせいただけると こちらの事象を理解する手がかりになると思います。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    2011年3月1日 2:36