none
「集計値」列の式にID列を指定した場合、値が正しく表示されない RRS feed

  • 質問

  • こんにちは

    カスタムリストに「集計値」列を追加して、システム列の「ID」列を表示するため、式に「=ID」と入力しました。
    アイテムを登録しても「集計値」列には「0」と表示され「ID」列の値が正しく表示されません。

    列の設定画面を一旦開いて「OK」を押すと「集計値」列に「ID」列の値が入っています。
    再度アイテムを登録すると「集計値」列には「0」と表示されます。

    不具合の原因および解決方法はありますでしょうか?

    ・動作環境
    Server:Windows 2003 R2、SharePoint 2007 SP2
    Client:Windows SEVEN

    何らかのヒントになるような情報があれば、ご教示頂ければと思います。

    よろしくお願いいたします。


    2011年4月14日 9:54

回答

  • ichigo5657 さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    ichigo5657 さんと同様の疑問をもたれた方のサイトがありました。
    残念ながら、「ID」列を「集計値」列の計算式に含んだ場合に正しく計算できないようです。

    ・Microsoft SharePoint Serverの「集計値」列の再計算はいつされる?:
    http://d.hatena.ne.jp/jjs/20070117/p1

    ・Did you resolve this?:
    http://www.office-outlook.com/outlook-forum/index.php/m/660715/

    同様にKateR さんも集計値列でID 列が計算されない理由を述べてます。
    (Kathy,The reason that you cannot use this as a calculated field formula is..)

    ご参考になれば幸いです。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    • 回答としてマーク 服部清次 2011年4月27日 8:38
    2011年4月21日 5:03

すべての返信

  • ichigo5657 さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    ichigo5657 さんと同様の疑問をもたれた方のサイトがありました。
    残念ながら、「ID」列を「集計値」列の計算式に含んだ場合に正しく計算できないようです。

    ・Microsoft SharePoint Serverの「集計値」列の再計算はいつされる?:
    http://d.hatena.ne.jp/jjs/20070117/p1

    ・Did you resolve this?:
    http://www.office-outlook.com/outlook-forum/index.php/m/660715/

    同様にKateR さんも集計値列でID 列が計算されない理由を述べてます。
    (Kathy,The reason that you cannot use this as a calculated field formula is..)

    ご参考になれば幸いです。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    • 回答としてマーク 服部清次 2011年4月27日 8:38
    2011年4月21日 5:03
  • ichigo5657 さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ichigo5657 さんがこちらの質問を投稿されてから少し経ちましたが、
    弊社の星睦美の回答はご確認いただけましたでしょうか?

    今回 弊社の星が紹介しました情報はちょっと残念な内容だったかもしれませんが、、、
    1つの情報として参考にしていただけるのではないかと思いましたので、
    勝手ながら、私の方でいったん [回答としてマーク] させていただきました。

    また何か疑問や質問などがありましたら、ぜひ TechNet フォーラムをご利用ください。
    今後とも、よろしくお願いします。
    それでは、また。


    __________________________________________________
    日本マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2011年4月27日 8:39
  • 確かに不具合ではないですねー

    ID列は、保存されるまで、確定しないので、保存した後にワークフローか、イベントシンクでID列からコピーするしかないですね。

    私はそのようにしてます、

     


    Blog:http://blog.sharepointissue.com HP:http://www.piecepoint.jp/
    2011年6月4日 16:59