none
一度IEを起動しないとプロキシの設定が反映されません RRS feed

  • 質問

  • ドメインのグループポリシーでプロキシの設定(ログオンスクリプトでレジストリにプロキシの値を書き込むorグループポリシーの基本設定でプロキシを設定)をした際、一度IEを起動するまでプロキシの設定が反映されないことはありませんか?

    仕事柄共用PCの展開作業をよくやっているのですが、初回ログインユーザーでchromeがネットに繋がらない、officeのオンライン機能(イメージのオンライン検索やオンラインテンプレート等)が使えないという報告を頂くことがあります。

    そして、どのケースでも「プロキシサーバーの設定がしてある」「一度でもIEを起動すれば現象が再現されない」という共通点があります。

    chromeの「chrome://net-internals/#proxy」でプロキシ設定の挙動を見ていたのですが、やはりIEを起動するまではプロキシの設定が反映されておらず、プロキシの設定が原因でchromeがネットに繋がらないのは明白です。

    ただしレジストリの値を見ると、ちゃんと設定した値が書き込まれているのが確認できます。

    これは構築方法の問題なのでしょうか?それともWindowsの仕様の問題?

    原因や解決方法など、何か情報を持っておられる方がいましたら教えて頂けると幸いです。

    ちなみにWindows8のフォーラムで質問させて頂いていますが、7の64bit Proffesionalでも同様の現象を確認しております。

    よろしくお願いいたします。

    2015年11月9日 2:06

回答

すべての返信

  • レジストリに直接書き込んでもwininetが新しいレジストリ設定に気づいてない(=設定を読み込まない)という可能性が考えられるので、
    レジストリ書き込みではなく、wininetの下記APIを呼び出すプログラムかスクリプトを作成して試してみてはどうかと思います。
    違っていたら、すみません。

    InternetSetOption function
    https://msdn.microsoft.com/ja-jp/library/windows/desktop/aa385114%28v=vs.85%29.aspx

    2015年11月9日 11:37
  • チャブーンです。

    私もy-yamasakiさんのコメントに同意します。プロキシ設定を認識させるスクリプトですが、現状では簡単に見つけられないようです(先に書いた内容はレジストリの変更のみでInternetSetOption function()の読み込みは行っていません)。

    対象となる情報があれば追記させていただきますが、バックグラウンド(ウインドウが表示されないかたち)でiexplore.exeを開く、という対応が現実的なのかもしれません。

    追記:確認したところ、したのページに「インターネットオプションのリロード」を行うためのスクリプトがあるようです。

    http://superuser.heapoverflow.me/question-windows-7-disable-proxy-via-cmd-and-put-in-effect-710921


    フォーラムは有償サポートとは異なる「コミュニティ」です。フォーラムでご質問頂くにあたっての注意点 をご一読のうえ、お楽しみください。



    2015年11月10日 8:15
  • oooohです。

    Chrome用のGPO拡張を使った方が楽かも?

    Chrome用GPO拡張

    ※GPO拡張を使用して直接Proxy指定するという意味です。
    • 編集済み ooooh 2015年11月11日 6:38 注追記
    • 回答の候補に設定 チャブーンMVP 2015年11月17日 8:21
    • 回答としてマーク 佐伯玲 2015年11月20日 2:36
    2015年11月11日 6:37
  • こんにちは、maccha_maccha さん
    フォーラムオペレータの佐伯 玲 です。

    その後の状況はいかがでしょうか?
    皆さんからご参考になりそうな情報が寄せられておりますので私のほうから「回答としてマーク」とさせていただきますね。

    お試しいただけましたらご返信くださいませ。

    宜しくお願い致します。

    TechNet Community Support 佐伯 玲

    2015年11月20日 2:35
  • 返信して頂いた皆さま、ありがとうございました。

    こちらの返事が遅くなってしまい申し訳ございませんでした・・・

    結局、ChromeのGPOを使うことで問題は解決いたしました。

    2016年7月5日 7:08