none
ApplicationPoolIdentity で認証エラーが発生する。 RRS feed

  • 質問

  • お世話になっております。

    ApplicationPoolIdentityを使用してASP.NET4.0のASP.NETアプリケーションを構築したところ、

    以下のような事象が発生しました。NetworkServiceに変更して暫定対処としておりますが、

    妥当な設定であるのかが不明確な状態であります。

    類似の事象がございましたら情報提供頂けると幸いです。

    ■環境

    サーバOS:Windows Server 2008 R2 Standard

    アプリケーション:ASP.NET 4.0

    認証方式:統合Windows認証のみ

    ■事象

    アプリケーションプールのIDにApplicationPoolIdentityを設定したアプリケーションプールを停止・開始した後、

    ブラウザからアクセスした場合、認証ダイアログが表示され続け、エラー画面が表示される。

    アプリケーションプールのIDをNetworkServiceに設定すると、認証ダイアログは表示されずにWebアプリケーションが起動する。

    また、IDがApplicationPoolIdentityの場合でも、サーバ自体を再起動すると、認証ダイアログは表示されずにWebアプリケーションが起動する。

    ご教授頂ければ幸いです。

     


    masuda
    2011年6月8日 14:24

回答

  • masuda_benest さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    アプリケーションプールのIDにApplicationPoolIdentityを設定した場合、認証を求められるようになります。
    表示されるエラー画面の内容が質問からはわかりませんが、ApplicationPoolIdentity に関しては以下の情報が設定の参考になりそうです。

    (参考情報)
    ・[アプリケーション プール ID] ダイアログ ボックス:
    http://technet.microsoft.com/ja-jp/library/cc731981(WS.10).aspx

    ・Ensure Security Isolation for Web Sites: (英語)
    http://learn.iis.net/page.aspx/764/ensure-security-isolation-for-web-sites/

    上記ページのCompatibility Issues with Application Pool Identities の内容が関連あるのではと思います。

    こちらの情報がmasuda_benest さんのお役に立ちましたら幸いです。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    • 回答としてマーク 服部清次 2011年7月6日 9:37
    2011年6月13日 7:28

すべての返信

  • masuda_benest さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    アプリケーションプールのIDにApplicationPoolIdentityを設定した場合、認証を求められるようになります。
    表示されるエラー画面の内容が質問からはわかりませんが、ApplicationPoolIdentity に関しては以下の情報が設定の参考になりそうです。

    (参考情報)
    ・[アプリケーション プール ID] ダイアログ ボックス:
    http://technet.microsoft.com/ja-jp/library/cc731981(WS.10).aspx

    ・Ensure Security Isolation for Web Sites: (英語)
    http://learn.iis.net/page.aspx/764/ensure-security-isolation-for-web-sites/

    上記ページのCompatibility Issues with Application Pool Identities の内容が関連あるのではと思います。

    こちらの情報がmasuda_benest さんのお役に立ちましたら幸いです。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    • 回答としてマーク 服部清次 2011年7月6日 9:37
    2011年6月13日 7:28
  • masuda_benest さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    masuda_benest さんがこちらの質問を投稿されてから少し経ちましたが、その後の状況はいかがでしょうか?
    弊社の星睦美が紹介しましたリンク情報はご確認いただけましたでしょうか?

    masuda_benest さんの現在の状況が気になるところなのですが、、、今回、参考情報として弊社の星の回答を役立てて
    いただけるのではないかと思いましたので、勝手ながら、私の方でひとまず [回答としてマーク] させていただきました。

    もし masuda_benest さんの疑問がまだ解消されていない場合は、もちろんこのまま質問を続けていただくことも可能ですので、
    その際にはお気軽に [回答としてのマークの解除] をクリックして返信してください。

    なお、現時点でご提供いただいている情報だけではちょっと状況が見えにくいところがありますので、、、返信の際には正確な
    エラー メッセージの内容などもご提供いただけますと、他の回答者の方々もイメージしやすくなるのではないかと思います。

    今後とも、TechNet フォーラムをよろしくお願いします!
    それでは、また。


    __________________________________________________
    日本マイクロソフト株式会社 フォーラム オペレーター 服部 清次


    2011年7月6日 9:40
  • 星様、服部様、

    情報提供頂きましてありがとうございます。

    また、回答が遅くなりまして申し訳ございません。

    現状としましては、NETWORKSERVICEに設定したままとなりそうな状況です。

    ご提供いただきました情報を参照させて頂きました。

    ユーザプロファイル作成関連について記述されているように見受けました。

    英文読解力の無さもあるかと思いますが、具体的にどのように設定するべきなのかまでは読み取れませんでした。

    エラーメッセージに関しましては、サーバ上のイベントログ等からは発見できず、

    ブラウザ上で権限エラーが表示されるのみとなっておりました。

    提供できる情報が少ないので申し訳なかったですが、以上が現状報告となります。

     


    masuda
    2011年7月6日 13:06