none
MOSS2007+Windows 2008, NTLM認証にて、FQDNでアクセスしたときに認証情報が通らない RRS feed

  • 質問

  • MOSS 2007 をWindows Server 2008にインストールしました。ドメイン環境、単一マシンにファーム構成です。
    MOSSにサービスパックなどはまだ当てていない状態です。

    NTLM認証がかかった管理サイトおよび作成したWebアプリケーションサイトにアクセスをする際に、
    どうにも認証情報が通ってくれません。
    ユーザー名とパスワードは正しいです。

    症状は以下のとおりです。

    ・ 管理サイトに http://servername:port/ でアクセスした場合は、通常通り認証されてページにアクセスできます。
    ・ 代替アクセスで設定したURL http://cp.contoso.com/  をつかって管理サイトにアクセスすると、ブラウザに認証用ダイアログは表示されますが、正しい情報を入力しても、再度ダイアログが表示されるばかりで、ページにアクセスできません。
    ・ この現象は、管理サイトのみならず同じようにFQDNを使用したサイトすべてで発生します。 http://app1.contoso.com/ , http://www.contoso.com など。
    ・ 他のクライアントPCからアクセスした場合はこの現象は起こりません。MOSSがインストールされたWindows 2008 からアクセスするときのみ発生します。
    ・ NTLM認証のときのみ発生します。基本認証(併用)にすると通常通りアクセスができます。
    ・ cp.contoso.com, www.contoso.com など、要求したインターネットドメインは、すべてこのマシンのIPアドレスを正しく指しています。
    ・Windows 2003 にインストールしたときには、この現象は確認されませんでした。


    技術情報、インターネット上などをここ2週間ほど調べましたが、これと同じ現象は確認できませんでしたので、
    どなたか知っている方は教えていただけないでしょうか。よろしくお願いします。

    2009年5月9日 15:29

回答

  • nakaz さん、こんにちは。

    MOSSにSP1を適用していない点が引っ掛かります。
    昨年のTechEdでもらったセッション資料によるとSP1の新機能として
    「Windows Server 2008 と インターネット インフォメーション サービス (IIS) 7 のサポート」
    と書いてあります。

    また、Windows Server 2008ということなので当たらないかもしれませんが
    FQDN または、コンピュータ名と一致しないカスタム ホスト ヘッダーを使用している場合、
    ループバック チェック問題が発生することがあるという記述を見つけることが出来ました。
    これも参考までに付け加えておきます。

      896861  (http://support.microsoft.com/kb/896861/ ) 統合認証を使用してされ
      IIS 5.1 または IIS 6 でホストされている Web サイトを参照するとエラー 401.1 が表示されます。

    まずは、MOSSのSPを適用したほうがよいように思います。
    • 回答としてマーク nakaz 2009年5月25日 14:32
    2009年5月12日 0:56

すべての返信

  • nakaz さん、こんにちは。

    MOSSにSP1を適用していない点が引っ掛かります。
    昨年のTechEdでもらったセッション資料によるとSP1の新機能として
    「Windows Server 2008 と インターネット インフォメーション サービス (IIS) 7 のサポート」
    と書いてあります。

    また、Windows Server 2008ということなので当たらないかもしれませんが
    FQDN または、コンピュータ名と一致しないカスタム ホスト ヘッダーを使用している場合、
    ループバック チェック問題が発生することがあるという記述を見つけることが出来ました。
    これも参考までに付け加えておきます。

      896861  (http://support.microsoft.com/kb/896861/ ) 統合認証を使用してされ
      IIS 5.1 または IIS 6 でホストされている Web サイトを参照するとエラー 401.1 が表示されます。

    まずは、MOSSのSPを適用したほうがよいように思います。
    • 回答としてマーク nakaz 2009年5月25日 14:32
    2009年5月12日 0:56
  • >rabys 様

    ありがとうございます。

    後から気がつきましたが、MOSSは 2007 with SP1 でした。つまり最初からSP1は当たっていたようです。

    http://support.microsoft.com/kb/896861/
    の件ですが、たぶんこれに当たると思います。症状的にはドンぴしゃです。

    ループバックアドレスというから、127. かと思っていたら、要は自分自身ということですね。
    まだ解決には至っていませんが、貴重な情報をありがとうございました。

    ちょっと後になりますが、試してみますね。

     

    2009年5月12日 12:12
  • とりあえず、レジストリの変更はしないことにしました。
    よって、本当に解決するかどうかには至りませんでした。

    rabys様
    非常に的確な情報をくださって、ありがとうございました。

    2009年5月25日 14:33