none
windows Storage Server 2012 から2016への移行ツールについて RRS feed

  • 質問

  • 現在、windows Storage Server 2012rからwindows Storage Server 2016へ「Windows Server 移行ツール」を利用して

    [ユーザーとグループの移⾏]を実行しようとしてますが、インポート側で「Windows Server 移行ツール」を

    実施した際に、以下のエラーが表示されます。

    <エラー内容>

    Import-SmigServerSetting : 移行操作を実行できません。移行元サーバーと移行先サーバーの Windows Server 移行ツールのバージ
    ョンが異なります。移行元サーバーと移行先サーバーで、同じバージョンの Windows Server 移行ツールを使用してください。

    上記の内容通りだと、移行元サーバーと移行先サーバーのバージョン情報を取得する方法が分かりません。

    また、2012rから 2016への移行は移行ツールでは出来ないのでしょうか。

    その他に、[ユーザーとグループの移⾏]について解決方法がございましたらご教授願います。

    何卒、宜しくお願い致します。

    2019年9月9日 3:47

回答

  • フォーラムにご投稿くださいましてありがとうございます

    この後の状況はいかがでしょうか。

    皆さんから寄せられた投稿はお役に立ちましたか。


    ご不明な点がございましたら、お気軽にお問い合わせください

     

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月16日 7:12
    モデレータ
  • Mr.Spock 様

    ご連絡が遅くなり大変申し訳ございません。

    ご指摘の通り、本来であれば「W12R2」を指定するのですが、エラーが出てしまいます。
    エラー内容は保存しておらず、その後サーバーをリカバリーし再度、設定した所

    移行先で、移行ツール作成が完了しました。

     移行元 WS12R2 移行先 WS16

     <移行先>
      cd C:\Windows\System32\ServerMigrationTools
      smigDeploy.exe /package /architecture amd64  /os WS12R2/path <移行先>Dドライブ内

    ご指摘ありがとうございます。
    しかしながら、その後移行元に「移行ツールフォルダ」を張り付け、フォルダ内のSmigDeploy.exeを実行した所

    Windows PowerShellが一瞬起動後、「前提を確認します」の表示が出た後に、 
    プログラム終了表示がされ閉じてしまいます。 

    これは、前回の移行元で行った、SmigDeploy.exeが邪魔をして 
    実行できないのでしょうか。 

    その場合、一度解除を行うにはどのような対応を行えばよいでしょうか。 

    情報としてSmigDeploy.logログ内容を記載いたします。

    ログ内容:SmigDeploy.log(移行元)

    Error (Id=0) 現在、Windows Server 移行ツールの別のコピーがこのコンピューターに登録されています。
     次のコマンドを実行して、Windows Server 移行ツールの既存のコピーを登録解除してください:
     C:\Windows\System32\ServerMigrationTools\SmigDeploy.exe /unregister
     その後、新しい展開ディレクトリ内で登録コマンドを再度実行し、Windows Server 移行ツールのコピーを登録して使用してください。 

     2019-09-17 12:02:41.501 [SmigDeploy]     Registering
     2019-09-17 12:02:41.563 [SmigDeploy]     Register - check to see if the snap in reg key has already been existed

    念の為、下記のコマンドを実行しましたが添付のエラーとなります。

    C:\Windows\System32\ServerMigrationTools\SmigDeploy.exe /unregister

    大変、恐縮ですが原因と対応等がございましたらご教授ください。 

    何卒、宜しくお願い致します。

    • 編集済み onishiGI 2019年9月17日 7:09 情報の追記
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月17日 4:37
  • Windows erver 2012R2の「サーバマネージャー」で「Windows Server移行ツール」の機能を削除するからサーバマネージャー」で「Windows Server移行ツール」の機能のチェックを外したらUninstallできないでしょうか。

    Install自体が機能の追加で行っていますのでまずWindows Server移行ツール機能を外されてから作業を行えばいいのでしょうか。

    参考

    https://docs.microsoft.com/ja-jp/windows-server/administration/server-manager/install-or-uninstall-roles-role-services-or-features

    • 編集済み Mr.Spock 2019年9月17日 7:51
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月17日 7:47
  • Mr.Spock 様

    ご連絡ありがとうございます。
    ご指摘の通り、移行元の「移行ツール」を削除後、移行を実施た所
    移行データ・USER・グループ情報が無事、移行できました。

    本当にありがとうございます。

    しかしながら、最後にローカル側PCより共有フォルダーへアクセスした際に

    以下、アクセスエラーの表示がされログインできません。

    <エラー内容

    【共有フォルダ名】にアクセスできません

    【共有フォルダ名】に対するアクセス許可がありません。ネットワーク管理者にアクセス許可を要求してください。

    本来であれば、「ネットワーク資格情報の入力」ウィンドウが表示されるかと存じますが表示されません。

    これは、移行先のsever側でネットワーク設定エラーの為でしょうか。それとも移行データに問題があるのでしょうか。

    移行完了まで、あと一歩かと存じます。

    何卒、ご教授くださりますようお願い申し上げます。
    【共有名】にアクセスできません
    【共有フォルダ名】に対するアクセス許可がありません。ネットワーク管理者にアクセス許可を要求してください。

    本来であれば、「ネットワーク資格情報の入力」ウィンドウが表示されるかと存じますが表示されません。
    これは、移行先のsever側でネットワーク設定エラーの為でしょうか。それとも移行データに問題があるのでしょうか。
    移行完了まで、あと一歩かと存じます。

    何卒、ご教授くださりますようお願い申し上げます。

    • 編集済み onishiGI 2019年9月19日 3:10 間違い
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 3:08
  • 移行ツールで移行されるのは、共有フォルダの共有アクセス権でドメインアカウントの権限のみとなります。

    ローカルのNTFSアカウントの権限は、移行されません。

    移行元のローカルNTFSアクセス権と移行先のローカルNTFSアクセス権を比較し、同じアクセス権設定を行えばよいのではないでしょうか。

    ローカルのNTFSアクセス権は、同じユーザーアカウントであってもsidが異なりますので移行することができません。

    例 サーバAのユーザーAとサーバーBのユーザーAは、アカウント名は、同じですがsidが異なるため別アカウントと認識されます。

    一度ご確認ください。


    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 6:37
  • Mr.Spock 様

    ご連絡ありがとうございます。
    おっしゃる通り、sid設定は違うことを確認致しました。

    また、説明が足らず申し訳ございません。
    現状、移行元と移行先で共有の詳細設定にてオプションを合わせ作業を行ております。

    すると、現状のエラー内容は下記のエラー内容に切り替わりました。

    <エラー内容>

     アクセスできません。このネットワークリソースを使用するアクセス許可がない可能性があります。

     アクセス許可があるかどうかこのサーバーの管理者に問い合わせてください。
     ログオン失敗: 要求された種類のログオンは、このコンピュータではユーザーに許可されていません。

    次に、sidアカウントは確かに移行元とくらべ変わっておりましたが、

    パスは現行のサーバー用に変わっていたので特に問題ないかと思っておりました。

    また、現状<資格情報>を入力(登録)したPCにおいては、ログインが可能である事を確認しております。

    そこで、移行データが問題ではなくサーバー側の設定と考えておりましたが、見当違いの答えをしていれば

    ご容赦くださいませ。

    それらをふまえ、現行の状態としてご報告させていただきます。

    現在やりたいことは、「Windows セキュリティ」を表示させて<資格情報>を登録させたいと

    考えております。

    何卒、ご尽力の程宜しくお願い致します。


    • 編集済み onishiGI 2019年9月19日 7:37 記入不足
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 7:16
  • 共有フォルダには、どのようにアクセスされているのですか?

    ドメインアカウントでアクセスまたは、ローカルアカウントでアクセス?

    ドメインアカウントでアクセスなら共有フォルダのドメインアカウントのアクセス権の設定は、移行ツールで移行されているのでローカルのアクセス権の問題と思われます。ローカルにドメインのアクセス権を設定されていますでしょうか?

    共有フォルダにローカルのアカウントのアクセス権を設定しているのであれば、移行されていないので再設定が必要と思われます。(通常は、このような設定はしないと思いますが・・・・)

    また、ローカルアカウントとドメインアカウントで同じアカウント名で設定されている場合は、パスワードも同じにしないとアクセスできないです。

    Windowsセキュリティ→フォルダのプロパティのセキュリティのことですか?

    移行ツールを使われているのでドメイン環境と推測していましたがワークグループ環境ですか?

    • 編集済み Mr.Spock 2019年9月19日 9:43
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 9:39
  • Mr.Spock 様

    ご連絡ありがとうございます。

    はじめに、前提条件を記載せず質問してしまい
    誤解を招き申し訳ございません。

    現在、「ワークグループ環境」での、移行ツールを使用しております。
    パスワードに関しましては、移行ツールでは移行できない為再度、入れなおしている状況です。

    また、「Windowsセキュリティ」とは、ローカル内で共有フォルダにアクセスした際に
    下記のように出る、ウィンドウを指しており。

    <以下ウィンドウの内容>

    「Windows セキュリティ」

    ネットワークパスワードの入力
    次に接続するためのパスワードを入力してください:

     ユーザー名
     パスワード

    <ここまで>

    私のイメージでは、アクセスの際に上記のウィンドウが表示されるかと思っていたのですが
    アクセス後、前回説明させていただきました「エラー」が表示されアクセスできない状況です。

    ちなみに、資格情報を直接ローカルPCに登録するとログインが可能となります。

    説明が足らず申し訳ございません。

    不明な点がございましたら、ご返答いただけると幸いです。

    何卒、ご尽力の程宜しくお願い致します。

    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月20日 0:07
  • Mr.Spock 様
    ご連絡ありがとうございます。

    あれから、検証を行った結果「アクセス先のドライブにて」共有フォルダにEveryone権限を与えていた事により
    アクセス先で、「Windows セキュリティ」ウィンドウが表示されておりませんでした。

    共有フォルダの「Everyone権限」を解除後、アクセスすると通常通り
    「Windows セキュリティ」ウィンドウが表示されました。

    誠に、初歩的なミスによりご迷惑をおかけしてしまい申し訳ございません。
    これにより、本案件はクローズドとさせていただきます。

    この度は、ご助力いただき誠にありがとうございます。
    それでは、失礼いたします。


    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月24日 3:07

すべての返信

  • Windows Server移行ツールは、移行先で移行元の展開ツールを作成する仕様だったと思いますが、

    作成して移行元にコピーされました?

    作成してコピーしたものならバージョンが異なることはないと思いますが。

    cd C:\Windows\System32\ServerMigrationTools

    smigDeploy.exe /package /architecture <アーキテクチャ> /os /path <展開先パス>

    参考

    https://www.atmarkit.co.jp/ait/articles/1406/30/news017.html

    コピーされてたのならバージョンが異なる理由は、ちょっとわかりません。
    • 編集済み Mr.Spock 2019年9月9日 7:49
    2019年9月9日 7:49
  • Mr.Spock 様

    早速のご返答ありがとうございます。
    ご指摘いただいた通り、<移行先>で以下のコマンドを実行し移行元でコピーをしておりませんでした。

    ご指摘ありがとうございます。

    現在、コピーしたフォルダを<移行元>デスクトップに保存し
    ご提供いただいたURLを基に「<移行元>でSmigDeploy.exe」を実行しましたが

    一瞬、黒い画面(コマンドプロンプト?)が開きすぐに閉じます。
    念の為、ご指摘いただいた箇所の現在の状況を下記に示します。

     移行元 WS12R2 移行先 WS16

     <移行先>

     cd C:\Windows\System32\ServerMigrationTools

     smigDeploy.exe /package /architecture amd64  /os WS12/path <移行先>Dドライブ内

    コマンド実行後、作成したフォルダーを<移行元>デスクトップへコピーしました。

    <移行先>フォルダーで実行後、黒い画面(コマンドプロンプト?)が一瞬出て閉じます。
    これは、セキュリティ的な問題でしょうか?

    何卒、ご教授くださいます様宜しくお願い致します。
    2019年9月9日 14:12
  • OSのパラメータW12R2ではないでしょうか?

    通常では、SmigDeploy.exeを実行するとDOS画面が開きPowershell画面になります。

    2019年9月10日 1:00
  • フォーラムにご投稿くださいましてありがとうございます

    この後の状況はいかがでしょうか。

    皆さんから寄せられた投稿はお役に立ちましたか。


    ご不明な点がございましたら、お気軽にお問い合わせください

     

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月16日 7:12
    モデレータ
  • Mr.Spock 様

    ご連絡が遅くなり大変申し訳ございません。

    ご指摘の通り、本来であれば「W12R2」を指定するのですが、エラーが出てしまいます。
    エラー内容は保存しておらず、その後サーバーをリカバリーし再度、設定した所

    移行先で、移行ツール作成が完了しました。

     移行元 WS12R2 移行先 WS16

     <移行先>
      cd C:\Windows\System32\ServerMigrationTools
      smigDeploy.exe /package /architecture amd64  /os WS12R2/path <移行先>Dドライブ内

    ご指摘ありがとうございます。
    しかしながら、その後移行元に「移行ツールフォルダ」を張り付け、フォルダ内のSmigDeploy.exeを実行した所

    Windows PowerShellが一瞬起動後、「前提を確認します」の表示が出た後に、 
    プログラム終了表示がされ閉じてしまいます。 

    これは、前回の移行元で行った、SmigDeploy.exeが邪魔をして 
    実行できないのでしょうか。 

    その場合、一度解除を行うにはどのような対応を行えばよいでしょうか。 

    情報としてSmigDeploy.logログ内容を記載いたします。

    ログ内容:SmigDeploy.log(移行元)

    Error (Id=0) 現在、Windows Server 移行ツールの別のコピーがこのコンピューターに登録されています。
     次のコマンドを実行して、Windows Server 移行ツールの既存のコピーを登録解除してください:
     C:\Windows\System32\ServerMigrationTools\SmigDeploy.exe /unregister
     その後、新しい展開ディレクトリ内で登録コマンドを再度実行し、Windows Server 移行ツールのコピーを登録して使用してください。 

     2019-09-17 12:02:41.501 [SmigDeploy]     Registering
     2019-09-17 12:02:41.563 [SmigDeploy]     Register - check to see if the snap in reg key has already been existed

    念の為、下記のコマンドを実行しましたが添付のエラーとなります。

    C:\Windows\System32\ServerMigrationTools\SmigDeploy.exe /unregister

    大変、恐縮ですが原因と対応等がございましたらご教授ください。 

    何卒、宜しくお願い致します。

    • 編集済み onishiGI 2019年9月17日 7:09 情報の追記
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月17日 4:37
  • Windows erver 2012R2の「サーバマネージャー」で「Windows Server移行ツール」の機能を削除するからサーバマネージャー」で「Windows Server移行ツール」の機能のチェックを外したらUninstallできないでしょうか。

    Install自体が機能の追加で行っていますのでまずWindows Server移行ツール機能を外されてから作業を行えばいいのでしょうか。

    参考

    https://docs.microsoft.com/ja-jp/windows-server/administration/server-manager/install-or-uninstall-roles-role-services-or-features

    • 編集済み Mr.Spock 2019年9月17日 7:51
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月17日 7:47
  • Mr.Spock 様

    ご連絡ありがとうございます。
    ご指摘の通り、移行元の「移行ツール」を削除後、移行を実施た所
    移行データ・USER・グループ情報が無事、移行できました。

    本当にありがとうございます。

    しかしながら、最後にローカル側PCより共有フォルダーへアクセスした際に

    以下、アクセスエラーの表示がされログインできません。

    <エラー内容

    【共有フォルダ名】にアクセスできません

    【共有フォルダ名】に対するアクセス許可がありません。ネットワーク管理者にアクセス許可を要求してください。

    本来であれば、「ネットワーク資格情報の入力」ウィンドウが表示されるかと存じますが表示されません。

    これは、移行先のsever側でネットワーク設定エラーの為でしょうか。それとも移行データに問題があるのでしょうか。

    移行完了まで、あと一歩かと存じます。

    何卒、ご教授くださりますようお願い申し上げます。
    【共有名】にアクセスできません
    【共有フォルダ名】に対するアクセス許可がありません。ネットワーク管理者にアクセス許可を要求してください。

    本来であれば、「ネットワーク資格情報の入力」ウィンドウが表示されるかと存じますが表示されません。
    これは、移行先のsever側でネットワーク設定エラーの為でしょうか。それとも移行データに問題があるのでしょうか。
    移行完了まで、あと一歩かと存じます。

    何卒、ご教授くださりますようお願い申し上げます。

    • 編集済み onishiGI 2019年9月19日 3:10 間違い
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 3:08
  • 移行ツールで移行されるのは、共有フォルダの共有アクセス権でドメインアカウントの権限のみとなります。

    ローカルのNTFSアカウントの権限は、移行されません。

    移行元のローカルNTFSアクセス権と移行先のローカルNTFSアクセス権を比較し、同じアクセス権設定を行えばよいのではないでしょうか。

    ローカルのNTFSアクセス権は、同じユーザーアカウントであってもsidが異なりますので移行することができません。

    例 サーバAのユーザーAとサーバーBのユーザーAは、アカウント名は、同じですがsidが異なるため別アカウントと認識されます。

    一度ご確認ください。


    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 6:37
  • Mr.Spock 様

    ご連絡ありがとうございます。
    おっしゃる通り、sid設定は違うことを確認致しました。

    また、説明が足らず申し訳ございません。
    現状、移行元と移行先で共有の詳細設定にてオプションを合わせ作業を行ております。

    すると、現状のエラー内容は下記のエラー内容に切り替わりました。

    <エラー内容>

     アクセスできません。このネットワークリソースを使用するアクセス許可がない可能性があります。

     アクセス許可があるかどうかこのサーバーの管理者に問い合わせてください。
     ログオン失敗: 要求された種類のログオンは、このコンピュータではユーザーに許可されていません。

    次に、sidアカウントは確かに移行元とくらべ変わっておりましたが、

    パスは現行のサーバー用に変わっていたので特に問題ないかと思っておりました。

    また、現状<資格情報>を入力(登録)したPCにおいては、ログインが可能である事を確認しております。

    そこで、移行データが問題ではなくサーバー側の設定と考えておりましたが、見当違いの答えをしていれば

    ご容赦くださいませ。

    それらをふまえ、現行の状態としてご報告させていただきます。

    現在やりたいことは、「Windows セキュリティ」を表示させて<資格情報>を登録させたいと

    考えております。

    何卒、ご尽力の程宜しくお願い致します。


    • 編集済み onishiGI 2019年9月19日 7:37 記入不足
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 7:16
  • 共有フォルダには、どのようにアクセスされているのですか?

    ドメインアカウントでアクセスまたは、ローカルアカウントでアクセス?

    ドメインアカウントでアクセスなら共有フォルダのドメインアカウントのアクセス権の設定は、移行ツールで移行されているのでローカルのアクセス権の問題と思われます。ローカルにドメインのアクセス権を設定されていますでしょうか?

    共有フォルダにローカルのアカウントのアクセス権を設定しているのであれば、移行されていないので再設定が必要と思われます。(通常は、このような設定はしないと思いますが・・・・)

    また、ローカルアカウントとドメインアカウントで同じアカウント名で設定されている場合は、パスワードも同じにしないとアクセスできないです。

    Windowsセキュリティ→フォルダのプロパティのセキュリティのことですか?

    移行ツールを使われているのでドメイン環境と推測していましたがワークグループ環境ですか?

    • 編集済み Mr.Spock 2019年9月19日 9:43
    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月19日 9:39
  • Mr.Spock 様

    ご連絡ありがとうございます。

    はじめに、前提条件を記載せず質問してしまい
    誤解を招き申し訳ございません。

    現在、「ワークグループ環境」での、移行ツールを使用しております。
    パスワードに関しましては、移行ツールでは移行できない為再度、入れなおしている状況です。

    また、「Windowsセキュリティ」とは、ローカル内で共有フォルダにアクセスした際に
    下記のように出る、ウィンドウを指しており。

    <以下ウィンドウの内容>

    「Windows セキュリティ」

    ネットワークパスワードの入力
    次に接続するためのパスワードを入力してください:

     ユーザー名
     パスワード

    <ここまで>

    私のイメージでは、アクセスの際に上記のウィンドウが表示されるかと思っていたのですが
    アクセス後、前回説明させていただきました「エラー」が表示されアクセスできない状況です。

    ちなみに、資格情報を直接ローカルPCに登録するとログインが可能となります。

    説明が足らず申し訳ございません。

    不明な点がございましたら、ご返答いただけると幸いです。

    何卒、ご尽力の程宜しくお願い致します。

    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月20日 0:07
  • Mr.Spock 様
    ご連絡ありがとうございます。

    あれから、検証を行った結果「アクセス先のドライブにて」共有フォルダにEveryone権限を与えていた事により
    アクセス先で、「Windows セキュリティ」ウィンドウが表示されておりませんでした。

    共有フォルダの「Everyone権限」を解除後、アクセスすると通常通り
    「Windows セキュリティ」ウィンドウが表示されました。

    誠に、初歩的なミスによりご迷惑をおかけしてしまい申し訳ございません。
    これにより、本案件はクローズドとさせていただきます。

    この度は、ご助力いただき誠にありがとうございます。
    それでは、失礼いたします。


    • 回答としてマーク onishiGI 2019年9月24日 3:07
    2019年9月24日 3:07