none
IE7でOWA表示時に、ステータスバーに「実行しましたが、ページでエラーが発生しました」と表示され、「読み込み中」のままメッセージ一覧が表示されない RRS feed

  • 質問

  • 「Microsoft Answers」の方で、同様の書き込みをしておりましたが、
    こちらを誘導されたため、重複ながら改めて書き込みさせていただきます。

    Vista Home Premium SP1+IE7+ウイルスバスター2009です。

    標記の通り、Internet ExplorerでOWA表示時のみ以下のようなエラーが発生します。
    Firefoxでは問題なく表示ができます。

    ============================================================
    ステータスバー:「実行しましたが、ページでエラーが発生しました。」
    <エラーの詳細>
    ライン:3069
    文字:3
    エラー:クラス文字列が無効です
    ============================================================
    <試したこと>
    ・一時ファイル、クッキー、履歴などの消去
    ・Internet Explorer(アドオンなし)で表示
    ・インターネットオプション[詳細設定]でInternet Explorerのリセット
    ・信頼済みサイトへの登録
    ・保護モードを無効にする
    ・http://support.microsoft.com/kb/308260/の中の
    <対処方法>の1、3、4、5
    <高度なトラブルシューティング>の1~5
    ・http://support.microsoft.com/kb/306831/jaを参照して
    regsvr32 urlmon.dll」の実行
    ・ウイルスバスターのフィッシング機能で例外にアドレスを登録
    ・ウイルスバスターを無効にした状態での表示

    上記を試しましたが、いずれの方法でも状態変わらずで回避されませんでした。

    Firefoxでは表示できる、ほかにこのような問い合わせはないので
    サーバ側の問題やページの作りの問題ではなさそうなのですが。。。

    気になる点で、関係ないかもしれませんが、そのユーザのアカウント名が「ひらがな」でした。

    IE8にすれば表示されるのでしょうか?
    ActiveX関係の問題でしょうか?

    ご教示お願いします。
    2009年11月14日 8:34

すべての返信

  • こんにちは、フォーラムオペレーターの三沢健二です。

    ご投稿された内容について私の方でも調べてみましたが、参考になりそうな情報が見当たらないですね。。。

    「クラス文字列が無効です」 のエラーは、"regsvr32 xxxxx.dll" で直る可能性もあるのですが、どの dll を対象にすればよいかが分かりません。

    すでに色々と試されているようですので、現時点で有効な回避策は思い浮かばないのですが、まずは特定のクライアントで発生する現象なのか、それとも、特定のアカウントで発生する現象なのかを切り分けていただければと思います。

    もし特定のクライアントで発生する現象であれば、IE8 のインストールをきっかけに直る可能性もありそうです。
    特定のアカウントで発生する現象でしたら、サーバー管理者にご相談された方がよいと思います。


    あまり具体的な案内が出来ずすみません。
    それでは、他の皆様からの情報もお待ちしております。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    2009年11月20日 5:51
    モデレータ
  • ご返信ありがとうございました。

    いまだ未解決状態です。。

    ちなみに、特定のユーザでのみ発生しており、件数もさほど多くはありません。

    Internet Explorerが壊れているのかも?と考え、ひとまずIE8のインストールを試してもらっています。

    有益な情報があれば、引き続き回答お待ちしています。
    2009年11月24日 0:30