none
RSSビューワーの動きについて RRS feed

  • 質問

  • こんはんは。

    RSSビューワーを設定して、別のサイトコレクションにある、リストWebパーツの新着情報を持ってこようとしています。

    この動きが、いまいち安定しないため、質問させてください。


    ●Webフロントエンド
    サーバ名:Server1
    FQDN:Server1.test.aa
    FQDN2:sps2010.test.aa
    OS:Windows Server 2008 R2 SP1
    SharePoint Server 2010
    認証方式:Kerberos 認証(←認証が通っているのは、Windowsログで確認済み)


    この状態で、うまく表示できるかのテストを実施しました。
    ■ケース1
    [RSSビューワー]-[RSSフィードのURL]にサーバ名で記入
    http://Server1/**********************

    ▲結果⇒正常に表示された

    ■ケース2
    [RSSビューワー]-[RSSフィードのURL]にFQDN名で記入
    http://Server1.test.aa/**********************

    ▲結果⇒「この RSS Web パーツでは、認証されたフィードはサポートされていません。」とエラーになる

    ■ケース3
    [RSSビューワー]-[RSSフィードのURL]にFQDN2名で記入
    http://sps2010.test.aa/**********************

    ▲結果⇒「この RSS Web パーツでは、認証されたフィードはサポートされていません。」とエラーになる


    私は、ケース3での接続が成功して欲しいのですが、FQDNにしたところでなぜか取得できなくなってしまいます。
    どこを調べれば良いのか、手詰まり状態になってしまったので、是非皆様のお知恵を拝借できると幸いです。

    よろしくお願いします。

    2011年6月20日 8:56

回答

  • この方がきちんと解決まで書き込んで下さる保証はないですからね…あまり期待はできないかと。

    事情と、この情報をみると、やはり 認証が通っていないとしか思えないのですよね。

    …あ。

     

    おそらくこれです

     

    Kerberos認証とURL(FQDN) http://mossmomo.exblog.jp/12912137/

    > Kerberos認証のとき、ここで問題が。

    > Kerberos認証している場合、既定に設定されているURLしか認識できないそうです。

    > 結果、Kerberos認証にした目的が、コレクション内のコンテンツのRSSフィードだった場合、

    > http://momochiro_pubでアクセスしても、RSSフィードのWebパーツにエラーが表示されます。

    > じゃあ、既定にBIOS名じゃない http://momochiro_pubを登録すればいいじゃん。

    > となるのですが、ここにも課題が・・・ていうか 不具合が。

    > 解消するにはRegistryの編集が必要。未検証ですが、MSの情報ではそうなっています

     

    で、解決策はおそらくこちら(英語・未検証)

    http://bloggingabout.net/blogs/mglaser/archive/2007/01/31/hosting-sharepoint-on-a-fully-qualified-domain-name-fqdn.aspx

     


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答としてマーク 星 睦美 2011年7月6日 2:36
    2011年6月23日 13:46

すべての返信

  • 参考情報だけですが、こちらの四番目のtrickが関連していそうな気がします
    http://sharepointconnoisseur.blogspot.com/2011/04/sharepoint-2010-rss-viewer-web-part.html
    The fourth issue is I'm not able to display the feed across the farms. See previous third RSS feed web part. I'm getting error "The RSS webpart does not support authenticated feeds." that is same as you have not setup Kerberos.
    There are some other issues you may encounter fro external RSS feeds with SSL and different sources. We have noticed people mentioned they could display feed across farm we will continue to debug.
     

    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    2011年6月20日 22:03
  • 情報、ありがとうございます!

    私のしょぼい英語力で読んだところ、Kerberos 認証が設定されていないときと、同じエラーを出していて、
    RSSビューアーの不具合な気がするので調査中

    と言ったところでしょうか。
    これの結果が出るまで、様子見したほうが無難なのでしょうかね・・・。

    2011年6月21日 5:07
  • この方がきちんと解決まで書き込んで下さる保証はないですからね…あまり期待はできないかと。

    事情と、この情報をみると、やはり 認証が通っていないとしか思えないのですよね。

    …あ。

     

    おそらくこれです

     

    Kerberos認証とURL(FQDN) http://mossmomo.exblog.jp/12912137/

    > Kerberos認証のとき、ここで問題が。

    > Kerberos認証している場合、既定に設定されているURLしか認識できないそうです。

    > 結果、Kerberos認証にした目的が、コレクション内のコンテンツのRSSフィードだった場合、

    > http://momochiro_pubでアクセスしても、RSSフィードのWebパーツにエラーが表示されます。

    > じゃあ、既定にBIOS名じゃない http://momochiro_pubを登録すればいいじゃん。

    > となるのですが、ここにも課題が・・・ていうか 不具合が。

    > 解消するにはRegistryの編集が必要。未検証ですが、MSの情報ではそうなっています

     

    で、解決策はおそらくこちら(英語・未検証)

    http://bloggingabout.net/blogs/mglaser/archive/2007/01/31/hosting-sharepoint-on-a-fully-qualified-domain-name-fqdn.aspx

     


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答としてマーク 星 睦美 2011年7月6日 2:36
    2011年6月23日 13:46
  • 重ね重ね、情報ありがとうございます。

    設定は簡単そうですが、IIS の設定を変更するので、敷居は高そうです。
    近々、メンテナンスの機会をみて、実施してみようと思います。
    ひとまず、ありがとうございました。

    実施後、結果はまた書き込みに来ます。
    2011年6月27日 1:32
  • 豚肉定食 さん、こんにちは
    フォーラム オペレーターの星 睦美です。

    中村 和彦さんの返信を参考にしていただけたと思います。
    今回は私のほうでいったん[回答としてマーク] をさせていただきました。
    豚肉定食 さんからの結果のご報告もおまちしています。

    今後ともTechNet フォーラムをよろしくお願いします。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美
    2011年7月6日 2:36
  • 遅くなりましたが、無事解決したので、報告させていただきます。

    実際に、教えていただいたサイトにあるように、実行してみました。
    手順としては、次の通りです。

    1.IIS のバインド情報に FQDN 名を登録
    2.SharePoint の「サーバの全体管理」から「代替アクセスマッピングの構成」で
    ”既定”となっている領域を FQDN 名のアドレスに変更
    念のため、元々既定になっていた値を”イントラネット”に設定

    これで、無事通るようになりました。

    いろいろ、ありがとうございました。
    2011年8月4日 7:28