none
SCCM2007 での安定したソフトウェア配布 RRS feed

  • 質問

  • はじめまして。SCCMにてクライアントソフトの配布を考えている者です。
    以下のサイトを参考にして、ソフトウェアの配布を設定しましたが、ソフトウェアの配布ができる場合と出来ない場合があって困っております。安定した配布にはどのようにすればよいのかを教えてください。

    http://technet.microsoft.com/ja-jp/library/bb632640.aspx

    症状としては、提供情報で指定したスケジュール時刻を過ぎてもインストールが開始されないというものです。同じ時刻に作成した同様の設定のソフトウェア配布設定の中には、すでに配布が完了したものも含まれております。
    配布されないソフトウェアを、SCCMのレポート機能「すべての提供情報」にて確認したところ、リソースの受信ステータスが「ステータスなし」となっております。

    この状況から、どのようにしてインストールを続行したらよいのかについてご教示ください。また、他に確認すべき事項がありましたら、併せてお願い致します。

    よろしくお願いします。

    環境
    サーバー Windows2008 Server Standard SP2、SCCM2007 SP2
    クライアント Windows XP Pro SP3など
    2010年3月30日 4:11

回答

  • 初めましてinspire2000です。

    前提として配布対象PCにSCCMクライアントがセットアップされサイトに設定されていれば

    「ステータスなし」状態は、ほとんどの場合、PCの電源が入っていない状態と

    推測できます。 まずそこを確認してみてください。

    2010年4月1日 14:06
  • SundaySilenceです。

    一番ありがちなのは、inspire2000さんのおっしゃるように、クライアントがオフラインの場合ですね。

    受信ステータスが「なし」となっているクライアントの最終インベントリ日時を正常にソフトウェア配布出来ているクライアントと比較してみて下さい。おおまかな推測は立てられるかと思います。

    これで問題ない場合、該当するクライアントのセグメントがサイト境界に存在するものか、そうでない場合はサイト境界を見直す必要があります。

    ネットワークに接続されていることが確認できているのであれば、該当クライアントを新規コレクションにダイレクトメンバシップで登録し、作成したコレクションに先のソフトウェア配布の提供情報を「必須の割り当て」で強制してみて下さい。

    SundaySilence

     

    2010年4月2日 6:48

すべての返信

  • 初めましてinspire2000です。

    前提として配布対象PCにSCCMクライアントがセットアップされサイトに設定されていれば

    「ステータスなし」状態は、ほとんどの場合、PCの電源が入っていない状態と

    推測できます。 まずそこを確認してみてください。

    2010年4月1日 14:06
  • SundaySilenceです。

    一番ありがちなのは、inspire2000さんのおっしゃるように、クライアントがオフラインの場合ですね。

    受信ステータスが「なし」となっているクライアントの最終インベントリ日時を正常にソフトウェア配布出来ているクライアントと比較してみて下さい。おおまかな推測は立てられるかと思います。

    これで問題ない場合、該当するクライアントのセグメントがサイト境界に存在するものか、そうでない場合はサイト境界を見直す必要があります。

    ネットワークに接続されていることが確認できているのであれば、該当クライアントを新規コレクションにダイレクトメンバシップで登録し、作成したコレクションに先のソフトウェア配布の提供情報を「必須の割り当て」で強制してみて下さい。

    SundaySilence

     

    2010年4月2日 6:48
  • ありがとうございます。inspire2000様、SundaySilence様。

    その後、クライアントやサーバー設定等を見直し、クライアントの起動状態も確認いたしました。

     

    現在は、テスト配布中なので、クライアントの電源は常に立ち上がっており、ここは問題ありません。

    サーバーとの通信も問題なく出来ております。(pingで確認しました)また、サーバー側の設定ですが、パッケージを別名で作り直したところ問題なく配布される所も確認しました。

     

    サーバー側の設定は、パッケージ名、プログラム名などの名称以外は何一つ変えておりません。

    ただ、配布するプログラムの、Updateキーは変更しました(別のプログラムだと認識させるため)。

     

    これらの事から、パッケージの作成し直しが、本現象の解決に役立ったのではないかと推察している次第です。

    中々、SCCMでの配布は難しいですね。一応、本件は配布出来るようになったので原因は分かりませんが解決扱いとしたいと思います。

     

    ご回答ありがとうございました。

    2010年4月5日 4:32