none
WindowsServer2003へTomcatをインストール時エラーが発生しサービスに登録できない RRS feed

  • 質問

  • はじめて、投稿いたします。

    よろしくお願いいたします。

    WindowsServer2003(sp1)へTomcatをインストールしたのですが、

    以下のエラーメッセージにより、サービスに登録できません。

    解決方法をご存知の方がいらっしゃいましたらご教授お願いいたします。

    【エラーメッセージ】

     指定されたサービスはインストールされたサービスとして存在しません。
     unable to open the service 'Tomcat5'

    以上、よろしくお願いいたします。

    2007年1月24日 5:49

すべての返信


  • メッセージ的にはWinodws Server 2003のエラーですが
    どちらかと言うとTomcat側に原因があると思います。

    ※↓手元に2000しか無かったので2000のメッセージです。
    例:
    ==========
    C:\>net stop test
    システム エラー 1060 が発生しました。

    指定されたサービスはインストールされたサービスとして存在しません。
    ==========
    ⇒testと言うサービスは存在しないのでエラーになる。

    メッセージ的に"Tomcat5"と言うサービスが無いのでエラーになっている
    ような感じです。
    Windows側で確認するとしたら以下の2点ぐらいかな?と思います。
    1)net start tomcat5 / net stop tomcat5
    ⇒手動で開始/停止をして正常に開始/停止できるか確認する。
    2)サービスに"Tomcat5"が登録されているか否か?

    Tomcat側のインストール手順、設定など見直しては如何でしょうか?
    (Tomcatのパス、環境変数は間違っていないですか?)

    #@IT会議室、Yahoo!知恵袋も反応無いみたいですね。
    ##Windows系では無くApache/Tomcat系のサイトで聞いた方が
    ##良い内容のような気がします。

     

    2007年1月29日 6:11
  •  193007okuda さんからの引用

    【エラーメッセージ】

     指定されたサービスはインストールされたサービスとして存在しません。
     unable to open the service 'Tomcat5'

    以上、よろしくお願いいたします。

    今日は。

    Shin291さんも書いていますが、結局の所Tomcatをインストールする時に

    サービスとして登録出来なかった事が原因でしょう。 

    サービスに登録出来ないという訳では無く、

    サービスがないから起動出来ないよ。

    って状態ですね。

    管理者権限でインストールしたんでしょうか?

    また、インストール時に何かエラーは表示されませんでした?

    一度アンインストールして管理者権限でインストールし直して見てはどうでしょう。

    それから。

    手動でサービスを登録する事も可能です。

    「sc」ってコマンドを使えば出来ますよ。

    登録する時は「sc create~」

    削除する時は「sc delete~」

    です。

    詳細はsc /?で見て下さい。

     

    2007年1月30日 7:19