none
InfoPathテンプレートをInfoPath Forms Servicesに発行して利用する方法 RRS feed

  • 質問

  • 表題の件で、Infopath2007のデザインタスクからフォームテンプレートの発行を行っております。

     

    こちらのサイトの情報を参考に行っているのですが、

    http://msdn.microsoft.com/ja-jp/library/bb267334.aspx

     

    作業を進めると、「このフォームをブラウザで入力できるようにする」というチェックが出来る画面に推移するのですが

    その際に、「このフォームをブラウザで入力できるようにする」がグレーアウトされておりチェック出来ず困っております。

     

    エラーとしては、「このフォームテンプレートはブラウザ互換ですが、選択したサイトでブラウザ対応にすることができません」との

    メッセージが出力されてしまいます。

     

    http://blog.straw-hat.jp/?cid=1796

    ↑こちらのサイトも参考にさせて頂いて設定を行いましたが、やはり

    >6.「このフォームをブラウザで入力できるようにする」をチェックしてください。

    >そうすると「ドキュメントライブラリ」「サイトコンテンツタイプ(高度)」がグレーアウトして「管理者承認用フォームテンプレート(高度)」>が自動的に選択されます。

     

    という部分で「このフォームをブラウザで入力できるようにする」をチェックができません。

     

    こちらの解決方法をご教授頂けませんでしょうか?

     

     

     

    追伸:

    TechNetフォーラムは何回か書き込みさせて頂いていたのですが、画像の貼りつけが出来ないというのに

    今日初めて気付きました。出来たら便利なような気がします。

    (エラーメッセージのプリントなどそのまま貼りつけられるので)

    素人が勝手な事言って申し訳ないです。

    2008年12月17日 5:16

回答

  • 茄 子 さん、こんにちは。フォーラムオペレーターの鈴木裕子です

     

    同じエラーの現象が、USのフォーラムに投稿されていました。

     

    This form template is browser-compatible, but it cannot be browser-enabled on the selected site.
    http://social.msdn.microsoft.com/forums/en-US/sharepointinfopath/thread/c9617953-a54c-44ec-86cf-df215c750c18/

     

    質問者さんの投稿を読むと「"Enable this form to be filled out by using a browser"」をチェックできない点も同じなので、同じ現象なのではないかなと思いました。
    スレッド内のBajju さんの投稿に対して、質問者さん(と、もうひと方)が「解決しました」と返信されていましたので、そちらが参考になるかもしれません。内容をご紹介させていただきますね。

     

    Bajju さんの投稿(15番目の投稿)
    ---------------------------------------------
    「すべてのサイトコンテンツ」ページに「フォームテンプレート」オプションが表示されていることを確認してください。

    もしそれがデフォルトで有効になっていなければ、下記のステップが有効です。

    また、「Office SharePoint Server Enterprise サイト機能」が有効になっているにも関わらず、「すべてのサイトコンテンツ」ページに「フォームテンプレート」が表示されていない場合も、下記のステップを試してみて下さい。

    • すべてのバックアップを取得してください。
    • SharePoint Designerで、サイトを開きます(http://< あなたのサイトのURL >)。
    • ルートURLを選択して、[ファイル]-[新規作成]-[SharePointコンテンツ]とします。
    • [ドキュメントライブラリ]内の[フォームライブラリ]を選択します。
    • 「オプション」に”FormServerTemplates”という名前を入力して、コンテンツを作成してください。
    • [FormServerTemplates]を右クリックして「プロパティ」を開きます。
    • 「設定」タブで、名前を「フォームテンプレート」に変更し、「新しいドキュメントでテンプレートを使用する」オプションのチェックをはずします。
    • [OK]します。
    • これで、「すべてのサイトコンテンツ」ページで「フォームテンプレート」を見ることができるはずです。
    • 「このフォームをブラウザで入力できるようにする」の設定で、このinfoPathフォームを発行できるようになるはずです。

    ---------------------------------------------

     

    InfoPathはあまり詳しくないのでもしかしたら外しているところもあるかもしれませんが、その時はごめんなさい。
    Bajju さんの他、Nicolas Curti さん、deeptyranjan さん、Typhoon007 さんも解決策を投稿されているようなので、そちらも参考になるかもしれません。一度確認してみて下さい。

     

    ご参考となれば幸いです!

    2008年12月19日 6:06
    モデレータ
  • 鈴木様

     

    ご返信ありがとうございます。

     

    頂いて手順実施したのですが、残念ながら解決しませんでした。

     

    只、その後自己解決出来ました。

     

    今回の手順の中で、サーバの全体管理を行っているサイトコレクションに対してフォームを発行する必要があったのですが、

    該当のサイトコレクションで「Office SharePoint Server Enterprise サイト コレクション機能」が非アクティブとなっています。

    これはデフォルトでOFFだと思います。

     

    アクティブにした所、正常に発行が出来るようになりました。

     

    とにかく、解決して良かったです。

    2008年12月19日 7:41

すべての返信

  • 茄 子 さん、こんにちは。フォーラムオペレーターの鈴木裕子です

     

    同じエラーの現象が、USのフォーラムに投稿されていました。

     

    This form template is browser-compatible, but it cannot be browser-enabled on the selected site.
    http://social.msdn.microsoft.com/forums/en-US/sharepointinfopath/thread/c9617953-a54c-44ec-86cf-df215c750c18/

     

    質問者さんの投稿を読むと「"Enable this form to be filled out by using a browser"」をチェックできない点も同じなので、同じ現象なのではないかなと思いました。
    スレッド内のBajju さんの投稿に対して、質問者さん(と、もうひと方)が「解決しました」と返信されていましたので、そちらが参考になるかもしれません。内容をご紹介させていただきますね。

     

    Bajju さんの投稿(15番目の投稿)
    ---------------------------------------------
    「すべてのサイトコンテンツ」ページに「フォームテンプレート」オプションが表示されていることを確認してください。

    もしそれがデフォルトで有効になっていなければ、下記のステップが有効です。

    また、「Office SharePoint Server Enterprise サイト機能」が有効になっているにも関わらず、「すべてのサイトコンテンツ」ページに「フォームテンプレート」が表示されていない場合も、下記のステップを試してみて下さい。

    • すべてのバックアップを取得してください。
    • SharePoint Designerで、サイトを開きます(http://< あなたのサイトのURL >)。
    • ルートURLを選択して、[ファイル]-[新規作成]-[SharePointコンテンツ]とします。
    • [ドキュメントライブラリ]内の[フォームライブラリ]を選択します。
    • 「オプション」に”FormServerTemplates”という名前を入力して、コンテンツを作成してください。
    • [FormServerTemplates]を右クリックして「プロパティ」を開きます。
    • 「設定」タブで、名前を「フォームテンプレート」に変更し、「新しいドキュメントでテンプレートを使用する」オプションのチェックをはずします。
    • [OK]します。
    • これで、「すべてのサイトコンテンツ」ページで「フォームテンプレート」を見ることができるはずです。
    • 「このフォームをブラウザで入力できるようにする」の設定で、このinfoPathフォームを発行できるようになるはずです。

    ---------------------------------------------

     

    InfoPathはあまり詳しくないのでもしかしたら外しているところもあるかもしれませんが、その時はごめんなさい。
    Bajju さんの他、Nicolas Curti さん、deeptyranjan さん、Typhoon007 さんも解決策を投稿されているようなので、そちらも参考になるかもしれません。一度確認してみて下さい。

     

    ご参考となれば幸いです!

    2008年12月19日 6:06
    モデレータ
  • 鈴木様

     

    ご返信ありがとうございます。

     

    頂いて手順実施したのですが、残念ながら解決しませんでした。

     

    只、その後自己解決出来ました。

     

    今回の手順の中で、サーバの全体管理を行っているサイトコレクションに対してフォームを発行する必要があったのですが、

    該当のサイトコレクションで「Office SharePoint Server Enterprise サイト コレクション機能」が非アクティブとなっています。

    これはデフォルトでOFFだと思います。

     

    アクティブにした所、正常に発行が出来るようになりました。

     

    とにかく、解決して良かったです。

    2008年12月19日 7:41
  • 茄 子 さん、こんにちは。フォーラムオペレーターの鈴木裕子です

    私の投稿も間接的にお役に立ったでしょうか・・・何より、無事解決されてよかったです!

     

    解決結果のご投稿、ありがとうございました

    実体験に基づく情報なので、同現象に遭遇された方に大変参考になると思います。

    フォーラムオペレーターとしては、有用な情報を投稿していただいて嬉しい限りです!

    今後とも、投稿・回答ともども、よろしくお願いします。

    2008年12月22日 0:53
    モデレータ