none
サイト管理者の指定について RRS feed

  • 質問

  • このような所に質問するのもお恥ずかしい内容なのですが、

    SharePoint2013でサイトを作成いたしました。

    そちらのカスタマイズをいろいろ実行しようとしているのですが、どうもそれ以前にサイト管理者の権限がないのではないかと思われるような現象が発生しております。

    ログオンしているユーザーはサイトコレクション管理者という所に所属していますがこれはサイト管理者というとらえ方で良いのかわかりません。

    サイト管理者権限がないのではと考える理由として、

    SharePoint自習書の[SharePoint Server 2013 サイト デザイン編集ガイド]を参考に作業をしていたところP.6のトップリンクバーの説明の部分で、

    「またサイトの管理者権限を持つユーザーには[リンクの編集]M3絵ニューが表示され、クリックすることで、・・・」と記載されていますが、[リンクの編集]が表示されません。

    サイトの管理者権限を割り当てるにはどこから設定を行うのかご教示いただけますでしょうか。


    2014年5月20日 8:04

回答

  • Gs.NangChunさん

    回答ありがとうございます。

    ご指摘いただきましたサイトコレクション管理者の部分は確認して、さらにサイトに対してフルコントロール権限も付与してありましたが、うまくいきませんでした。

    まだ、運用しているサイトではないので、

    【SharePoint 2013 サーバーの全体管理】→【アプリケーション構成の管理】→【Webアプリケーション】→【Webアプリケーションの管理】

    からSharePointのトップサイトを削除して、製品構成ウィザードから再度生成し直したところ表示されるようになりました。

    原因がわかったわけではありませんが、とりあえず手順を進められそうです。アドバイスいただきありがとうございました。

    • 回答としてマーク mockk-kk 2014年5月21日 10:40
    2014年5月21日 10:36

すべての返信

  • mockk-kkさんこんにちは。

    今もう一度確認しましたが、サイトコレクション管理者、代理管理者はそのコレクションの中のサイトならサイトの権限設定に関係なく必ずフールコントロールを持つと思います...

    もしかして、そのログインしているユーザーが管理者に設定されているサイトコレクションと違うサイトコレクションのサイトに接続しているとか...の問題が考えられますが...

    SharePointサーバー全体管理 -> アプリケーション構成の管理 -> サイトコレクション管理者の変更

    メニューで自分のアカウントが管理者あるいは代理管理者に設定されているか確認して、設定されているサイトコレクションんおアドレスをもう一度確認してみてください。

    サイトコレクション管理者ではなくても、サイトに対してフールコントロール権限を付与することですべての権限を持つことができます。 リンクの編集が見えないのはおそらく現在使っているユーザーアカウントはサイト設定メニューも見えないはずだと思われますが。そのサイトを作ったユーザーにサイト設定→権限設定 メニューで管理者にしたいユーザー(質問者)にフールコントロール権限を付けるようにしてみてください。


    2014年5月21日 0:05
  • > SharePoint自習書の[SharePoint Server 2013 サイト デザイン編集ガイド]を参考に
    > 作業をしていたところP.6のトップリンクバーの説明の部分で、
    > 「またサイトの管理者権限を持つユーザーには[リンクの編集]M3絵ニューが表示され、クリックすることで、・・・」と
    > 記載されていますが、[リンクの編集]が表示されません。

    これだけの現象を述べているのなら、管理者でも、「親サイトのトップリンクバーを継承」している場合には、[リンクの編集]は表示されませんよ。

    現象が発生している画面で、

     「*(歯車マーク)」-「サイトの設定」-「トップリンクバー」

    を選んだ時に、「×リンクの継承の中止」、というメニューが出ていれば、そのサイトは、親サイトのトップリンクバーを継承しています。

    もし表示されていれば、このメニューを選んでみて、[リンクの編集]が、表示されるか試してみてください。(「親のリンクの使用」で元に戻せます)

    2014年5月21日 6:53
  • Gs.NangChunさん

    回答ありがとうございます。

    ご指摘いただきましたサイトコレクション管理者の部分は確認して、さらにサイトに対してフルコントロール権限も付与してありましたが、うまくいきませんでした。

    まだ、運用しているサイトではないので、

    【SharePoint 2013 サーバーの全体管理】→【アプリケーション構成の管理】→【Webアプリケーション】→【Webアプリケーションの管理】

    からSharePointのトップサイトを削除して、製品構成ウィザードから再度生成し直したところ表示されるようになりました。

    原因がわかったわけではありませんが、とりあえず手順を進められそうです。アドバイスいただきありがとうございました。

    • 回答としてマーク mockk-kk 2014年5月21日 10:40
    2014年5月21日 10:36
  • たけさとさん

    回答ありがとうございます。

    ご指摘いただきました「親サイトのトップリンクバーを継承」している場合ですが、今回の場合は一番トップのサイトでの質問でしたので、ご指摘いただいた件は該当しないです。

    Gs.NangChunさんにもご報告いたしましたが、結局まだ、運用しているサイトではないので、

    【SharePoint 2013 サーバーの全体管理】→【アプリケーション構成の管理】→【Webアプリケーション】→【Webアプリケーションの管理】

    からSharePointのトップサイトを削除して、製品構成ウィザードから再度生成し直したところ表示されるようになりました。

    原因がわかったわけではありませんが、とりあえず手順を進められそうです。アドバイスいただきありがとうございました。

    2014年5月21日 10:39