none
Windows Server 2012 RC のデスクトップのIEでFlashが再生できません RRS feed

  • 質問

  • よろしくお願いいたします。

    サーバーの本来の使い方ではないことは承知しておりますが、
    当方、個人で、自宅のなけなしの自作PCで作業をしており、
    サーバー機でも、YouTubeなど、Flashを再生したいのです。

    しかし、Windows Server 2012 RC のデスクトップのIEで、Flashを再生することができません。
    従って、YouTubeなども再生できません。

    Adobeサイトで、Adobe Flash Player をインストールしようとしても、エラーになります。
    (これは、IE10が、Adobe Flash Player と一体化しているためだと思います。)

    どうすれば、Windows Server 2012 RC のデスクトップのIEで、Flashを再生することができるのでしょうか?
    何方か、方法をご教示ください。お願いいたします。

    2012年7月10日 10:16

回答

  • Windows Server 2012 正式版 において、IE10で、YouTubeなどFlashを画像・音声共に再生できることを確認しました。

    結局、Windows Server 2012 RC版のバグだったという結論です。
    人騒がせだなあ・・・。

    • 回答としてマーク Makoto.Cue 2012年9月5日 12:20
    2012年9月5日 12:20

すべての返信

  • IE以外のブラウザでよければChromeなら表示できてます。

    こちらのスレッドでも同じような質問が出ていますが
    Windows Server 2012 RCのIE10でActiveXのFlashは正常に動作しないようです。
    [speedtest.net and other similiar sites not working in win2012]
    http://social.technet.microsoft.com/Forums/en-AU/winserver8gen/thread/3a390b62-d72f-4982-88fd-5b6fada99f90

    私の環境でyoutubeやニコニコ動画等を表示してみましたが音声のみで動画は表示されませんでした。
    ブラウザウインドウをリサイズすると一瞬だけ表示され
    本来動画が表示されているであろう場所をクリックすると動画が一時停止するので
    IEとFlashどちらの問題かまではわかりませんが
    Flash Playerの描画処理のZ軸が狂っているのではないかと思います。


    // [署名建設予定地]
    //      ||


    • 編集済み S.HiROMVP 2012年7月10日 12:58 リンク設定を忘れてました
    • 回答の候補に設定 S.HiROMVP 2012年7月11日 2:15
    • 回答の候補の設定解除 Makoto.Cue 2012年7月11日 4:00
    2012年7月10日 12:42
  • S.HIRO様
    ご返信、ありがとうございます!
    動画は表示されませんが、私の環境でも音声は出ていました。
    (すぐに止めてしまったので、気が付きませんでした。)
    ご教示いただいたので早速、Chromeをインストールした所、無事、表示も音声も正常に再生されました。
    本当に、ご教示、ありがとうございました。助かりました。

    それにしても、これはどう考えてもバグですよね。
    Microsoftは、IE10でFlashを再生する、というテストをたった一度でもしたのでしょうか???
    ああ、Release Candidate「出荷候補」の名を付ける品質管理体制が情けない・・・。
    Microsoftの皆様、しっかりしてくださいよ!

    2012年7月10日 13:23
  • このバグが今日の Windows Update で修正されるといいなあ、と期待していたのですが、修正されませんでした。

    修正は、RTM版かな?

    修正されたことを確認した時点で、この件をクローズします。それまでは、この件は生きています。

    S.HIRO様へ
    なので、S.HIRO様が設定した「回答の候補の設定」を解除させていただきました。申し訳ございません。



    2012年7月11日 4:12
  • ちなみに、S.HiRO さんが書かれたスレッドの先、madmaxsoft さんによると

    So to fix the problem with the flash player on Windows Server 2012 RC all you need to do is to locate the feature User Interfaces and Infrastructure and click on it to expand it there you will see the feature Desktop Experience that you need to install.

    Once this is installed you need to re start the computer and check for updates and there should be an update to install. Once this is done all you need to do is to adjust the security setting accordingly in internet explorer and it should work fine.

    だそうですが、これでは直らないのでしょうか?

    • 回答の候補に設定 星 睦美 2012年7月23日 7:47
    • 回答の候補の設定解除 Makoto.Cue 2012年7月23日 8:53
    2012年7月11日 4:53
  • デスクトップ エスクペリエンス はインストールしてあります。

    HomeCloset様や星 睦美様の環境では動作しているのでしょうか?


    2012年7月23日 9:32
  • Once this is installed から先もやったのでしょうか?

    私は Server で Flash を使うことはないので、試してません。

    2012年7月23日 10:28
  • Once this is installed から先は意味が分かりません。(インストール後の再起動は当然しています。)
    翻訳サイトで翻訳しても意味不明です。
    翻訳していただけると助かります。

    2012年7月23日 11:21
    1. 再起動。
    2. 更新プログラムをインストール。
    3. IE のセキュリティ設定を調整。

    です。
    私はあちらで Marked as Answer になっている投稿から引用しただけなので、それ以上のことは残念ながらわからないです。

    2012年7月23日 15:24
  • その更新プログラムというのとIEのセキュリティ設定を調整というのが意味不明なのです。
    もちろん、Windows Updateはしています。IEのプロパティのセキュリティなども見ましたがそれらしいものがありません。

    2012年7月24日 2:46
  • フォーラム オペレーターの星 睦美です。

    Makoto.Cue さん、こんにちは。

    「IE のセキュリティ設定」に関して。
    サーバーからInternet Explorer を利用する場合にはクライアントと比較してセキュリティレベルが高くなっています。
    「Internet Explorer セキュリティの構成」を無効にしてみる、Internet Explorer 10 のインターネット オプション>詳細設定で「拡張保護モードを有効にする」にチェックが入っていたら外す、グループポリシーを確認する、の順に試してみてはいかがでしょうか。

    私もまだWindows Server 2012RC 上ではInternet Explorer 10 でFlashを使った動画は再生していませんが、Windows8 では問題なく再生できていますので、Internet Explorer 10 とFlash の問題はないのではないかと思います。


    日本マイクロソフト株式会社 フォーラム オペレーター 星 睦美



    2012年7月25日 5:04
  • 星 睦美様、こんにちは。
    Makoto.Cueです。

    ご教示、ありがとうがとうございます。
    しかし、現象(音声のみ再生されて、画像が表示されない)は変わりませんでした。

    1. 「Internet Explorer セキュリティの構成」を無効

    これは、既に、無効にしていまwす。

    2. Internet Explorer 10 のインターネット オプション>詳細設定で「拡張保護モードを有効にする」にチェックが入っていたら外す

    チェックを外してみました。

    3. グループポリシーを確認する

    ひとつひとつ確認しましたが、今回の問題と関係ありそうな項目は、私には分かりませんでした。
    (デフォルトのままで問題無いように思いました。)
    Windows 8 の IE10の設定と見比べてみましたが、唯一「ページフリップ」に関する設定が違っていましたが、これは本件とは無関係だと思います。それ以外には、違いは見つけられませんでした。

     

    「音声のみ再生されて、画像が表示されない」という現象から、何か、(他に)考えられることは無いでしょうか?
    どうか、引き続き、ご教示をお願いいたします。

    2012年7月25日 7:39
  • Windows Server 2012 正式版 において、IE10で、YouTubeなどFlashを画像・音声共に再生できることを確認しました。

    結局、Windows Server 2012 RC版のバグだったという結論です。
    人騒がせだなあ・・・。

    • 回答としてマーク Makoto.Cue 2012年9月5日 12:20
    2012年9月5日 12:20