locked
Application Virtualization セットアップガイドの捕捉 RRS feed

  • 全般的な情報交換

  • Application Virtualization 4.5 ドキュメント(http://technet.microsoft.com/ja-jp/appvirtualization/cc843994.aspx )に公開されている「Application Virtualization セットアップガイド(リリース日/2008-11-11)」の手順では、Application Virtualization Management Server からのデフォルトアプリケーション配布が出来ないので、対処方法を紹介します。

    <P.16>
    4.1.3 Microsoft SQL Server 2005 Express Edition SP2 のインストール
    画面キャプチャーが実際のインストールと違っていますが(RTMのキャプチャが使われている?)、ここをご覧になっている方は問題無いでしょう。

    <P.28>
    4.2.1 System Center Application Virtualization Server のインストール
    手順通りだと、インストールした SQL Server 2005 Express Edition の SQL Browser が無効になっているので、構成データベースが作れない事があります。
    その場合は、SQL Browser サービスを自動起動にして、手動でサービスを起動します。

    <P.38>
    17. Application Virtualization Management Console への接続
    接続時に「0000C800」エラーになって接続が出来ません。
    対処方法は僕のサイトに書いておきましたので、そちらを参照してください。
    http://www.vwnet.jp/mura/Soliloquy/200902.htm

    <P.49>
    4.5 System Center Application Management Server の動作確認
    http配信の設定をしていますが、ファイル共有で配布する場合は以下のように設定します(UNC指定)。
    OSD Path:
    \\appsrv01\content\DefaultApp.osd
    Icon Path:
    \\appsrv01\content\DefaultApp.ico

    <P.51>
    Application Virtualization Management Server サービスを手動で起動する。
    ここにも書き込みがありますし、安納さんの blog (http://blogs.technet.com/junichia/archive/2008/10/29/3144050.aspx )にもあるように、OS 起動時の SQL 起動に時間がかかるため Application Virtualization Management Server サービスの起動に失敗します。

    このため、OS を再起動する度に手動でサービスを起動する必要があります。(工夫をすれば何とかなりそうな気も)

    # Windows Server 2008 ならは遅延開始で解決できるんですけどね
    MVP for Virtual Machine : Networking
    2009年4月3日 6:24

すべての返信

  • 初めまして。

    私も、初めにテスト環境を作った時に「はまった」ので、何点か情報提供させてもらいます。

    <P.38>
    17. Application Virtualization Management Console への接続
    接続時に「0000C800」エラーになって接続が出来ません。
    対処方法は僕のサイトに書いておきましたので、そちらを参照してください。
    http://www.vwnet.jp/mura/Soliloquy/200902.htm


    このエラーは、下記KBの内容で対処できました。
     ※Manegement Web ServiceがSQLServerに接続できないと駄目ですね。
     http://support.microsoft.com/kb/930565/en-us

    <P.49>
    4.5 System Center Application Management Server の動作確認
    http配信の設定をしていますが、この設定では配信が出来ません(IISのログを見ると404エラーとなっていますし、IE で直接開こうとしても404になってダメです)ので、ファイル共有(UNC指定)で配布します。
    OSD Path:
    \\appsrv01\content\DefaultApp.osd
    Icon Path:
    \\appsrv01\content\DefaultApp.ico

    IISにhttp経由でアクセス出来ていないと駄目なので、
    クライアントPCのIEから
    ・http://appsrv01.appvdomain.local/appv/DefaultApp.osd
    ・http://appsrv01.appvdomain.local/appv/DefaultApp.ico
    にアクセス出来るか確認すると良いかと思います。

    上手く行かない場合は、IEのプロキシ設定を疑うか、サーバー側のIISの設定を確認した方が良いですね。
    <P.35>
    4番の手順~P.38の15番の手順までが正しく設定されているか確認

    私は、これでhttp経由OKでした。

    私が、初めにはまったのは、DefaultApp.osdファイルをメモ帳で開いて編集することを忘れたことですね。
    <P.51>10番の手順を忘れてました。
    RTSPS→RTSP
    322→554




    tune
    2009年4月3日 9:59
  • > 私は、これでhttp経由OKでした。
    .osd と同じフォルダにテキストファイルを配置したら、そちらはアクセス出来たので、この設定では http ダメなのかと思っていました。
    もう一度確認してみます。
    -----< 2009/04/07 追記 >-----
    もう一度環境を作りなおしたら(
    全く同じ設定をしたつもりでしたが )、今度は http 配信できました。
    何か設定をミスしていたようです
    ファイル共有の手順を消してしまうのももったいないので、情報を残しつつ訂正しました

    MVP for Virtual Machine : Networking
    2009年4月4日 4:24