none
CドライブにVistaがインストールされた状態で、DにXPを入れたら起動しなくなりました。 RRS feed

  • 質問

  • はじめまして、よっしーと言います。

    VistaとXPでデュアルブート環境を作ろうと思い、CドライブにVistaがインストールされている状態で、DドライブにXPをインストールしたら「error loading operating system」と表示されて、起動しなくなってしまいました。

    http://support.microsoft.com/default.aspx?scid=kb%3Bja%3B919529 を読んでみたのですが、機械翻訳みたいでよく分かりません。

    どなたか解決方法をご存知の方がいらっしゃいましたら、アドバイスをお願いします。

    解決方法が書いてあるHPでも構いません。

    よろしくお願いします。

    2007年1月24日 4:16

回答

  • となるとやはりシステムパーティションがアクティブになっていないのだと思います。
    次の手順でアクティブにしてみてください。

    1) VistaのDVDで起動して「Windowsのインストール」の最初の画面で「次へ」をクリック
    2) 次の画面で「コンピュータを修復する」をクリック。
    3) 「システム回復オプション」画面で「次へ」をクリック
    4) 次の画面で「コマンドプロンプト」をクリック
    5) コマンドプロンプト画面で次のコマンドを入力
      diskpart
      select disk 0
      select partition 1
      active
      exit
      exit
    6) VistaのDVDを取り出して「再起動」をクリック

    これでXPのインストールが続行されると思います。

    2007年1月24日 8:12
  • Vistaの場合、C:ドライブとかD:ドライブとか言ってもそれが実際にどのパーティションなのか分からないので、確認ですが、
    1番目のパーティションにインストールしてあったVistaのイメージバックアップを取り、それを2番目のパーティションに復元できるか、という意味でしょうか?
    それであれば、復元自体はできるかもしれませんが、正常な動作ができないでしょう。
    2007年1月25日 2:23
  • VistaとWindows XPのデュアルブートに関しては

    http://www.corso-b.net/itaya/TIPS/Vista/Vista02.html

    を参照してください。

     

    2007年5月18日 14:41

すべての返信

  • VistaがインストールされているマシンにXPをインストールすると、XPだけが起動できる状態になりますが、よっしーさんの場合はXPも起動しないということですか?
    XPのインストールは正常にできたのでしょうか?
    「error loading operating system」というメッセージはMBRが出しているメッセージなので、システムパーティション (通常はC:ドライブ) がアクティブになっていないようですが...
    2007年1月24日 6:27
  • ご返答ありがとうございます。

    XPのインストール中の再起動の段階で「error loading operating system」が表示され、起動しなくなってしまいました。

    したがって、XPのインストールは完了していない状態だと思います。

    現状、VistaもXPもどちらも起動しません。

    2007年1月24日 6:54
  • となるとやはりシステムパーティションがアクティブになっていないのだと思います。
    次の手順でアクティブにしてみてください。

    1) VistaのDVDで起動して「Windowsのインストール」の最初の画面で「次へ」をクリック
    2) 次の画面で「コンピュータを修復する」をクリック。
    3) 「システム回復オプション」画面で「次へ」をクリック
    4) 次の画面で「コマンドプロンプト」をクリック
    5) コマンドプロンプト画面で次のコマンドを入力
      diskpart
      select disk 0
      select partition 1
      active
      exit
      exit
    6) VistaのDVDを取り出して「再起動」をクリック

    これでXPのインストールが続行されると思います。

    2007年1月24日 8:12
  • ITAYA さん、せっかくアドバイス頂いたのですが、既に再インストールをしてしまい、試すことが出来ませんでした。

    で、再インストールの際にCドライブのVistaのイメージを「コンピュータのバックアップ」でバックアップしました。

    そして、もともと「CにVista、DにXP」だったものを、パーティションを切り直し「CにXP、DにVista」にしました。

    そしてここからが質問なのですが、もともとCドライブでバックアップしたイメージを使って、Dドライブに入れなおしたVistaを復元することは出来るのでしょうか?

    もし分かりましたらアドバイスをお願いします。

    2007年1月25日 2:14
  • Vistaの場合、C:ドライブとかD:ドライブとか言ってもそれが実際にどのパーティションなのか分からないので、確認ですが、
    1番目のパーティションにインストールしてあったVistaのイメージバックアップを取り、それを2番目のパーティションに復元できるか、という意味でしょうか?
    それであれば、復元自体はできるかもしれませんが、正常な動作ができないでしょう。
    2007年1月25日 2:23
  • 私もまったくおんなじ状況になりました。なんなのでしょう。。
    2007年5月18日 7:55
  • ITAYAさん

    まだ困っているので、仰せのとおりやってみました。

     おかげでvistaは起動するようになりましたが、XPのインストールは続行されてないように見えます。

     

    またお分かりになりましたらお願いします。

    ありがとうございました。

    2007年5月18日 11:24
  • VistaとWindows XPのデュアルブートに関しては

    http://www.corso-b.net/itaya/TIPS/Vista/Vista02.html

    を参照してください。

     

    2007年5月18日 14:41
  • 私は、C:にXP Home

        D:にVISTA

    をインストールしました。

    バックアップファイルからデーター移行を試みましたが失敗しました。

     

    そこで、D:VISTAを残したままC:のXPだけを再セットアップ。

    しかし、XPだけしか起動しなくなる。

     

    そこで、Bootproをインストールして試みました、がうまくいきませんでした。

     

    この場合、どこを間違ってるのでしょうか?

    教えていただけないでしょうか?

     

    2007年6月14日 5:38
  • microsoft.public.jp.windows.vistaでも同じ質問をしているようですが、
    どういう操作をしたらどうなったという、具体的なことを書いてくれないと、状況がさっぱりわかりませんよ。

    「バックアップファイルからデーター移行を試みた」とは、具体的に何をやったのでしょうか? 「失敗」とはどういう状況になったのでしょうか?
    「XPだけを再セットアップ」とは具体的にどういう方法で行ったのでしょうか?
    「Bootproをインストールして試みた」とは具体的に何をやったのでしょうか? 「うまくいきませんでした」とはどういう状態なのでしょうか? エラーメッセージが表示される場合は、それを省略せずに書いてください。

    ; XPのインストールの際に、C:ドライブをフォーマットしてしまったのではないだろうか...

    2007年6月14日 8:43
  • ありがとうございます。

     

    メーカー製パソコンのXP Homeのもの。

    C:XP Home(sp2)

    E:メーカーのTV機能(通常違うOSのためみえない)

    D:メーカーのデーターバックアップ

    であったものを、

    (昨年、11月RC-1をC:にインストールした。)

    2007年1月15日に再セットアップできないことに気づきました。

    (VISTAによってE:を認識しなくなり、不具合多発。)

    ・・・・・・でメーカーに再セットアップを有料にて再セットアップをした。

    2007/02/25に

    C:XP Home

    D:VISTAをインストールする。

    C:125GV、D:125GVにわけました。(再セットアップデスクをその時作った。)

    デュアルブートにしました。

    しかし、いろいろしているうち不具合のため、

    D:にフォーマットしてVISTAをクリーンインストール。

    2007/06/12

    D:を再びVISTAをクリーンインスト-ルしてC:にXP Homeを再セットアップして

    このスレッドを読み短絡的にBootpro3.1にてブートの出来るようできなかったのです。

    以上経過です。

    また、続きを書きます。

    2007年6月14日 10:29
  • 続きです。

     

    バックアップファイルのBKF.ファイルをVISTAに転送するのに、

    ファイル、フォルダーへの設定をよく知らずに安直にD:へバックアップしてしまいました。

    ダーとD:に入ってしまい。

    削除しようにも3000ファイルぐらいあるのであきらめました。

    3時間くらいでこれはいけないことに気付きました。(たぶん1カ月は要するのではないでしょうか。)

    ファイルを削除するのに、いちいち、これはいいですかと聞いてきます。

    それから、VISTA(バックアップの復元)で同じように復元したからたいへんでした。

     

    それで、DドライブをフォーマットしてVISTAをクリーンインストールしました。

    そして、Cドライブをみるとそのドライブにもダーとデーターが一括で入ってました。

     

    そこから、Cドライブのみを再セットアップしました。

    すると、CドライブのXPだけが起動するようになりました。

     

    旧OSをあとからインストールするとブートファイルが書き換わると書いてあったので

    このスレを参考に試みましたが、書いてあるとりにAppyのところまでいったのですが

    再起動すると、やはりXPしか起動しなかったのです。

     

    どうせならと思い

    もう一度、VISTAをD:にクリーンインストールしてみました。

    ブートファイルできて、旧WindowsとVISTAが起動するようになりました。

     

    お騒がせしてすみません。

    旧データーから再構築するのに、丸2日かかりました。

     

    理解不足ですみません。

    ありがとうございました。

    以上です。

    2007年6月14日 14:05
  • こんにちは、フォーラムオペレーターの鈴木裕子です

     

    投稿からかなり時間が経過したスレッドでしたが、ITAYA さんの丁寧な回答(とリンク先の情報)を、Forumをご覧の他の方々にも活用していただきたく、勝手ながら私の方で回答チェックを付けさせていただきました。

    質問者のよっしー さんは、チェックの解除ができますので、もし不適切な場合は遠慮なく修正してください。

     

    これからもたくさんの有用な情報をお待ちしております情報交換の場としてぜひForumをご活用ください!
    2009年1月15日 7:57
    モデレータ