none
Windows7の「バックアップと復元」でシステムイメージのバックアップ中に「0x80070020」エラーが発生する。 RRS feed

  • 質問

  • すでにTS1213さんが注釈(※1)でご質問され、自己解決されているものと内容的には同じなのですが、私の環境では記載内容と同等の手段を用いても解決しません。手詰まり状態で大変困っていますので、改めて質問させていただきます。

    症状はTS1213さんと同じく、Windows 7(Pro)標準装備の「バックアップと復元」機能を用いてシステムイメージを作成する段階で、「0x80070020」エラーにより失敗します。

    私の場合、SSDをシステムドライブ(C:)として使用している関係上、USERSフォルダは注釈(※2)記載のページを参考に、システムドライブからデータドライブ(D:)のHDD1移動させ、レジストリの変更およびmklinkコマンドによるマウント先の指定も行っています。

    ここで一度構成を整理しますと、以下の通りです。
    (C:)SSD(120GB中82GB使用) ⇒ USERSフォルダを除くシステムファイル用
    (D:)HDD1(200GB中150GB使用) ⇒ USERSフォルダ
    (E:)HDD2(250GB未使用) ⇒ バックアップ用

    ただ、都合によりバックアップドライブ(E:)として使用予定であったHDD2と中身およびドライブ文字を入れ替えています。入れ替えたあと、HDD1は完全フォーマットを行いました。
    注釈(※2)記載のレジストリ変更項目は、すでに(D:)のUSERSフォルダを指す値になっていましたので、改めて変更は行っておりませんし、mklinkコマンドも実行していません。
    一部のレジストリで(E:)を指している部分があったようですが、後述するレジストリ修復により、現在はなくなっています。

    現在の構成をまとめますと、以下の通りです。
    (C:)SSD(120GB中82GB使用) ⇒ USERSフォルダを除くシステムファイル用
    (D:)HDD2(250GB中150GB使用) ⇒ USERSフォルダ
    (E:)HDD1(200GB未使用) ⇒ バックアップ用

    TS1213さんのフォーラムを参考に、セキュリティソフトの停止、別の管理者アカウントによる実行、「Windows Live One Care (Windows7用)」によるクリーンアップ、フリーソフト「Free Window Registry Repair」によるレジストリの修復・最適化は再起動を重ねつつ何度も実施したのですが、(E:)へのバックアップは「プロセスはファイルにアクセス出来ません。別プロセスで使用中です。(0x80070020)」とのエラー表示で失敗します。確かに、完全フォーマットされて空のはずの(E:)が、たまに動いているときがあります。これが何らかのプロセスによるアクセスなのか、HDD自身のハードウェア的なメンテナンス機能なのかは分かりません。
    また、イベントビューアのアプリケーションログにより、イベントID(E:)が「4104」であることは確認できましたが、これの意味するところは私では調べ切れませんでした。

    TS1213さんの場合と大きく異なる点は、クリーンインストール段階でのバックアップを行っておらず、現在の構成になって初めて実行した点です。今となっては最初にバックアップを取っておけばよかった後悔していますが、SSDへの再インストールは寿命を著しく縮めそうで、躊躇しています。もちろん解決できなければ最終手段として再インストールしますが、構成はやはりUSERSフォルダをデータドライブ(D:)のHDD2に移動させるつもりです。

    ご迷惑をお掛けして申し訳ありませんが、何かアドバイスをいただければと思い、投稿させていただきます。
    不足の情報等ございましたら、ご指摘ください。

    以上、よろしくお願いいたします。

    注釈(※1)
    Windows 7 バックアップと復元でシステムイメージの作成が「エラー0x80070020」で失敗する
    http://social.technet.microsoft.com/Forums/ja-JP/w7itprogeneralja/thread/7761b690-8a8d-4b82-9976-a0cedaec44de

    注釈(※2)
    「Windows7のUsersフォルダをDドライブに移動する」
    http://taiseiko.blog.so-net.ne.jp/2009-11-01
    2010年3月14日 5:47

回答

  • Sercher さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ご質問の件に関しまして、私の方で調べてみましたところ、国内外の複数のサイトで、
    Sercher さんが遭遇されているエラーに関する情報が投稿されていたのですが、、、
    その大半はセキュリティ ソフト絡みのものでした。。。 (-"-)

    Sercher さんはすでにセキュリティ ソフトの停止も試されているとのことですので、
    それ以外の情報を選んでみましたところ、参考になりそうな情報が見つかりました。
    http://social.answers.microsoft.com/Forums/en-US/vistahardware/thread/8b75b27c-76ac-45f6-aef0-0959f0988c1a (英語)

    こちらは、英語版 Answers フォーラムに投稿された質問で、Windows Vista で発生したエラーに関する質問ですが、その内容から判断すると、Sercher さんのケースでも当てはまる可能性があります。
    参考までに、問題を自己解決された質問者の jmitch2192 さんの2009年5月12日(火)午前1時17分付けの投稿内容を和訳して紹介させていただきますね。 (^^)

    「問題が解決しました。 問題はハード ドライブにありました。 皆さんは同じ方向に向いていたようです。 私は、異なる2種類のバックアップ ユーティリティの試用版をダウンロードしました。 1つはバックアップを作成するためにボリューム シャドー コピー (VSS) を使用し、もう1つは VSS を使用しませんでした。 VSS を使用するユーティリティは毎回入出力エラーと共に失敗しましたが、もう1つは成功しました。 このサード パーティ製ソフトから生成されるエラー コードに関するスレッドを調べたところ、ハードドライブの製造元から診断ツールをダウンロードし、そのドライブをチェック/修復することを提案しているスレッドを見つけました。 そのとおりにすることで、バックアップは完全に成功しています!」

    また、もう1つ参考になりそうな情報が同じく英語版 Answers フォーラムに投稿されていましたので、
    こちらもリンクを紹介させていただきますね。
    http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/a4abfd13-edcd-44e5-b658-2440672f1f90 (英語)

    もし英語の内容で不明な箇所がありましたら、お気軽にお尋ねください。 (^^)

    こちらの情報がお役に立てることを願っています。
    それでは、また! (^_^)/


    _______________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    • 回答としてマーク Sercher 2010年3月19日 11:05
    • 回答としてマークされていない Sercher 2010年3月26日 8:25
    • 回答としてマーク 三沢健二Moderator 2010年3月29日 8:54
    2010年3月16日 2:37
    モデレータ

すべての返信

  • Sercher さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。

    ご質問の件に関しまして、私の方で調べてみましたところ、国内外の複数のサイトで、
    Sercher さんが遭遇されているエラーに関する情報が投稿されていたのですが、、、
    その大半はセキュリティ ソフト絡みのものでした。。。 (-"-)

    Sercher さんはすでにセキュリティ ソフトの停止も試されているとのことですので、
    それ以外の情報を選んでみましたところ、参考になりそうな情報が見つかりました。
    http://social.answers.microsoft.com/Forums/en-US/vistahardware/thread/8b75b27c-76ac-45f6-aef0-0959f0988c1a (英語)

    こちらは、英語版 Answers フォーラムに投稿された質問で、Windows Vista で発生したエラーに関する質問ですが、その内容から判断すると、Sercher さんのケースでも当てはまる可能性があります。
    参考までに、問題を自己解決された質問者の jmitch2192 さんの2009年5月12日(火)午前1時17分付けの投稿内容を和訳して紹介させていただきますね。 (^^)

    「問題が解決しました。 問題はハード ドライブにありました。 皆さんは同じ方向に向いていたようです。 私は、異なる2種類のバックアップ ユーティリティの試用版をダウンロードしました。 1つはバックアップを作成するためにボリューム シャドー コピー (VSS) を使用し、もう1つは VSS を使用しませんでした。 VSS を使用するユーティリティは毎回入出力エラーと共に失敗しましたが、もう1つは成功しました。 このサード パーティ製ソフトから生成されるエラー コードに関するスレッドを調べたところ、ハードドライブの製造元から診断ツールをダウンロードし、そのドライブをチェック/修復することを提案しているスレッドを見つけました。 そのとおりにすることで、バックアップは完全に成功しています!」

    また、もう1つ参考になりそうな情報が同じく英語版 Answers フォーラムに投稿されていましたので、
    こちらもリンクを紹介させていただきますね。
    http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/a4abfd13-edcd-44e5-b658-2440672f1f90 (英語)

    もし英語の内容で不明な箇所がありましたら、お気軽にお尋ねください。 (^^)

    こちらの情報がお役に立てることを願っています。
    それでは、また! (^_^)/


    _______________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    • 回答としてマーク Sercher 2010年3月19日 11:05
    • 回答としてマークされていない Sercher 2010年3月26日 8:25
    • 回答としてマーク 三沢健二Moderator 2010年3月29日 8:54
    2010年3月16日 2:37
    モデレータ
  • 解決しました!

     

    まず、ご紹介いただいたフォーラムのうち、1つ目のハードディスクの診断につきましては、Windows標準のエラーチェックを使用し、問題がないことが確認できました。

    そこで2つ目のフォーラムに記載されていた、「バックアップの対象」を「自分で選択する」にチェックを入れ、次の画面で「新規作成ユーザーのデータをバックアップする」の項目だけチェックを外してバックアップを実行してみたところ、正常終了いたしました。その後、もう一度バックアップを実行してみましたが、今のところ問題ありません。

     

    私の場合、質問文に注釈2で記載したページの説明に従って「C:\USERS」を「D:\USERS」に移動させるためや、今回のバックアップ失敗への対処のため、2、3度ユーザーアカウントの追加→削除を繰り返していました。そのとき何らかのプロセスがバックアップ対象の(E:)ドライブにアクセスする設定が有効な状態で残っているのかもしれません。(E:)ドライブはバックアップファイルの格納先にしか使用していませんが、今でもたまに何らかのプロセスがアクセスしているのか、動作音が聞こえるときがあります。

    (調査方法が間違っているかもしれませんが)タスクマネージャのプロセスタブで、「イメージパス名」と「コマンドライン」の列を表示させて(E:)にアクセスしているプロセスがないか確認してみましたが、見当たりませんでした。

    バックアップ失敗の原因を明確にしておきたいので追加で質問させていただきますが、ほかに何のプロセスが(E:)にアクセスしているのか調べる方法はありますでしょうか?

    また、私が見当違いな点を疑っているようでしたら、ご指摘いただければ幸いです。

     

    まだ復元の操作は行っていませんが、時間があるときにテストしてみたいと思います。

    そのときに何か問題が発生するようであれば、別件としてフォーラムを立ち上げ、質問させていただきます。

     

    とりあえずバックアップは作成できたということで、少し安心できました。ありがとうございます。

    お手数をお掛けして申し訳ありませんが、上記追加質問の件、よろしくお願いいたします。

     

    2010年3月19日 9:33
  • こんにちは、フォーラムオペレーターの三沢健二です。

    Sercher さん、問題が解決されたようで良かったです。

    まだ少し疑問が残られているようですが、弊社 服部 の案内した情報が参考になられたのではないかと思いましたので、私の方で [回答としてマーク] のチェックを付けさせていただきました。

    なお、プロセスの動作を確認する場合には、Process Monitor などを使用すると何か分かる場合があります。
    (他にも解析ツールはありますが、いずれにしても手間と時間、スキルが必要となります。。。)


    それでは、また何かありましたら、ぜひ TechNet フォーラムをご利用ください。

    ______________________________________
    マイクロソフト株式会社 フォーラム オペレーター 三沢健二

    2010年3月29日 8:55
    モデレータ
  • ご回答ありがとうございました。

     

    ご紹介いただいたツールを使用してみたところ、定期的にExplorerがアクセスしている他は、

    (E:)ドライブにアクセスしている不審なアプリケーション等はありませんでした。

     

    原因を理解するには、私の知識ではまだまだ無理なようですが、

    とりあえずその後も問題なくバックアップできていますので、安心しています。

     

    サポートいただき、誠にありがとうございました。

    今後ともよろしくお願いいたします。

     

    2010年3月31日 19:22