none
Exchange2010とExchangeOnlineのハイブリッドでの移行について RRS feed

  • 質問

  • お世話になっております。
    Exchange2010からOffice365ExchangeOnlineへのメールボックス移行についてお力を貸していただきたく、投稿させていただきました。

    【環境】
    ・Office365にはADFS、WAPを用いたフェデレーション認証、シングルサインオンを構築済み
     ・オンプレミスにはExchange2010を導入しており、Office365Exchange Onlineとのハイブリット構成
    ・Outlookクライアントは2010をメインで使用。(社内利用)

    【質問内容】
    オンプレのメールボックスをリモートメールボックスに変換したが、手順を変えてしまったためか、365のメールボックスにメールが届かない

    【質問背景】
    Office365を運用開始した際、先行ユーザーとしてOffice365に何人かユーザーを作成してしまったため、同期をした際、365とオンプレの両方にメールボックスを持つユーザーが存在しています。
    この状態ですとExchange管理センターでbatを作成して移行するという方式が取れなかったため、以下のサイトを参考に手動で移行を行いました。
    https://blogs.technet.microsoft.com/exchangeteamjp/2017/07/10/mailboxes-are-created-in-on-premise-and-exchange-online/

    ただし、これだけではメールが飛ばず、追加で以下の作業を行ったところ、メールが飛ぶようになりました。
    http://ebi.dyndns.biz/exchange/2013/03/%e3%82%aa%e3%83%96%e3%82%b8%e3%82%a7%e3%82%af%e3%83%88%e3%82%92%e5%89%8a%e9%99%a4%e3%81%97%e3%81%a6%e3%83%a1%e3%83%bc%e3%83%ab%e3%82%a2%e3%83%89%e3%83%ac%e3%82%b9%e3%82%92%e5%bc%95%e3%81%8d%e7%b6%99/

    【飛ぶ際の手順】
    ①同期を停止
    ②メールボックスを無効化
    ③リモートメールボックスに変換
    ④同期再開
    ⑤365のメールボックスにあるLegacyExchangeDNをオンプレのX500に設定
    ⑥メール相通確認(届く)
    ⑦365でExchangeGUIDがオンプレと違うとエラーが出ているので、オンプレのExchangeGUIDを直す

    【飛ばなかった際の手順】
    ①同期を停止
    ②メールボックスを無効化
    ③リモートメールボックスに変換
    ④365でExchangeGUIDがオンプレと違うとエラーが出てしまうので、先にオンプレのExchangeGUIDを直す
    ⑤同期再開
    ⑤365のメールボックスにあるLegacyExchangeDNをオンプレのX500に設定
    ⑥メール相通確認(届かない)

    以上のことから、原因は同期の前にExchangeGUIDを変えてしまったことだと思うのですが、
    ここからメールが届くようするにはどうしたらよいでしょうか?

    現状は、Conect-Mailboxを使用してメールボックスを復元してあります。
    その際、EchangeGUIDも元の値に戻っております。
    (すでに一度ExchangeGUIDを同期してしまったためか、Office365上ではExchangeGUIDが違うとエラーが出ている)

    以上、よろしくお願いいたします。

    2018年6月22日 10:46