locked
Essentialsのインストールに失敗する RRS feed

  • 質問

  •  

    前提条件はすべてクリアーし、ファイルのコピーが始まるのですが、

    途中からプログレスバーが進まなくなり、せっかくインストールされた

    SQL2005EXPRESSまで削除されてエラーになります。

    (ただ、「プログラムの追加と削除」を見ると、

     「Microsoft SQL Server Native Client」 と

     「System Center Essentials 2007」 は

     残っています)

    セットアップ ログ ファイル を見ると、

     

    Property(S): resolvedMG = 1
    Property(S): OutOfDiskSpace = 0
    Property(S): OutOfNoRbDiskSpace = 0
    Property(S): PrimaryVolumeSpaceAvailable = 0
    Property(S): PrimaryVolumeSpaceRequired = 0
    Property(S): PrimaryVolumeSpaceRemaining = 0
    Property(S): REPORT_SERVER_FULL_HTTP_PATH_VALID = 0
    Property(S): FailedMsgProperty = CheckHttpAddressResponse: Failed Status Code of リモート サーバーがエラーを返しました: (503) サーバーを使用できません
    MSI (s) (08:C4) [20:22:09:409]: Note: 1: 1708
    MSI (s) (08:C4) [20:22:09:409]: 製品: System Center Operations Manager 2007 Reporting Server -- インストールは失敗しました。

    MSI (s) (08:C4) [20:22:09:409]: Cleaning up uninstalled install packages, if any exist
    MSI (s) (08:C4) [20:22:09:409]: MainEngineThread is returning 1603
    MSI (s) (08:74) [20:22:09:518]: Destroying RemoteAPI object.
    MSI (s) (08:54) [20:22:09:518]: Custom Action Manager thread ending.

     

    と表示されています。

     

    <環境>

    Windows2003R2SP2。WindowsUpdateにて、IE7以外の全ての

    パッチを適用。

     

    OSからの入れ直しを何度も行っていますが、全くダメです。

    お助けください。

     

    よろしくお願いいたします。

     

    2008年3月13日 12:03

回答

  • こんにちは。

     

    私の所でも全く同じ症状が出ましたので昨日からいろいろと調べていましたところ、

    ログ等を見る限り、これらの症状ではないかと思っています。

     

    http://support.microsoft.com/kb/936219/

    http://support.microsoft.com/kb/936481/

     

    完全修飾のドメイン名(FQDN)とプライマリ DNS サフィックスが一致しないドメインが原因で発生する。

    といったところでしょうか?

     

    残念なことに、リモートで操作していたサーバがうまく再起動できずに操作不能となったため

    これ以上の確認ができませんでした。

     

    明日以降にいろいろ試してみようと思っておりますが、参考までにご報告させていただきました。

     

    2008年3月16日 12:06
  • 自己レスです。

     

    同じ内容ですが、こちらがEssentials用の説明みたいですね。

    http://support.microsoft.com/kb/937831/

     

    ここにあるように、私の環境の場合、ドメイン名(FQDN)が local.domain.co.jp のような感じで

    NETBIOSのドメインが、 DOMAIN となっています。

    これが原因で失敗すると読めるのですが、まだパッチが届いていないので確認は取れていません。

     

     

     

    追記:請求した結果、日本語版のパッチは無いそうです。他の回避法があればいいんですが・・・

    追記2:KB936481のパッチはありませんでしたが、上のKB937831のパッチはいただけました。 
    2008年3月17日 4:42
  • 上記パッチにて、インストールが正常に完了する事を確認しました。

    \setup\i386\QFEHandler.dll を置換するパッチでした。

    手動でインストールする必要がありますので、詳細はKBの説明をご覧下さい。

     

     

    2008年3月18日 11:23
  • こんにちは。

     

    ダメでしたか。

    原因を特定するためにSCEReportingN.logファイルに、KB937831のエラー記録が残っているか確かめて見てください。

     「SetPropertiesToManagementServerActionAndSDKAccountCA error」 

    という記録が残っているかどうかで判断できると思います。

     

    残っていない、またはKBの内容と違うようであれば、他の原因かもしれませんね。

    残っている場合は、パッチの当て方が間違っているのではないかと思います。

    ダブルクリックするだけではダメで、%temp%から、手動でファイルをコピーする必要があります。

     

    具体的には、パッチをダブルクリックしてインストール後、

    c:\Documents and Settings\administrator.DOMAIN\Local Settings\Temp\TempQFE\

    のフォルダに展開された、QFEHandler.dll を

    インストールメディアの Setup\i386\ にある同名のファイルに上書きコピーする必要があります。

    CDROM等からインストールしている場合は、当然上書きできませんので、セットアップファイル自体を

    HDD等にコピーしてからインストールする必要があります。

     

    とはいえ、こちらでもまだまだ問題がおこっています・・・。

    SCE2007はお手軽に入れるには、ちょっとハードルが高い感がどうしてもしますね。

    しかし便利になることを期待しています。

    がんばってください。

    2008年3月21日 7:31

すべての返信

  • こんにちは。

     

    私の所でも全く同じ症状が出ましたので昨日からいろいろと調べていましたところ、

    ログ等を見る限り、これらの症状ではないかと思っています。

     

    http://support.microsoft.com/kb/936219/

    http://support.microsoft.com/kb/936481/

     

    完全修飾のドメイン名(FQDN)とプライマリ DNS サフィックスが一致しないドメインが原因で発生する。

    といったところでしょうか?

     

    残念なことに、リモートで操作していたサーバがうまく再起動できずに操作不能となったため

    これ以上の確認ができませんでした。

     

    明日以降にいろいろ試してみようと思っておりますが、参考までにご報告させていただきました。

     

    2008年3月16日 12:06
  • 自己レスです。

     

    同じ内容ですが、こちらがEssentials用の説明みたいですね。

    http://support.microsoft.com/kb/937831/

     

    ここにあるように、私の環境の場合、ドメイン名(FQDN)が local.domain.co.jp のような感じで

    NETBIOSのドメインが、 DOMAIN となっています。

    これが原因で失敗すると読めるのですが、まだパッチが届いていないので確認は取れていません。

     

     

     

    追記:請求した結果、日本語版のパッチは無いそうです。他の回避法があればいいんですが・・・

    追記2:KB936481のパッチはありませんでしたが、上のKB937831のパッチはいただけました。 
    2008年3月17日 4:42
  • 上記パッチにて、インストールが正常に完了する事を確認しました。

    \setup\i386\QFEHandler.dll を置換するパッチでした。

    手動でインストールする必要がありますので、詳細はKBの説明をご覧下さい。

     

     

    2008年3月18日 11:23
  • NDNDNDさま

     

    情報ありがとうございます。

     

    当方も同じパッチを入手して試してみました。

     

    ・・・

     

    ダメでした。どうやら違う原因のようです。

     

    もう少し、がんばって見ます。

    2008年3月20日 8:24
  • こんにちは。

     

    ダメでしたか。

    原因を特定するためにSCEReportingN.logファイルに、KB937831のエラー記録が残っているか確かめて見てください。

     「SetPropertiesToManagementServerActionAndSDKAccountCA error」 

    という記録が残っているかどうかで判断できると思います。

     

    残っていない、またはKBの内容と違うようであれば、他の原因かもしれませんね。

    残っている場合は、パッチの当て方が間違っているのではないかと思います。

    ダブルクリックするだけではダメで、%temp%から、手動でファイルをコピーする必要があります。

     

    具体的には、パッチをダブルクリックしてインストール後、

    c:\Documents and Settings\administrator.DOMAIN\Local Settings\Temp\TempQFE\

    のフォルダに展開された、QFEHandler.dll を

    インストールメディアの Setup\i386\ にある同名のファイルに上書きコピーする必要があります。

    CDROM等からインストールしている場合は、当然上書きできませんので、セットアップファイル自体を

    HDD等にコピーしてからインストールする必要があります。

     

    とはいえ、こちらでもまだまだ問題がおこっています・・・。

    SCE2007はお手軽に入れるには、ちょっとハードルが高い感がどうしてもしますね。

    しかし便利になることを期待しています。

    がんばってください。

    2008年3月21日 7:31
  • こんにちは!
    フォーラム オペレータの鈴木裕子です

    NDNDND さん、大変丁寧な回答をありがとうございました!

     

    komatta_chan さん、フォーラムのご利用ありがとうございます。

    その後いかがでしょうか?

     

    NDNDND さんの回答が、内容的に有用な情報と思われましたので、

    私のほうで回答済みチェックをつけさせていただきました。

    回答済みチェックが付くことにより、有用な情報を探している方が情報を見つけやすくなります。
    有用な情報と思われる回答があった場合は、なるべく回答済みボタンを押してチェックを付けてくださいね

     

    komatta_chan さんはチェックを解除することもできますので、

    もし不適切でしたら、修正をお願いします。

    また、引き続き疑問や質問がありましたら、遠慮なく投稿してください。

     

    それでは!

    2008年3月26日 8:41
    モデレータ