none
SCCMサーバー自身でEndpoint Protectionが有効にならない RRS feed

  • 質問

  • お世話になります。

    現在以下の評価環境でSCCMの検証をしているのですが表題の件で困っております。

    原因をご存じの方がいらっしゃいましたらアドバイスいただければ幸いです。

    ■SCCMサーバー

    OS:Windows Server 2016 Std

    DB:SQLServer 2016 SP2

    SCCM:Endpoint Configuration Manager(1902→1910へ)

    ■管理対象コンピューター

    OS:Windows Server 2016 Std

    ■DC

    OS:Windows Server 2016 Std

    Windows Defenderを管理するためにEndpoint Protectionを有効にしていて

    SCCMサーバー以外の管理対象コンピューターは、DCも含めすべて正常なステータスで問題ありません。

    SCCMサーバー自身だけ管理コンソール上で”Endpoint Protectionの状態”が”有効”にならず”空白”のままで

    定義ファイルのバージョンも取得されません。

    その他のステータスに関しては正常な管理コンピューター同様に

    ”Endpoint Protectionの展開状態”のステータスは”マネージド”

    ”Endpoint Protectionのポリシー適用状態”のステータスは”成功”

    となっており管理コンソールからのスキャン実行も可能ですし、定義ファイルも配布できております。

    管理コンソール上だけの問題だけであればまだ許容できるのですが、

    この状態だと”監視”のEndpoint Protectionで定義ファイルが取得できていない扱いとなり

    リスクのあるコンピューターとして扱われるため正常なコンピューター同様にすべてのステータスを取得できる状態にしたく。。。

    再構築なども何度かしてみたのですが毎回同じ結果となってしまい困っております。

    2020年3月2日 8:34

回答

  • Endpoint Protectionの状態が有効になりました。
    いろいろとやったので、どれが有効かわからないですが記載しておきます。
    ①境界等のSCCMサーバの基本的な設定の見直し。
    ②SCCMクライアントの再インストール(プッシュインストールで既にインストールされている場合はインストールする前にアンインストールするオプションにチェック)
    ③プログラムのアンインストールから「System Center Endpoint Protection」の削除
    ④以下のコマンドを実行して「System Center Endpoint Protection」のインストール
     「"C:\Program Files\Microsoft Configuration Manager\Client\SCEPInstall.exe" /POLICY "C:\Program Files\SMS_CCM\EPAMPolicy.xml"」
    ⑤WindowsDefenderの定義インストール

    少ししてSCCMのコンソールにSCEPの情報が色々と表示されるようになりました。
    そもそもこんな手順を踏まないとダメなの?って所は置いときまして、やっていることからすると多分ですが③と④が有効だったのかなと思います。
    • 編集済み kaz8629 2020年3月3日 18:21
    • 回答としてマーク Tako8 2020年4月1日 13:58
    2020年3月3日 18:12

すべての返信

  • 気になったのでv1910で確認してみましたが、確かに同じ状態になりますね。レポートからみても自身の定義のバージョンは取れていないですね。

    SCCMの場合日にちを置けば急に見えるようになるってこともあるので、そのパターンだったら良いのですが気になりますね。。。

    2020年3月2日 17:51
  • Lapivy様

    情報ありがとうございます。

    アクセス権変更してみたのですがこちらの状況は変わらずでした。。。

    2020年3月3日 0:30
  • kaz8629様

    ご確認ありがとうございました。

    私だけの状況ではないようで少し安心?しました。

    こちらは何日も置いている環境もあるのですが状況変わらずです。

    その環境はそのままにし色々設定を変えてSCCM再構築をして試しているところです。

    Kaz8629様の環境でもし解消方法が見つかりましたらご教授いただければ幸いです。

    2020年3月3日 0:35
  • Endpoint Protectionの状態が有効になりました。
    いろいろとやったので、どれが有効かわからないですが記載しておきます。
    ①境界等のSCCMサーバの基本的な設定の見直し。
    ②SCCMクライアントの再インストール(プッシュインストールで既にインストールされている場合はインストールする前にアンインストールするオプションにチェック)
    ③プログラムのアンインストールから「System Center Endpoint Protection」の削除
    ④以下のコマンドを実行して「System Center Endpoint Protection」のインストール
     「"C:\Program Files\Microsoft Configuration Manager\Client\SCEPInstall.exe" /POLICY "C:\Program Files\SMS_CCM\EPAMPolicy.xml"」
    ⑤WindowsDefenderの定義インストール

    少ししてSCCMのコンソールにSCEPの情報が色々と表示されるようになりました。
    そもそもこんな手順を踏まないとダメなの?って所は置いときまして、やっていることからすると多分ですが③と④が有効だったのかなと思います。
    • 編集済み kaz8629 2020年3月3日 18:21
    • 回答としてマーク Tako8 2020年4月1日 13:58
    2020年3月3日 18:12
  • kaz8629様

    ご確認いただいた上での情報ありがとうございました!
    解消された手順でやってみたのですが私の環境では結局状況は変わらずでしたが
    恐らくあとは私の環境では別の要因があると思います。。。
    さらに再構築をしたところ正常になりました。

    # 原因は結局わからずですが

    他の方で同じような現象になった場合はおそらくkaz8629様の手順で解消すると思われますので回答としてマークさせていただきました。

    2020年4月1日 14:03