none
WHS2011 スタートパッドからサインイン出来ない RRS feed

  • 質問

  • 似たような事例の対処法をいろいろと試したのですが、解決に至らなかったため質問させていただきます。

    タイトルの通り、クライアントPC(windows7 Pro 64 bit)のスタートパッドからサーバーにサインインしようとすると

    「サーバーはオフラインです。オフラインノードにサインインしますか?」

    と表示され、サインインできません。

    リモートデスクトップ接続、ダッシュボードからのサインインは出来ますが、

    ダッシュボード上でクライアントPCはオフライン表示でバックアップも出来ません。

    • クリーンインストールを行っても状況は変わらず
    • 別のクライアントPC(Windows XP)では何の問題も無い


    チェックすべきポイントは何がありますでしょうか?

    また、必要なログファイル等ありましたらアップいたします。

    よろしくお願い致します。


    • 編集済み MC28GTB 2012年8月6日 9:56
    2012年8月6日 9:46

回答

  • 皆様

    事象の解決に至ったので報告いたします。

    クライアントのコンピュータ名を変更し、コネクターを再インストールしたところ、ダッシュボードに表示されるクライアントPCの状態がオンラインとなり、

    バックアップも行うことが出来ました。

    スタートパッドからのサインインも大丈夫でした。

    その後、TCP Chimney Offload、 Receive-Side Scaling(RSS)、 Network Direct Memory Access (NetDMA) を有効化しましたが、問題ありませんでした。

    以前はコンピュータ名が数字のみで今回英字に変更したのですが、コンピュータ名が数字のみだといけなかったのでしょうか?

    ひとまず、何か月も解決しなかった問題が解決できたので非常に嬉しいのですが、原因がたったこれだけのことだとしたら驚きです。

    そして、自分が情けないです。

    2012年8月22日 4:31

すべての返信

  • クライアントPCにおいて、以下のキャプチャに示すオレンジの枠で囲まれたサービスについて、全てが開始状態にあるかまず確認して頂けますでしょうか。停止しているサービスがあれば教えてください。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年8月6日 10:26
    モデレータ
  • >MC28GTBさん

    ださっちさんの投稿をプラスした内容になります。

    各サービスが起動していない場合、Windows Server Initialization Serviceがこけている場合があります。

    その場合はサービスのスタートアップ種類を「自動」→「自動(遅延開始)」にすると解決する事があります。

    詳しくは↓のブログ記事をみてください。

    http://nasunoblog.blogspot.jp/2012/01/whs2011-launchpad_09.html


    茄子 from 元「なんでもエンジニ屋」のダメ日
    http://nasunoblog.blogspot.jp/

    2012年8月7日 3:31
  • ださっち様、茄子さん様

    どうもありがとうございます。

    サービスは以下のように全て開始しています。各サービスを再起動してみたりしたこともありましたが、変化はありませんでした。

    よろしくお願い致します。

    2012年8月7日 4:07
  • それでは次に、以下を確認頂けますか?

    1. 当該の事象はUR2で改善されている事象ですので、WHS2011のUR2(KB2630434)がインストールされているか確認して頂けますでしょうか。
    2. クライアントPCのコネクターを一度アンインストールし、再インストールしてみて頂けますか。
    3. クライアントPCで netstat -b を実行して頂き、クライアントPCからサーバーの TCP 6602 宛の通信が出来ているか確認してみて頂けますでしょうか。
      http://social.technet.microsoft.com/Forums/ja-JP/windowshomeservergenericja/thread/7d2589cc-8bad-4017-9286-9711d89c57b3/
    4. Winodows 7クライアントで、管理者権限でコマンドプロンプトを起動し、以下のコマンドを試してみてください。
      ・TCP Chimney Offload の無効化netsh int tcp set global chimney=disabled
      ・Receive-Side Scaling(RSS)の無効化
      netsh int tcp set global rss=disabled
      ・Network Direct Memory Access(NetDMA)の無効化
      netsh int tcp set global netdma=disabled
      3つのコマンドを試して頂いて、Win7を再起動後事象が解決するかどうかを確認してみてください。
    5. それでダメな場合は、教えてください。他の可能性を考えます。

    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年8月7日 9:26
    モデレータ
  • ださっち様


    返信が遅くなり申し訳ありません。

    それぞれの事項を確認しました。

    1. WHS2011のUR2(KB2630434)はインストールされています。
    2. クライアントPCのコネクターアンインストール後、再インストールしても状況は変わらず。
    3. クライアントPCでの netstat -b の結果に問題があります。まず、Launchpad.exeが表示されていません(スタートパッドは起動しています)。次の内容(http://social.technet.microsoft.com/Forums/ja-JP/windowshomeservergenericja/thread/7d2589cc-8bad-4017-9286-9711d89c57b3/)は以前から拝見しており参考にしてOSのクリーンインストールを行った直後の状態で確認しましたが、私の場合問題の解決には至っていないです。
    4. 3つのコマンドを一つずつ実行し、それぞれ再起動後、確認しましたが変化はありません。
    5. 以上のような結果となっています。よろしくお願い致します。
    2012年8月10日 2:36
  • 横からコメント入れさせて戴いて宜しいでしょうか?

    MC28GTB さま よろしく。

    私も以前 Server の IP Address を弄繰り回した折、スタートパッドの挙動が似たような状況になった事がありまして、その時の失敗経験からのご確認ですが ... 。

    クライアントPCのコネクターアンインストール後、再インストールですが、
    クライアントに残っているインストールプログラムを実行していて、いつまでも改善できませんでした。
    新たに、 Sarver からインストールプログラムをダウンロードし直す事で回避できました。
    これによって、証明書が更新されたのでしょう。

    私のようなミスはなさっていませんよね。
    その場合、この投稿は無視なさって下さい。

    2012年8月10日 3:17
  • ShiroYuki_Mot様

    コネクターのインストールはその都度サーバーからダウンロードし、行っています。

    原因が分からず、困っているのでどのようなアドバイスでもありがたいです。

    何かお気づきのことがありましら、どうぞよろしくお願い致します。


    • 編集済み MC28GTB 2012年8月10日 4:05
    2012年8月10日 4:02
  • 遅くなってすみません。

    クライアント側で、netstat -b の結果にLaunchpad.exeが表示されていないというのが全てを物語っている訳で、サーバーとクライアントの間で通信が出来ていないことはやはり間違いありませんね。

    試しに、クライアントコネクターをIP v4を明示的に指定してインストールしてみて頂けますでしょうか?
    一旦クライアントPCからクライアントコネクターアンインストールし、http://WHS2011のIP v4アドレス/connect と、IPアドレスを明示的に指定してクライアントコネクターをインストールすることで、以降のサーバーとの通信をIP v4 で行わせることが出来ます。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年8月13日 9:20
    モデレータ
  • ださっち様

    返信が遅くなり申し訳ありません。

    クライアントコネクターアンインストール後、IP v4アドレス指定でコネクターを再インストールしましたが、

    症状は変わらず、また netstat -b の結果に Launchpad.exe も表示されていないままです。

    ファイアウォールで

    • TCP 6602、TCP 8912ポートの開放
    • Launchpad.exe の例外登録 等は行っています。

    時間がかかってしまい、申し訳ありませんが、よろしくお願い致します。

    2012年8月17日 2:50
  • 皆様

    事象の解決に至ったので報告いたします。

    クライアントのコンピュータ名を変更し、コネクターを再インストールしたところ、ダッシュボードに表示されるクライアントPCの状態がオンラインとなり、

    バックアップも行うことが出来ました。

    スタートパッドからのサインインも大丈夫でした。

    その後、TCP Chimney Offload、 Receive-Side Scaling(RSS)、 Network Direct Memory Access (NetDMA) を有効化しましたが、問題ありませんでした。

    以前はコンピュータ名が数字のみで今回英字に変更したのですが、コンピュータ名が数字のみだといけなかったのでしょうか?

    ひとまず、何か月も解決しなかった問題が解決できたので非常に嬉しいのですが、原因がたったこれだけのことだとしたら驚きです。

    そして、自分が情けないです。

    2012年8月22日 4:31
  • MC28GTB さま 問題解決、おめでとうございます。

    解決のご報告、参考になりました。
    しかし、何故、クライアントのコンピュータ名を変更して解決になったのかが分かりませんね。
    この辺にお詳しい方のコメントをお聞きしたい気がします。

    2012年8月22日 7:05
  •   お役に立たずすみません。
    今回変更されたのはコンピューター名だけでしょうか?コンピューターの説明文も変更されましたか?コンピューター名やコンピューターの説明に2byte文字が含まれているとおかしな挙動をする可能性はありますが、数字だけのコンピューター名は問題ないと思いますので、コンピューター名を変更するだけで解決したということだとすると、サーバーに登録されたクライアントに関する何らかの情報が破損していたのかもしれません。


    ださっち
    Microsoft MVP for Server Solutions - Windows Home Server
    薩摩藩中仙道蕨宿別邸 http://satsumahan.blog40.fc2.com/
    ・参考になった/解決のヒントになった投稿には「回答としてマーク」をつけましょう。
    ・後から参照する人のためにも、質問した内容について解決した場合は、必ず「回答としてマーク」をお願いします。

    2012年8月25日 3:13
    モデレータ
  • 'ださっち' Masahiko Sada さま ご投稿読ませて戴きました。
    >コンピューター名やコンピューターの説明に2byte文字が含まれているとおかしな挙動をする可能性はありますが
    >サーバーに登録されたクライアントに関する何らかの情報が破損していたのかもしれません

    こんな事もあるのですね。
    参考になりました。ありがとうございます。

    2012年8月25日 4:13
  • ださっち様

    多くのアドバイスを頂き、誠にありがとうございました。

    以下質問に対する回答です。

    • 変更したのはクライアントのコンピュータ名だけです。
    • 説明文は以前も、今回も何も書いておりませんので変更していません。
    • 2 byte文字も使用していませんでした。

    いまいち納得のいかない部分があるのですが、ひとまず解決しましたので今回の話題はこれで終了ということにします。

    みなさま、どうもありがとうございました。

    他に同様の症状で悩んでいる方の参考になれば幸いです。

    2012年8月28日 1:11