none
Windows2008R2へのリモートデスクトップ接続で「アクセスが拒否されました」となる RRS feed

  • 質問

  • Windows2008SvのAD環境下の特定ユーザのみ、WindowsXpsp3端末からRDC6.1を利用してリモートデスクトップ接続しようとすると、2008Svのログオン画面に「アクセスが拒否されました」と表示され接続できません。

    sp2やRDC6.0の他の端末から接続しても同様です。

    サーバ自体に該当ユーザでログインはできます。

    他ユーザでは問題がない為、所属グループなど確認しましたがすべて同じでした。

    この先調査すれは良いか行き詰まっております。

    宜しくお願い致します。

    • 移動 Robin_Ren 2012年10月3日 17:49 merge forum (移動元:Windows Server 2008 R2 全般)
    2010年5月18日 2:13

回答

  • サーバ側でネットワークレベル認証(NLA)が有効になっていませんか?

    NLA は RDP 6.1 からの対応になっていますが、XP 上の RDP 6.1 では NLA がデフォルト無効になっています。
    RDP 6.1 で NLA を有効にするには、以下のレジストリを修正する必要があります

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa の Security Packages に「tspkg」を追加
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders の SecurityProviders に「credssp.dll」を追加

    資格情報のセキュリティ サポート プロバイダー (CredSSP) で Windows XP Service Pack 3 の説明
    http://support.microsoft.com/kb/951608


    MVP for Virtual Machine : Networking
    • 回答としてマーク 服部清次 2010年5月18日 5:12
    2010年5月18日 3:35
    モデレータ
  • 早速の書き込みありがとう御座います。 その後も引き続き調査していたのですが、結果、該当ユーザの設定で「DESによる暗号化を行う」にチェックを入れてしまっていたことによる問題でした。 チェックオフにより正常に接続できるようになりました。 お手数お掛けしました。 以上
    • 回答としてマーク 服部清次 2010年5月18日 5:12
    2010年5月18日 4:46

すべての返信

  • サーバ側でネットワークレベル認証(NLA)が有効になっていませんか?

    NLA は RDP 6.1 からの対応になっていますが、XP 上の RDP 6.1 では NLA がデフォルト無効になっています。
    RDP 6.1 で NLA を有効にするには、以下のレジストリを修正する必要があります

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa の Security Packages に「tspkg」を追加
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders の SecurityProviders に「credssp.dll」を追加

    資格情報のセキュリティ サポート プロバイダー (CredSSP) で Windows XP Service Pack 3 の説明
    http://support.microsoft.com/kb/951608


    MVP for Virtual Machine : Networking
    • 回答としてマーク 服部清次 2010年5月18日 5:12
    2010年5月18日 3:35
    モデレータ
  • 早速の書き込みありがとう御座います。 その後も引き続き調査していたのですが、結果、該当ユーザの設定で「DESによる暗号化を行う」にチェックを入れてしまっていたことによる問題でした。 チェックオフにより正常に接続できるようになりました。 お手数お掛けしました。 以上
    • 回答としてマーク 服部清次 2010年5月18日 5:12
    2010年5月18日 4:46
  • たつ吉 さん、

    こんにちは。
    フォーラム オペレーターの服部 清次です。
    無事問題が解決されたとのことで、ご報告ありがとうございます!

    今回、質問者ご自身の回答ではありますが、
    問題の原因と解決策を報告してくださった たつ吉 さんの返信に
    [回答としてマーク] のチェックを付けさせていただきました。

    また、たつ吉 さんと同じ現象に遭遇された方にとっては、1つの確認ポイントとして、
    Murashima Syuichi さんの回答も参考にしていただけるのではないかと思いましたので、
    あわせて [回答としてマーク] のチェックを付けさせていただきました。

    また何か困ったことがありましたら、ぜひ TechNet フォーラムをご利用ください。
    今後とも、よろしくお願いします。
    それでは、また。


    __________________________________________________
    マイクロソフト株式会社 フォーラム オペレーター 服部 清次

    2010年5月18日 5:22
  • 同じようにトラブルで困っております。

    >該当ユーザの設定で「DESによる暗号化を行う」にチェックを入れてしまっていたことによる問題でした。

     >チェックオフにより正常に接続できるようになりました。

    「DESによる暗号化を行う」をオフにするのにどのようにすれば宜しいでしょうか?

    ご教授の程宜しくお願い致します。

    • 回答の候補に設定 20100423 2011年2月9日 8:14
    2011年2月9日 3:45