none
[WHS_V1]クライアント(PCとMac)のネットワークからH340の共有フォルダへ接続できない(見つからない) RRS feed

  • 質問

  • みなさまこんにちは。数日WHS(かネットワーク)の不具合で困っております。

    【使用環境】

    2年前からこちらやblog等を参考にH340を使い始めました。今回まで得に問題無く運用できていました。

    光ルータ - ハブ - H340他PC(XPとVistaのPC数台とMac数台)

    - 無線LANルータ(ブリッジ) - Macbook(他ガジェット)

     

    【問題】

    7日ほど前、急に各PCのマイネットワーク(workgroup)に不具合(アイコンが表示されない)が起こる。>これも未解決

    同様にWHSのサーバー名アイコンも表示されなくなる。しかし、アプリケーションに保存されているサーバのフォルダ名(例えば最近使用したファイルを開く等)から直接WHSへアクセスできた。

    何とか対処しようと思っている数日後、クライアントのネットワークからWHSへ接続できなくなった。同様に、コンソールも開けなくなってしまった。

    H340の電源ボタンを4秒押してシャットダウンし電源オンをすると、しばらくして本体から「ビッ」と音がしたら、コンソールについては5分程度開くことができる。しかしそのまま接続できなくなり、WHSのアイコンもグレーになってしまう。H340全面のLEDは、真ん中の茶筒のようなアイコンが消灯で、ネットワークとインフォは青点灯。

     

    【1ヶ月以内でWHS関連での変更点】

    Bフレッツからネクスト(光電話)へ変更に伴い、ルータをPR-S300HIへ交換。以前同様に静的NAT設定でWHS用ポートを変換する。不具合発生時まで問題無し。

    Advanced Admin ConsoleのAddinを追加。

    ださっちさんのBlogを参考に、Macbookのタイムマシン化を実行。問題なくバックアップ取れた。

    iPhoneにWHS Mobileを導入。外部ネットワークからも接続できた。

     

    【不具合が出てから試したこと】

    ルーター変更後、LANのブラウザにhttps://◎◎.homeserver.comを入力しても開けなくなった。外部ネットワークからはきちんとアクセスできた。(不具合発生前の話)

    LANに不具合が出始めた頃にコンソールでディスクをチェックしたら、2台のHDD両方の使用量がほぼ満タンになっており、慌てて8割以下まで削除した。

    Ethernetハブを新たに交換してみた。

    WHSアイコンがグレーの時にpingをWHSの固定アドレスへ打つと、ちゃんと帰ってくる。

    lookupで使用している◎◎.homeserver.comを調べると、ルーターのWANのアドレスが帰ってくる。しかし外部ネットワークから◎◎.homeserver.comへアクセスできない。(不具合前は外部から◎◎.homeserver.comへアクセスできた)

     

    2年使ってきてWHSアイコンがグレーになったことも、H340を直接再起動すると数分だけ接続できるということも初めてのことです。何日も焦っていて上手く文をまとめられているか解りません。なにとぞアドバイスをお願いします。

     

     

     

    2011年6月2日 10:08

すべての返信

  • 事象を拝見すると、WHSの固定IPアドレスと、新たな光ルーターのネットワークが別サブネットになっている可能性が高いという印象です。WHS V1では、クライアントPCとWHSが同一サブネット内に属している必要があります。

    WHSに固定で指定しているというIPアドレス/サブネットマスクと、クライアントPCでコマンドプロンプトから ipconfig /all を実行した結果をここにペースト頂ければ幸いです。コマンドプロンプトの結果をコピーするには、コマンドプロンプトウィンドウ左上のアイコンをクリックすると、[編集]メニューが表示されます。[すべて選択]を押下後[コピー]を実行してください。

    2011年6月2日 13:32
    モデレータ
  •  ありがとうございます。

    ただ、ipconfig内容のどこまでをここへ貼り付け、どこに個体情報があるのかが若干不明でしたので、全てコピーしたテキストデータを、きださっちさんのBlogの6月1日コメント欄を使わせていただきます。

     

    でお送り致します。ご面倒ですが取得いただき、引き続きアドバイスをお願いします。

     

    クライアントのipconfig /allの一部

    Windows IP 構成

       ホスト名 . . . . . . . . . . . . : RAM
       プライマリ DNS サフィックス . . . . . . . :
       ノード タイプ . . . . . . . . . . . . : ハイブリッド
       IP ルーティング有効 . . . . . . . . : いいえ
       WINS プロキシ有効 . . . . . . . . : いいえ

    イーサネット アダプタ ローカル エリア接続

      DHCP 有効 . . . . . . . . . . . . : はい
      自動構成有効. . . . . . . . . . . : はい

       IPv4 アドレス . . . . . . . . . . : 192.168.1.26(優先)
       サブネット マスク . . . . . . . . : 255.255.255.0
       リース取得. . . . . . . . . . . . : 2011年6月3日 13:32:35
       リースの有効期限. . . . . . . . . : 2011年6月3日 17:32:35
       デフォルト ゲートウェイ . . . . . : 192.168.1.1
       DHCP サーバー . . . . . . . . . . : 192.168.1.1
       DNS サーバー. . . . . . . . . . . : 192.168.1.1
       NetBIOS over TCP/IP . . . . . . . : 有効

     

    WHS

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : SERVER01
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Broadcast
       IP Routing Enabled. . . . . . . . : Yes
       WINS Proxy Enabled. . . . . . . . : Yes

    Ethernet adapter ローカル エリア接続:

       Connection-specific DNS Suffix  . :
       DHCP Enabled. . . . . . . . . . . : No
       IP Address. . . . . . . . . . . . : 192.168.1.77
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 192.168.1.1


    • 編集済み しゅうみ 2011年6月3日 10:49 内容変更
    2011年6月3日 9:25
  • この2つ(WHSとクライアントPC)は同じルーターにどちらも有線接続でつながっている状態でしょうか?これを拝見する限りではネットワークの設定には問題なさそうです。

    この設定で上記事象だとすると、クライアントPCまたはWHSに統合セキュリティソフト、ファイアーウォールソフトがインストールされているのではないでしょうか?それをアンインストールして事象が改善するか確認してください。

    2011年6月3日 12:32
    モデレータ
  • ありがとうございます。

    最初の発言通り、ハブを介していますが有線接続しています。

    本日試したことです。

    WHSについてですが、まずマカフィーをアンインストールしました。改善せず。

    次にファイヤーウォールを停止にしました。改善せず。

    クライアントのセキュリティですが、PCとMacが混在する中で、突然全クライアントからのアクセスが不能になったので、何かが悪さをしているようには思えません。ちなみに、OS付きのファイヤーウォールとエッセンシャルを使っています。

    ネットワークですが、ブラウザマスタを調べることができる「DomainView」というアプリを動かしてみました。再起動直後の通常接続できる時間が過ぎてマイネットワークから接続できなくなると、OSの種類を示す場所に「Can't retrieve」とでます。ちなみに昨日はworkgroupさえ接続できなかったのに本日はできるようで、コンピュータ名は見え続けていますし、WHSのアイコンもグリーンのままでグレーになりません。

    最後にひとつ確認なのですが、H340の前面パネルのLEDについて。普段気にかけなかったので状態を覚えていないのです。

    電源ボタン長押しによる再起動後の短時間接続が可能な時は、すべてのLEDが点灯しています。しかし接続できなく(ネットワークが見つかりません)なると、電源マークのふたつ下、茶筒のようなアイコンが消灯してしまいます。ネットワークとインフォ「i」と右側のHDDは点灯しています。

    ここからなにか分かることはありませんでしょうか?

    再起動後の数分間のみ接続できる状態なので、データの引越をしたくてもできません。もしかすると直接USB外付けHDDならデータコピーの命令をかけることができるかもと思って、HDDの準備をしています。

    引き続きよろしくお願いします。

     

    2011年6月4日 9:55
  • お世話になっております。クライアント側はWindows ファイアーウォールのようですが、WHS側も同様でしょうか?

    電源マークのふたつ下、茶筒のようなアイコンが消灯してしまいます。ネットワークとインフォ「i」と右側のHDDは点灯しています。

    当該のLEDはHDDへのアクセスランプなので、ほとんど消灯していて問題ありません。

    IPアドレスの設定で問題ない、ファイアーウォール等ソフトも問題ないとすると、あとは物理的な問題を疑うしかなくなってくるのですが、まずはPR-S300HIを疑って切り分けしてみたいと思います。ハブを介していらっしゃるとのことなので、クライアントPCのIPアドレスもWHS同様静的にアサインして、一度PR-S300HIとハブの接続を切断してみて頂けませんでしょうか。その上でクライアントPC、WHSを再起動してしばらく様子を見て事象が改善されるか試してみて頂けますか?

    2011年6月4日 10:35
    モデレータ
  • 外に出る機会が多い週末で、お返事が遅くなりました。

    問題の切り分けについてやってみたことです。

    クライアントにローカルのIPアドレスを振り、以前使っていたハブにWHSのケーブルとクライアントのケーブルのみを接続し、両者を再起動しました。クライアントからpingをWHSへ打って帰ってきたことを確認して、コンソールを開いたり、マイネットワークを開いたりしてみました。

    結果、切り離す前と違いはなく、再起動後はWHSの共有フォルダへアクセスしたりコンソール接続できましたが、数分後にアクセス不能となりました。

    と言うことは、ハブやネットワークの問題というよりも、はやりH340かWHSそのものの設定が狂っているということになりそうです。何か考えつく場所などはありますでしょうか?

    2011年6月7日 8:36
  • 正直、WHS側に問題があるとは考えにくいのですが・・・。

    何度も申し訳ないですが以下、お願いできますか。

     

    1) WHSに接続出来る状態でWHSにリモートデスクトップして頂き、すべてのHDDにchkdskを実施してください。方法はこちらを参照してください。 

    2) クライアントPC、WHSの両方でNICのプロパティを開き、ジャンボフレーム/ジャンボパケットに関する設定を確認する。無効にするか、パケットサイズを一番小さな値に設定する。

    3) WHSにつながらない状態で、WHSにリモートデスクトップ接続は出来ますか?出来る場合は、WHS側でコマンドプロンプトから netstat -b を実行頂いて結果を貼り付けて頂けませんでしょうか。同様にクライアントPC側も netstat -b の結果をペースト頂ければ幸いです。つながらない状態ではWHSにリモートデスクトップ出来ない場合は、クライアントPC側だけの結果だけで構いません。

    4) 同様にWHSにつながらない状態で、WHS側でコマンドプロンプトから net start を実行した結果を貼り付けて頂けませんでしょうか。


    もしWHS側に問題があるとすると、HDDへのアクセスランプが完全に消灯状態で全く光っていない場合、OSがブルースクリーン等で停止している可能性が考えられます。H340はディスプレイが接続出来ないので確認できませんが、この場合原因がハードウェア的な要素なのかソフトウェア的な要素なのかにもよりますが、一度WHSの再インストールをする必要があるかと思います。
    2011年6月7日 10:10
    モデレータ
  • こちらこそ、大変お世話になっております。
    ここ数日向かい合う時間が取れず、長期になってしまい申し訳ありません。
    短時間のリモート接続に限界を感じたので、モニター接続を試みました。
    その際の挙動はリモートに近く、BIOS後、ctrl+alt+delからadminで入り、IE8が立ち上がった後、デスクトップから数分扱えるというものでした。使えなくなると同時にHDDアクセスランプも消灯し、マウスが動かなくなりました。
    chkdskについて。リンク先のコマンドをファイルにし、起動後のうごいている段階でクライアントからコピーし、デスクトップへ置きました。しかし、ダブルクリックすると一瞬コマンドが出ますが消えてしまいました。whs上で打ち込もうと思っていますが、本日は時間切れでしたので、明日もう一度やります。その際、リンク先のコマンドを一行づつ打ち込むつもりですが、全てYで進めてよいのですよね?それともしも実行中に止まった場合強制再起動になると思いますが、問題はないでしょうか。少し心配です。
    あるいは2以降を先にやった方が良いでしょうか。
    長期化してすみません。もうしばらくお願いします。
    2011年6月8日 13:49
  • ディスプレイケーブルを入手されていらっしゃいましたか。それなら話が早いです。

    マウスが動かなくなった状態では、ディスプレイにはWHSのデスクトップが表示されている状態のままフリーズしているんでしょうか。あまり聞いたことがありませんが、HDD障害だとするとchkdskで修復できるかもしれませんし、そうでないHW障害だとすると修理に出された方がよいかもしれません。

    バッチファイルを実行して一瞬で画面が消えるということですが、一行ごとにコマンドを入力する場合はすべて Y で進めて頂いて構いません。

    また、クリーンブートを試みてみるのもよいかもしれません。
    http://support.microsoft.com/kb/880988/ja
    を参考に、クリーンブートをしてみて、事象が変わるかどうかもお試し頂ければ幸いです。 

    2011年6月8日 14:08
    モデレータ
  • こんにちは。

    ただいまCHKDSKでDドライブをチェック中です。かなり時間がかかっています。逆に言うと、昨日途中で止まってしまったのに今日は既に1時間近く動いている訳で、このままCドライブまで完走してくれると嬉しいです。

    完走し再起動できたとして、2)以降を行うべきか、クリーンブートを行うべきか、どうでしょうか。

    途中経過報告でした。

    2011年6月9日 2:28
  • 残念ながら途中で止まってしまいました。

    順番でいうとDドライブのchkdsk中で「ファイナルデータ検査 264448のファイルのうち221367が処理されました(ステージ4/5)」のところでHDDアクセスランプが切れてそのまま止まったようです。

    しかも2度とも同じ場所でした。

    1度目は、HDDアクセスランプが消えたので、マウスを動かしてみたらコマンドの窓が動かずフリーズ状態。マウスは水平両方向矢印に変化したままで動きますが、なにもクリックできない状態になりました。本体電源で今日強制リブートし再度やってみたところ、上記の通り同じ場所で止まりました。ここまで行くにも小一時間ほどだったので、一晩放置してみましたが、変化ありませでした。現在処理中の時のようにカーソルが点滅しており、HDDランプも消えています。処理実行中ならスタートボタンとか押してもメニューが出てきましたが、恐らく今回もこの状態でスタートボタンなどをクリックすれば、そのままフリーズすると思います。

    次の一手なのですが、リブートして今度はCドライブを先にchkdskしてみるか、クリーンブートを試みるのが良いか、どうでしょうか?


    • 編集済み しゅうみ 2011年6月10日 4:25 付け加え
    2011年6月10日 4:24
  • Dドライブということは、プライマリHDDの2番目のパーティション(プライマリデータパーティション)ということになりますので、プライマリHDDの交換を行った方がよいでしょう。

    新しいプライマリHDDを用意し新しいHDDだけを接続した状態で、一度Acer H340の"工場出荷状態にリセット"を実施してください。方法は、FacebookコミュニティのAcer easyStore H340をリカバリするには?を参考にしてください。(くれぐれも他のHDDを接続しないよう注意してください。)

    一度新しいプライマリHDDにシステムをインストールしたら、今度は他のセカンダリHDDも接続した状態で"サーバーのリカバリ"を実施してください。

    セカンダリHDDのデータは失われませんが、今プライマリデータパーティションにのみ保存されているデータは失われてしまいます。クライアントPCのバックアップデータベースも失われる可能性があります。[FAQ]WHSの障害時にHDDからデータを取り出す方法 を参考に、
    サルベージして復旧できるファイルはWHSの共有フォルダに移してください。おそらくサルベージに失敗するファイルがあると思いますので、それは残念ですがあきらめてください。


    2011年6月10日 11:39
    モデレータ