none
Windows10 64bit LTSB版 スタンドアロンインストーラについて RRS feed

  • 質問

  • お世話になります。

    表題の通り、ネット環境の無いwindows10 64bit LTSB版にセキュリティパッチを当てようと作業を行ったのですが

    "この更新プログラムはお使いのコンピュータには適用できません。"と表示が出てインストールすることが出来ません。

    windowsUpdateCatalogより64bit LTSB版を選択してダウンロードしているのですが何が原因か分からなく質問させていただきました。

    WinverよりWindowsのバージョンは1607(OSビルド14393.1715)と標記があります。

    適用したいセキュリティパッチは

    kb4462922

    kb4457146

    kb4457132

    kb4343902

    kb4343892

    kb4345455

    kb4338832

    kb4338829

    kb4284860

    kb4287903

    kb4103729 ※インストール成功

    kb4103716

    kb4093111

    kb4093110

    kb4088786

    kb4088785

    以上16個になります。内kb4103729はなぜかインストール成功しました。他は上記のエラーが出てしまいました。

    管理者ユーザでの作業、ウイルスソフト、ファイヤウォールは念のため切り、パソコン自体の再起動、WindowsUpdateサービスの再起動なども行いました。以上、恐れ入りますがなにとぞよろしくお願いいたします。

    2018年11月30日 7:46

すべての返信

  • 適用しようとしている更新プログラムが、適用済みの更新プログラムにより置き換えられているか、サービススタック更新プログラムが適用されていないとかでは無いでしょうか?

    更新プログラムのインストール処理を改善するサービススタック更新プログラムについて
    https://blogs.technet.microsoft.com/askcorejp/2018/07/12/servicingstack_guide/

    そもそも、Windows 10 の品質更新プログラムはロールアップ更新プログラムですので、サービススタック更新プログラムの適用は必要としても、OS向けについては最新のOSのロールアップ更新プログラムのみ適用すれば、過去の修正も含め全て適用されます。
    FlashPlayerについても最新状態にしたいのであれば、最新版のFlashPlayerに対応している更新プログラムのみ適用すれば良いでしょう。
    2018年11月30日 10:16
  • Lapivy様

    ご回答ありがとうございます。

    "適用しようとしている更新プログラムが、適用済みの更新プログラムにより置き換えられているか、サービススタック更新プログラムが適用されていないとかでは無いでしょうか?" 

    なぜ適用できないのかPCまたはOSに対して不具合ばかりを考えていて、こちらに関しては全く調べておりませんでした。

    現在適用されている更新プログラム(kbxxxxxxx)を調べてサービススタック、置き換えにて適用済み、累積更新などがあるかどうか調べて参ります。また何か分からないことがあればなにとぞご教示の程よろしくお願いいたします。

    2018年12月3日 7:06
  • Lapivy様

    お世話になります。

    立て続けに申し訳ありません。PCの更新履歴を確認してきまして、先日私が導入したい更新プログラムはversion1507用でした。

    しかし稼動しているOSは1607です。つまり上記の一覧プログラムは既に適用済みという認識でよろしいのでしょうか。因みにプログラムの削除の画面よりインストールされているKB番号をWindowsCatalogで検索したところ置き換えはされてない様でした。

    KB4462922→KB4467680へ置き換え

    KB4457146→KB4477029へ置き換え

    以降の更新プログラムはKB4467680、KB4477029に含まれているところまでは調べました。

    私の認識であっていた場合"1507のアップデート内容が包括的に適用されたものが1607です"みたいな情報がほしく

    大変恐縮ではありますが、的なことを謳っているMS公式のサイトなどがあればご案内いただきたく存じます。自力で可能な範囲では調べましたが、https://www.microsoft.com/ja-jp/itpro/windows-10/release-information

    ここには書いていない様で、含まれているという認識があればそれでよいのでご回答願えませんでしょうか。

    お忙しいところ恐縮ですがなにとぞよろしくお願い申し上げます。

    2018年12月5日 5:54
  • 適用したいセキュリティパッチのリストはどのようにリストアップしたものでしょうか? ざっと見たところ、

    (A) 2018 年 3 月~ 9 月に提供された Adobe Flash Player 用セキュリティ更新プログラム
    (B) 2018 年 3 月~ 9 月に Windows 10 version 1507 向けの累積更新プログラム

    がリストアップされているように見えます。

    Windows 10 version 1507 (ビルド 10240.x)と Windows 10 version 1607 (ビルド 14393.x)は Windows の別バージョンです。そのため、(B) は不要です。"1507のアップデート内容が包括的に適用されたものが1607です"ではありません。Windows 7 用の更新プログラムが Windows 8 には不要であるのと同じ理屈です。

    次に、(A) は OS に標準搭載されている Adobe Flash Player のアップデートですので、最新のものをインストールすればそれで OK です。(B)については累積更新プログラムは新しいものに前月までの累積更新プログラムの内容が累積されていますので、Windows 10 version 1607(2016 LTSB と共通バージョンです)の累積更新プログラムのできるだけ新しいものインストールされば、それ以前のものは不要です。できるだけ新しいものといっても、毎月第二火曜日の翌日にリリースされるものにしてください。それ以外のタイミングで提供される累積更新プログラムは次の月の第二火曜日の翌日にリリースされるもののプレビュー版(テスト版)という意味合いで提供されるもので、十分にテストされていません。また、(B)は前提となるサービススタックの更新(Latest SSU)があるので、そちらを最初にインストールする必要があります。

    Windows 10 Enterprise LTSB 2016の場合、2018 年 11 月の時点の状態にまで更新するには、次の順番でインストール(要求されれば再起動)すればよいと思います。

    (1) Servicing stack update for Windows Server 2016 and Windows 10, version 1607: November 13, 2018 ・・・ (2) の前提要件
    https://support.microsoft.com/en-us/help/4465659/
    Microsoft Update Catalog サイトから「2018-11 x64 ベース システム用 Windows 10 Version 1607 更新プログラム (KB4465659) 」をダウンロードしてインストールします。

    (2) November 13, 2018-KB4467691 (OS Build 14393.2608)
    https://support.microsoft.com/en-us/help/4467691/
    Microsoft Update Catalog サイトから「2018-11 x64 ベース システム用 Windows 10 Version 1607 の累積更新プログラム (KB4467691) 」をダウンロードしてインストールします。※「・・・差分更新プログラム (KB4467691) 」は使用しないでください。

    (3) Security update for Adobe Flash Player: November 20, 2018
    https://support.microsoft.com/en-us/help/4477029/

    Microsoft Update Catalog サイトから「2018-11 x64 ベース システム用 Windows 10 Version 1607 セキュリティ更新プログラム (Adobe Flash Player 対応) (KB4477029) 」をダウンロードしてインストールします。

    (1)(2) が失敗する場合は、10 月の累積更新プログラム(https://support.microsoft.com/en-us/help/4462928/)にさかのぼって試してみてください(必要な SSU は URL の先の文書に書いてます)。ただし、現在の ビルド14393.1715 は 2018 年 9 月時点のビルドなので、それ以前にさかのぼる必要はありませんし、できません(2017 年 8 月~ 2018 年 9 月までの更新内容はすべて含まれています)。

    KB4103729 が成功したのは、たまたま 1507 向けではなく、1607 向けのものをダウンロードしたからでしょう。


    2018年12月5日 6:45