locked
WindowsXPのサービスパックを特定できないか RRS feed

  • 全般的な情報交換

  • ユーザエージェントを参照し、Windows XPの端末でSP3が適用されているか、SP2までしか適用されていないか明確に区別できるでしょうか?

    WebサーバでSSL暗号化アルゴリズムをSHA-2に移行することにより、SHA-2に対応していないWindowsXP/SP2までのクライアントは、サーバにアクセスできなくなりますが、WindowsXPであることの特定条件は分かりましたが、サービスパックを明確に特定する方法があるかどうかを教えていただきたいのです。

    "SV1" がユーザエージェントにあると、SP2がインストールされているようですが、更にSP3インストールされている場合もあるようで"明確な"切り分けにならないので困っています。

    WindowsXP はサポートが終了していることは承知しております。

    • 編集済み るでめ 2015年9月9日 2:27
    2015年9月9日 2:24

すべての返信

  • (自己返信です)

    ■ユーザエージェント情報内に "NT 5.1" が Windows XPをあらわしている。

    Mozilla/4.0 (compatible; ; Windows NT 5.1; BTRS129271; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

    ■"SV1;" があるからSP2がインストールされているようだ。でもSP3もインストールされているかもしれない。

    Mozilla/4.0 (compatible; ; Windows NT 5.1; FunWebProducts; SV1)

    Mozilla/4.0 (compatible; ; Windows NT 5.1; GTB7.3; SV1)

    ■これはSP2までしかインストールされていないといえるのか?

    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.0.3705)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; YTB730; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 1.0.3705; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)

    Mozilla/4.0 (compatible; ; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

    ■これらはSP3がインストールされたものか、SP2までしかインストールされていないか区別できるか。

    明確にはできないのが結論であれば、受け入れるしかないと思っています(あたりまえですけど)。


    • 編集済み るでめ 2015年9月9日 3:03
    2015年9月9日 3:00