none
Set -SCVirtualNetworkAdapter script is failing while cloning ubuntu vm

    質問

  • Set -SCVirtualNetworkAdapter script is failing while cloning ubuntu vm with OS 14.X and 16.X versions. The IPs are allocating by granting but are not reflected in OS of cloned VM. The VM is not getting new IPs and if it gets then after some time automatically changed with Parent VM's IP addresses in SCVMM. I checked with "ifconfig" command in VM console , it is showing parent VM's IPs. The above script is working for Windows, Linux but not for ubuntu. Is there any step to assign IP addresses to OS of cloned Ubuntu VM ? Please give a reply with solution....
    2018年4月27日 5:50

すべての返信

  • Hello,

    How did the parent VM get the IP address, static or DHCP?

    In addition, how did you use the Set-SCVirtualNetworkAdapter cmdlet? Did you clone the VM from the VMM console?

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年4月27日 8:43
  • Parent VM got static IP Address with new virtual machine configuration by using
    "New-SCVirtualMachine -VMConfiguration" but Child VM is created from parent VM's configuration using "New-SCVirtualMachine -VM". Static IPs are granted after allocating from IP Pool. This thing is working fine for other OS. But failing for Ubuntu VM with below error-

    Error (714)
    SCVMM cannot modify the virtual machine because it is in either an unsupported, transitional, or a failed state.


    Recommended Action
    If the virtual machine is in a transitional state, wait for the operation to complete, and then try the command again. If the virtual machine is in a failed or unsupported state, repair the failure, and then try the operation again.

    I tried to clone Ubuntu virtual machines using PSScripts and directly from SCVMM.In both ways, it is failing while changing properties of network adapter.  I used the cmdlet Set-SCVirtualNetworkAdapter -VirtualNetworkAdapter $VMNic -IPv4AddressType static -IPv4Address $grantedIP.Address in PSScript.


    2018年4月27日 13:25
  • Hi Liu,

    I found that Static IP injection is not working for Ubuntu VMs. I get to know to turn off "Network Manager" in that VM. But I checked it is not even installed and configured. Is there any other way to inject static IP in Ubuntu VM?

    2018年4月30日 6:14
  • Hi,

    I have faced the same issue.. If anyone from Microsoft could elaborate the root cause behind it or help to resolve the issue it will be very much beneficial.

    Thanks in Advance!!

    2018年6月6日 12:01
  • Can anyone put some lights on it?

    Is there any limitation while cloning the Ubuntu VM?

     Awaiting for a reply!

    2018年7月12日 14:02
  • Same here also when creating a new VM with Ubuntu and static IP from VMM (2016)
    2018年8月22日 18:01