none
firewall changes required to change remote desktop port from 3389 to 3392

    質問

  • Everything works using port 3389. I have changed port to 3392 on router and registry. How do I change firewall rule to port 3392? port is grayed out - not changeable
    2010年10月2日 21:09

回答

  • I suspected I would have to figure this out myself. You CAN change the port number on the default inbound rule. Simply search the registry and change every instance of 3389 (where it refers to a port) to 3392 (or your preferred port #). Also in "Network and Sharing Center" change the TCP adapter settings from "Obtain an IP address automatically" to "Use the following IP address" using an address in the range of your router. Then in your router point port 3392 (or whatever # you used) to this static IP. Note: the wording in the Remote Desktop Firewall Rule Description still says 3389 but if you look at the local port actually being used it has changed.

    As always with registry changes - backup first!

    • 回答としてマーク rod001 2010年10月3日 20:51
    2010年10月3日 20:50

すべての返信

  • If you are talking about the Windows Firewall then it is normal.
    You cannot change the port number on the default inbound rule. You need to create another inbound rule and define it there.
     
    Source Port: TCP (any)
    Destination Port: TCP 3392
     
    Regards,
    Vik Singh
     
    Everything works using port 3389. I have changed port to 3392 on router and registry. How do I change firewall rule to port 3392? port is grayed out - not changeable
    2010年10月2日 23:12
  • I suspected I would have to figure this out myself. You CAN change the port number on the default inbound rule. Simply search the registry and change every instance of 3389 (where it refers to a port) to 3392 (or your preferred port #). Also in "Network and Sharing Center" change the TCP adapter settings from "Obtain an IP address automatically" to "Use the following IP address" using an address in the range of your router. Then in your router point port 3392 (or whatever # you used) to this static IP. Note: the wording in the Remote Desktop Firewall Rule Description still says 3389 but if you look at the local port actually being used it has changed.

    As always with registry changes - backup first!

    • 回答としてマーク rod001 2010年10月3日 20:51
    2010年10月3日 20:50
  • You really SHOULD create a new firewall rule with port 3392.

    It's always possible some update in the future could put the default remote desktop port back at 3389 where it's "supposed" to be.

    Besides, it's easier to create a new rule than to go through the registry and find the default one and change it.

    Go to Control Panel - Windows Firewall - click on Advanced Settings, click yes that it's ok to change - click Inbound Rules - click New Rule - click the PORT button - click Next - Click TCP or UDP button (TCP, for me) - put 3392 in the PORT box - click Next - click ALLOW the connect button - click Next - click Domain and/or Private and/or Public buttons - click Next - give the rule a NAME - click Finish.

    Sounds complicated, but it flows right through...

    2013年8月19日 1:27
  • will this prevent scanning for viruses on that port ?
    2018年6月12日 7:42