none
2003からのアップグレードしたドメインでDNSが参照できなくなる RRS feed

  • 質問

  • WindowsServer2003のActiveDirectoryからWindowsServer2008のActiveDirectoryへ
    アップグレードし、2台以上のドメインコントローラが構築された状態。(アップグレード後の機能レベルはフォレスト/ドメイン共に2003)

    上記環境において、すべてのサーバをシャットダウン状態にし、1台のDCを起動するとDNS レコードが表示されなくなる。

    ADとして機能しなくなる。
    DNS のサービスは動作している。
    具体的には、MMC で DNS を参照するとサーバー名に赤 ×が付く。
    ログインはできる。

     

    【試した回避策等】

    ・DC の DNS 参照設定に、セカンダリとして外部の DNS を指定すると回避できた。
    ・DNS サービスを再起動で、たまに回復する。
    ・NIC の有効/無効切り替えを行うと確実に回復する。
    ・他のDCのDNSとたすき掛けに参照をしても回避できない。
    ・どのDCを先に起動しても同様の現象は発生する。
    ・新規構築した2008の環境では発生しない。
    ・復旧後3,4日すると同じ現象が起こる。

    また、以下のイベントログが記録されている。
    イベント ID : 4013
    ソース : Microsoft Windows DNS Service


    アップグレードの大まかな手順は以下の通り

    ・2008サーバをドメイン参加
    ・Prepの実行
     adprep /forestprep
     adprep /domainprep
     adprep /rodcprep
    ・DCPROMO実行
    ・DNS サーバー複製(AD統合)
    ・グローバル カタログ複製
    ・FSMO移行
    ・2003降格
    ・2008DC追加

    以上の条件で何か情報をお持ちの方がいれば教えてください。
    何度か検証していますが確実に再現します。

     

    2008年9月25日 9:55

回答

  • チャブーンです。

     

    とりあえず、DNS 周りの 4013 エラーというのは、このイベントですよね。

     

    http://technet.microsoft.com/en-us/library/cc735842.aspx

     

    こういうのは私もまだ知りませんが、DNS Server サービスや AD DS サービスに設定された "サービスの依存関係" に何か問題がある可能性があります。サービスによっては、別のサービスが起動した状態でないと正常に動作しないものがあり、これを防ぐため、あるサービスが起動した後に自サービスを起動できるよう、設定を加えることができます。

     

    正常に設定された (直接 Windows Server 2008 をインストールした) ものと、アップグレードしたものとの、両サービスのサービスの依存関係に関する項目をチェックして、差がないか確認する、という方法をとってみてはどうでしょう?まあこれで解決するかどうか、正直わからないですけれどね。

    2008年9月28日 8:39
    モデレータ

すべての返信

  • チャブーンです。

     

    とりあえず、DNS 周りの 4013 エラーというのは、このイベントですよね。

     

    http://technet.microsoft.com/en-us/library/cc735842.aspx

     

    こういうのは私もまだ知りませんが、DNS Server サービスや AD DS サービスに設定された "サービスの依存関係" に何か問題がある可能性があります。サービスによっては、別のサービスが起動した状態でないと正常に動作しないものがあり、これを防ぐため、あるサービスが起動した後に自サービスを起動できるよう、設定を加えることができます。

     

    正常に設定された (直接 Windows Server 2008 をインストールした) ものと、アップグレードしたものとの、両サービスのサービスの依存関係に関する項目をチェックして、差がないか確認する、という方法をとってみてはどうでしょう?まあこれで解決するかどうか、正直わからないですけれどね。

    2008年9月28日 8:39
    モデレータ
  • チャブーンさん

     

    ご回答ありがとうございます。

     

    一応追記させていただきますと

    この現象が起きた時に色々と試してDNS Serverサービスを遅延開始にしてみたのですが

    改善されませんでした。

    ADSは遅延開始できなかったです。

     

    ドメインコントローラは起動時に複製パートナーとの間で Active Directory データベースの複製を

    行うのですがそれが終わるまでDNSサービスは起動しないようです。

    DNSが先のイメージでしたが。。。

     

    なので今回の場合は全ドメインコントローラがシャットダウン状態から

    1台を起動するので複製処理のタイムアウトを待っている状態でこのような現象が起こるようです。

     

    2008と2003からのアップグレードを比べる。。盲点でした。

    時間がある時に比べてみます。

    2008年9月29日 8:39
  • Atsushi0000 さん、

     

    こんにちは!

    フォーラム オペレーターの服部 清次です。

    Atsushi0000 さんがこちらの質問を投稿されてから少し時間が経ちましたが、その後いかがでしょうか?

     

    Atsushi0000 さんのその後が気になるところなのですが、今回、チャブーン さんの情報が参考になったのではないかと思いましたので、こちらの情報を他の方々に役立てていただくためにも、ひとまず私の方で回答チェックを付けさせていただきました。

    もし Atsushi0000 さんの問題がまだ解決していない場合は、回答チェックを外して返信していただくことも可能です。

    また、よろしければ、2003 と 2008 を比較した結果なども投稿していていただけると嬉しいです。

     

    これからも TechNet Forum をどうぞよろしくお願いします!

    それでは、また!

     

    _____________________________________________

    マイクロソフト株式会社 フォーラム オペレータ 服部 清次

    2008年10月16日 4:03