none
ソースTcpip, イベントID4199:IPアドレスの競合が検出されました RRS feed

  • 質問

  • お世話になります。

    サーバなので固定IPアドレスにて運用しています。
    従来Windows 2000 Serverでしたが、今回、同じマシンにWindows Server 2008をピュアインストールしました。

    その結果次のネットワークエラーのダイアログが表示され、接続表示が「ローカルのみへのアクセス」となり、インターネットに繋がりません。

    ネットワークエラー
    IPアドレスの競合が検出されました
    このネットワーク上の別のコンピュータが、このコンピュータと同じ、IPアドレスを使用しています。…


    システムのイベントビューアには次が記録されました。

    IPアドレスxxx.xxx.xxx.xxx(自分自身です)とシステムのネットワークハードウェアアドレスxx-xx-xx-xx-xx-xx(ゲートウェイのMACです)が重複しているのを、検出しました。
    ソースはTcpipでイベントIDは4199でした。


    ipconfig /all を実行して確認すると
    物理アドレスは従来からの自分自身のMACを表示
    IPv4アドレスは自分で設定した固定IPのアドレス(重複)の他に
    自動構成IPv4アドレス 169.254.xxx.xxx(優先)が表示されます。
    サブネットマスクも自動構成IPv4に対応する 255.255.0.0が表示されます。

    このサーバを固定IPのネットワークから192で始まるネットワークに接続してIPアドレスを自動的に取得する様にするとネットワークに接続され、インターネットにもアクセス出来ます。
    この状態でサーバをSP2の状態までアップデートしてから固定IPのネットワークに戻すと、最初と同じ状態でネットワークエラーになります。

    固定IPのアドレスを他のアドレスに変えて試してみましたが、エラーの内容は同じでした。

    サーバOSをアップしたものの、今はサーバとして機能せず、困り果てています。
    どうか助けて下さい。

    2010年3月20日 9:53

回答

  • システムのイベントビューアには次が記録されました。

    IPアドレスxxx.xxx.xxx.xxx(自分自身です)とシステムのネットワークハードウェアアドレスxx-xx-xx-xx-xx-xx(ゲートウェイのMACです)が重複しているのを、検出しました。
    ソースはTcpipでイベントIDは4199でした。

    まずは素直に、イベントビューアーに出ているとおりにゲートウェイの IP アドレスを確認した方がいいでしょう

    今までのサーバーの方が、ゲートウェイより以前から起動していたために、ゲートウェイが重複した IP アドレスの使用を抑制させられていた可能性も考えられます
    重複した IP アドレスを持ったサーバーが停止したために、ゲートウェイがその IP アドレスを自分の所有だと公知し始めたのかもしれません

    2010年3月20日 22:02
  • ルータに proxy arp 設定が入っていると、条件が揃うとそのような症状になることがあります。
    MVP for Virtual Machine : Networking
    2010年3月21日 23:42
    モデレータ

すべての返信

  • システムのイベントビューアには次が記録されました。

    IPアドレスxxx.xxx.xxx.xxx(自分自身です)とシステムのネットワークハードウェアアドレスxx-xx-xx-xx-xx-xx(ゲートウェイのMACです)が重複しているのを、検出しました。
    ソースはTcpipでイベントIDは4199でした。

    まずは素直に、イベントビューアーに出ているとおりにゲートウェイの IP アドレスを確認した方がいいでしょう

    今までのサーバーの方が、ゲートウェイより以前から起動していたために、ゲートウェイが重複した IP アドレスの使用を抑制させられていた可能性も考えられます
    重複した IP アドレスを持ったサーバーが停止したために、ゲートウェイがその IP アドレスを自分の所有だと公知し始めたのかもしれません

    2010年3月20日 22:02
  • ルータに proxy arp 設定が入っていると、条件が揃うとそのような症状になることがあります。
    MVP for Virtual Machine : Networking
    2010年3月21日 23:42
    モデレータ
  • 回答ありがとうございます。

    アドバイス通りに出来た訳ではないのですが、アドバイスいただいた様にルータに問題があると考えました。
    ルータの調査ですが、Windows 2000 Server の時に順調に稼働していたので気付きませんでしたが、今回ルータの編集画面が開きませんでした。この状態でも他のWindows 2000 Serverは順調にインターネットに接続出来ていました。現状の設定状態を確認したかったのですが諦めてリセットしてみる事にしました。
    それに先立ち、ルータのメーカーHPを見て現在のファームウェアのバージョンを調べるとかなりアップしていました。新しいバージョンではVista対応となっていましたので、これをダウンロードしてからルータのリセットを行いファームウェアのバージョンアップを行ってから新たに接続設定をやり直しました。
    その結果、Windows Server 2008がネットワークに接続される様になりました。
    この正常な状態では、自動構成IPv4アドレス 169.254.xxx.xxxが表示される事は無くなりました。

    纏めますと、Windows Server 2008が繋がらなかった原因は、ルータのファームウェアが古かった為であったと判断しました。

    2010年3月22日 13:44
  • 回答ありがとうございます。
    上の竜さんへの返信に書いたのですが、ルータのモニタ画面、設定画面が開きませんでしたので確認出来ませんでしたが、アドバイスを頂いたお陰でルータの調査を行い解決しました。
    2010年3月22日 13:49
  • こんにちは、フォーラムオペレーターの三沢健二です。

    竜 さん、Murashima Syuichi さん、アドバイスありがとうございます。

    cazz2010 さん、無事に問題が解決できたようで良かったです。

    それでは、皆様のアドバイスが参考になられたようですので、私の方で [回答としてマーク] を付けさせていただきました。


    これからも皆様の情報交換の場として、ぜひ TechNet フォーラムをご利用ください。

    ______________________________________
    マイクロソフト株式会社 フォーラムオペレーター 三沢健二

    2010年3月23日 2:54
    モデレータ