none
IIS を起動できない。 RRS feed

  • 質問

  •  Visual Studio 2003 から 2005 へ昨夏より移行し

    OS= WinXp Sp2 + IIS 6.0 という環境です。

    Database をメンテしようとして数ヵ月ぶりに

    PC を起動してみたところ、IIS が Autostart

    していないことに気が付きました。さらに

     Services から IIS Admin をスタ-トさせようと

    すると

     

      Could not start the IIS Admin servce on local Computer.

        Error 13: The data is invalid.

     

    というエラーメッセージが出ました。ちょっと忘れていたのですが

    Visual Studio 2005 Professinal を Install した段階で

    IIS 6.0 は殺されるんだったでしょうか。つまり開発環境専用の

    Web Server が動いているので、IIS は動かないように

    設定されていたのでしょうか。

     だいぶ間抜けな質問になってしまいましたがよろしくお願いします。

    • 移動 Wang Huang 2012年10月2日 1:45 (移動元:Internet Information Services 5.x, 6.0 - 全般)
    2008年1月15日 20:07

回答

すべての返信

  •  bs6 さんからの引用

     Visual Studio 2003 から 2005 へ昨夏より移行し

    OS= WinXp Sp2 + IIS 6.0 という環境です。


    Windows XpであればIISのバージョンは5.1であり、IIS 6.0は動かないはずです。
    私が無知なだけかもしれませんが、動かす方法があるのでしょうか?

     

     bs6 さんからの引用

    Visual Studio 2005 Professinal を Install した段階で

    IIS 6.0 は殺されるんだったでしょうか。つまり開発環境専用の

    Web Server が動いているので、IIS は動かないように

    設定されていたのでしょうか。


    IISが殺されることはありません。Visual Studio 2003でWebアプリケーションの開発を行うこともありますので。

    2008年1月16日 2:07
  • x64環境でしょうか?そうであればIIS6.0です。

     

    2008年1月21日 0:15
  • > IISが殺されることはありません。

     

    IIS は 5.1 だったんだと思います。というのもすでに

    死んでしまっているので Version もわかりません。

    VS 2005 prof のインストールのステップの中で

    ウィザードの途中で、IIS を起動できなくするかどうかの

    問い合わせに Yes とでも返答したのでしょうか。

    自分でやったんだと思いますがとにかく

     IIS は死んでいます。

     

    重ねての質問で恐縮ですが、、、

    もしかすると IIS 5.1 と VS2005 prof を

    WinXp Sp2 の中で共存させることは、普通に

    可能なのでしょうか。

     

    実は、ASP ( ASP.NET ではなく ) も

    いまだに利用しています。IIS が共存してくれれば

    同じ WinXp を開発用マシンとして利用可能( VS 2003 の

    ときはそうしておりました)なので大助かりなのです。

     

    あるいは、VS2005 prof にて ASP のデバッグが

    できるとか? 

     

    以上、初歩的な質問ばかりで恐縮ですが

    よろしくお願いします。

     

    2008年1月21日 19:39
  • > 死んでしまっているので Version もわかりません。

     

    訂正させていただきます。IIS は起動できませんが

    snap-in というのでしょうか IIS の Manager は起動できますので

    その help から IIS の Version を確認することができました。

    5.1 でした。

     

    2008年1月21日 19:54
  • IIS 5.1 だと Metabase が XML ではなく、binary ですね。

     

    IIS 6.0 以降の metabase.xml では破損したことが無いですが、Binary 形式の metabase は壊れたことが何度かあります。

     

    metabase.bin をとりあえず rename してみては?

    2008年1月22日 0:15
  • > 壊れたことが何度かあります。

     

    今朝方、Command Prompt を起動しようとしたのですが

    Error ! となりました。ここに至ってようやく

    OS そのものが、あるいは、HDD が

    こわれたのではないかと疑っております。

     

    その前に、Virus のチェックをするための

    準備をしているところです。

    2008年1月22日 4:05
  • お騒がせしました。

    HDD に読み取り不良セクターが発生した、と確認しました。

    ありがとうございました。

    2008年1月22日 20:04