none
ドメイン参加の際、ネットワークパスが見つかりません

    質問

  • 1台だけドメインに参加が出来ません。
    というよりクライアントPC側は参加した事になっていますが、DNSサーバ側では参加していないような状態に見えます。
    クライアントPC側のシステムのプロパティのドメイン名は正しく表示されていますが、ローカルのアドミニグループに登録してあるドメインユーザ名が正常に認識されておらずS-1-21・・・というSIDで表示されています。
    また、別のドメインユーザを追加しようしても見つかりませんというエラーが表示されます。
    クライアントWin7
    サーバ Win2008server

    現象及び状況
    ・ネットワークと共有センターにて該当ドメイン名が表示されず、ネットワーク3となっている。
    ・クライアントPCから共有フォルダ等にアクセスが出来ない。他のPCへの直パスをきっても見つからない。
    ・ドメイン参加している別PCからホスト名でのpingが通らない。
    ・コンピュータ一覧(AD ユーザとコンピュータのcomputers)に該当PC名が表示されない。
    ・DNSマネージャの正引きに該当PC名とIPアドレスが表示されない。
    ・workgroupにおとして再度ドメインの再参加をさせようとすると上記エラーにてドメインに参加出来ない。

    実施した事
    ・別拠点にて該当PCを接続した所、問題なくドメインに参加が出来た。
    ・TCP/IPの設定等は問題はなし。
    ・DNSサフィックスに完全修飾ドメイン名を入力すると、ネットワークと共有センターにて「ドメイン名(非認証)」という表示に変わる。
    ・クライアントPCにてDNSキャッシュ及びレジストリのクリア
    ・lmhostにドメイン名を記載
    ・DNSの一覧に旧IPアドレスが表示されていた為、リストから削除。
    ・ADのcomputersから該当PC名を削除
    ・該当PCでログインするドメインユーザをAD側にて再作成
    ・該当PC名を変更、ドメイン参加 →同じエラーにて参加出来ず
    ・ipconfig ドメイン名 → 正常
    ・windowsのファイアーウォール関連及びセキュリティソフトは全て無効

    lmhost、WINSは使用していません。本社⇔拠点間はインターネットVPNで接続しています。
    どこかに以前の情報が残っている為に上手く参加出来ないという事はあるのでしょうか。

    対処法、原因究明、問題の切り分け方法等、ご教授をお願い致します。

    2011年1月19日 5:58

回答

  • ABE NAOKI 様、チャブーン様
    早速のアドバイスありがとうございます。

    ABE NAOKI 様
     本社→拠点ルータまではIPアドレスでpingが通ります。
     また拠点内ネットワークでもIPアドレスでのpingは通り、拠点内ネットワークではコンピュータブラウジングも正常です。
     HUB等も疑わしかった為、拠点ルータに直結しましたが同じ状態でした。  ホスト名でのpingが通らない為、DNSの問題ではないかと考えております。

    チャブーン様
     lmhostsやhostsファイルを確認しましたが何も記載はありませんでした。  また、DNSサフィックスもテスト後すぐに削除しております。
        >その上でまず、ping <ドメインコントローラのIPアドレス> で IP レベルの通信ができることを確認してください。
      →出来ます。nslookup ドメイン名 では 正しいDNSのIPアドレスを返してきます。
         
      LDAPをベンダーに確認させてみます。

    • 編集済み syslady2 2011年1月24日 6:09 改行修正
    • 回答としてマーク syslady2 2011年1月28日 5:49
    2011年1月24日 6:07

すべての返信

  • まず、ネットワークパスが見つからないということは、ネットワークがおかしいということになりますよね。

    そこで切り分けとしては物理的なものから疑ってみてはいかがでしょうか?例えば、ネットワークケーブルやハブなどになります。

    1. 同じセグメントのPCとの通信ができるかの確認を行ってみてはどうでしょう。IPアドレスでのPingによりテストをしてみてください。これがダメならネットワーク層以下の問題となります。(FW設定に注意が必要です)
    2. これがOKなら、ホスト名を使ってのPingですね。これがダメならDNSの問題になります。

    まずはこれらのことを行ってみていただければいいのではないでしょうか?

    以上、参考になれば幸いです。


    MVP:Virtual Machine Blog:MCTの憂鬱 http://naonao71.spaces.live.com/
    2011年1月21日 7:02
    モデレータ
  • チャブーンです。

    この件ですが、トラブルシュートの指針として、「IP通信(pingとか)」と「名前解決」は分けて考えた方がいいですよ。

    まず名前解決を最適化するため、lmhostsやhostsファイルの余計な名前(localhost 以外)はすべて削除してください。
    そして、Windows 7 クライアントの 参照先 DNS サーバーをドメインコントローラだけに向けてください。 また「DNSサフィックス」の内容もいったん全部クリアしたほうがいいでしょう。

    その上でまず、ping <ドメインコントローラのIPアドレス> で IP レベルの通信ができることを確認してください。
    次に、したのページの方法で「ドメインコントローラのSRVレコード(LDAP)」を確認してください。ドメインコントローラのFQDNではありません。

    http://technet.microsoft.com/ja-jp/library/cc816903(WS.10).aspx

    たとえドメインコントローラ自体の名前解決ができていても、SRVレコードの解決ができないと、ドメインへの参加はできないです。
    DNSの名前解決は通常は必須だと考えていただいた方がいいでしょう。NetBIOS over TCP/IP の機能で何とかしよう、とは思わないことです。

    2011年1月21日 13:29
    モデレータ
  • ABE NAOKI 様、チャブーン様
    早速のアドバイスありがとうございます。

    ABE NAOKI 様
     本社→拠点ルータまではIPアドレスでpingが通ります。
     また拠点内ネットワークでもIPアドレスでのpingは通り、拠点内ネットワークではコンピュータブラウジングも正常です。
     HUB等も疑わしかった為、拠点ルータに直結しましたが同じ状態でした。  ホスト名でのpingが通らない為、DNSの問題ではないかと考えております。

    チャブーン様
     lmhostsやhostsファイルを確認しましたが何も記載はありませんでした。  また、DNSサフィックスもテスト後すぐに削除しております。
        >その上でまず、ping <ドメインコントローラのIPアドレス> で IP レベルの通信ができることを確認してください。
      →出来ます。nslookup ドメイン名 では 正しいDNSのIPアドレスを返してきます。
         
      LDAPをベンダーに確認させてみます。

    • 編集済み syslady2 2011年1月24日 6:09 改行修正
    • 回答としてマーク syslady2 2011年1月28日 5:49
    2011年1月24日 6:07