none
ワークフローで設定した、メール本文のエンコードされた絶対URLが開かない RRS feed

  • 質問

  • こんにちは

    SharePoint Desigunerを使用して、カスタムリストにワークフローを設定しました。
    アクション[電子メールを送信する]の[本文への参照の追加]に以下の設定を行いましたが、
    メール本文に記載されているURLが開きません。原因をお教えいただけますでしょうか?
    また、正しいURLが記載される方法がありましたらお教えいただけますでしょうか?

    ■設定内容
    ソース:現在のアイテム
    フィールド:エンコードされた絶対URL

    送られてきたメール本文に記載されているURLは以下の通りです。
    http://xxxxx/sites/xxxxx/Lists/List4/4_.000

    カスタムリストからアイテムを表示した時のURLは以下の通りです。
    http://xxxxx/sites/xxxxx/Lists/List4/DispForm.aspx?ID=4

    ■動作環境
    Server:Windows 2003 R2、SharePoint 2007
    Client:Windows XP、VISTA
    Service Pack:WSS/MOSS SP2

    何らかのヒントになるような情報があれば
    ご教示頂けませんでしょうか。

    よろしくお願いいたします。

    2010年12月2日 5:39

回答

  • 残念ながらこれは仕様です。

    そこで発想を切替えます。

    http://xxxxx/sites/xxxxx/Lists/List4/DispForm.aspx?ID=

    までは常に固定ですのでここはテキストでひらうちしてしまします。

    最後の数字の部分だけ、参照変数で動的に値を取得します。

    あまりスマートとは言えませんがこれで一応きちんと動きます。

     

     

     


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答としてマーク ichigo5657 2010年12月3日 4:53
    2010年12月2日 14:08

すべての返信

  • 残念ながらこれは仕様です。

    そこで発想を切替えます。

    http://xxxxx/sites/xxxxx/Lists/List4/DispForm.aspx?ID=

    までは常に固定ですのでここはテキストでひらうちしてしまします。

    最後の数字の部分だけ、参照変数で動的に値を取得します。

    あまりスマートとは言えませんがこれで一応きちんと動きます。

     

     

     


    SharePoint MANIACS あなたの SharePoint 活用できていますか?ちいさな「アドバイス」からご支援します。 http://sharepointmaniacs.com/
    • 回答としてマーク ichigo5657 2010年12月3日 4:53
    2010年12月2日 14:08
  • 中村 和彦さん

    ご回答ありがとうございます。
    >http://xxxxx/sites/xxxxx/Lists/List4/4_.000
    こちらの表示形式は仕様なのですね。

    アドバイスいただいた通り、固定部分をテキストで入力し、
    参照変数で値を取得する方法で試してみたいと思います。

    ありがとうございました。
    2010年12月3日 4:53