none
移行エンドポイントのサーバー検出不可 (Exchange ハイブリッド) RRS feed

  • 質問

  • タイトルの件、皆様のお知恵をお借りしたく投稿させて頂きました。


    【質問内容】:

    Exchange Online ヘのメールボックス移行の際に、Exchange Online 側の移行エンドポイント設定で、サーバーが自動検出されない原因についてご教示ください。

    【環境】:

    ・Exchange Server 2013 CAS, MBX

      →Exchange Online とのハイブリッド構成済み

        CAS にてMRS有効化済み

    ・お名前.com

      →ドメイン、外部DNS を利用

    ・SSL 証明書

      →Core SSL ワイルドカードを利用

    【状況】:

    ・Exchange Server 2013 上にあるメールボックスを移行するため、ハイブリッド構成を行い、リモート移動移行での移行を検討しております。

     移行バッチ作成の前に、エンドポイントの設定を行おうとEAC→Office365サインイン→移行エンドポイントとウィザードを起動したのですが、設定ウィザード内「移行エンドポイントの作成」にて、サーバー設定を検出できない警告が発生しており先に進めなくなっております。 

     ※Exchange Server 上の移行エンドポイントも確認したところ、こちらは自動検出がされました。

     MRS については、CAS 側で有効にしており、手動でCAS, MBX のFQDN を入力しても確認出来ないとのエラーが出力されてしまう状況です。

    フォーラム内に同様の質問が存在しなかったため、お手数をお掛け致しますが、お力添えいただけますと幸いです。

    2017年3月24日 0:37

回答

  • 接続アナライザの結果を確認させて頂きましたが、外部DNSでautodiscoverのAレコードがOffice365側を向いていませんでしょうか?
    ハイブリッド構成の場合はautodiscoverはオンプレミス側を向ける必要があります。(合わせてautodiscoverをSANとするSSL証明書も必要です)

    https://technet.microsoft.com/ja-jp/library/hh534377(v=exchg.150).aspx

    自動検出 DNS レコード   社内の Exchange 2013 クライアント アクセス サーバーをポイントするように、既存の SMTP ドメイン向けに自動検出パブリック DNS レコードを構成します。

    • 回答としてマーク kahoso 2017年3月29日 1:08
    2017年3月27日 7:54

すべての返信

  • リバースProxyサーバは適切に構成されておりますでしょうか?

    ・EWSのExternalURLとAutodiscoverの外部DNSレコードが正しくリバースProxyサーバのグローバルIPに向いている
    ・リバースProxyはPre-AuthせずパススルーでCASに接続される

    あたりを確認頂ければ、と。

    2017年3月24日 1:56
  • genki.w 産の内容に捕捉しますと、オンプレ側からO365への到達性はあるが、

    O365から見て、ハイブリッドが見つからない状態です。

    なので、外部から ハイブリッドサーバに正しく名前解決できアクセスできる状態なのであれば、うまくいくはずです。

    2017年3月24日 4:54
  • genki.w 様、Hotaka 様

    上記の件、ご回答いただき誠にありがとうございます。

    現状と致しましては、まだ先に進めていない状態となります。

    ご指摘頂きました通り、外部DNS の設定が間違っており、外部からのアクセスが出来ない状態となっておりました。

    そのため、外部DNS にWeb Application Proxy (WAP)のグローバルIP を登録し、WAP上にてEWSのExternal URLとAutodiscover を公開致しました。

    WAP サーバーは、内部のDNS を見ており、そちらでExternal URL とAutodiscover のアクセス先がCAS になるようAレコードを登録しております。

    上記の設定を行い外部からExternal URL とAutodiscover へアクセスすると、Autodiscover はxml の中身が表示され問題無いことが確認出来たのですが、External URL の方は、400 Error によりアクセスが出来ない状態です。

     ※Internal URL からアクセスをするとEWS のサービス画面が正常に表示されます。

       「Get-WebServicesVirtualDirectory」コマンドにより、MRSProxyEnable、External URLに間違いが無い事を確認済み

    恐らくですが、まだ外部からのアクセスが出来ていない or EWS 側に問題があると考えております。

    別途何か考慮するべき点が無いか、ご教示いただけますでしょうか。

    何卒よろしくお願い致します。

    ************ 13:58 追記 ************

    一点追加での情報を記載致します。

    今回構築しているサーバーですが、全てAzure 上に構築しております。

    DNS は、各NIC で内部DNS を見る様に設定しており、WAP, CAS, MBX のみ、NSG で、HTTPS(443)とSMTP(25)が通るよう設定をしております。


    • 編集済み kahoso 2017年3月27日 5:00
    2017年3月27日 4:48
  • ・400番エラーの詳細は何か表示されておりますでしょうか
    ・WAPの認証モードはPass-Thruで設定されたか確認できますでしょうか
    ・リモート接続アナライザのMicrosoft Exchange Web Services Connectivity TestsならびにOutlook Autodiscoverの実行結果は如何でしょうか。
    https://www.testconnectivity.microsoft.com/


    2017年3月27日 5:36
  • genki.w 様

    早速のご回答誠にありがとうございます。

    ご指摘頂きました点、回答致します。

    ・400番エラーの詳細は何か表示されておりますでしょうか

     →400番エラーの画面の詳細情報に、以下メッセージが出力されておりました。

    https://<CAS FQDN>/ews/exchange.asmx/このエラー (HTTP 400 正しくない要求) は、Web サーバーに接続されましたが、アドレスに問題があって Web ページが見つからなかったことを意味します。

    HTTP エラーについての詳しい情報は、ヘルプをご覧ください。

    ・WAPの認証モードはPass-Thruで設定されたか確認できますでしょうか

     →リモートアクセス画面から、事前認証がパススルーで公開されていることを確認致しました。

    ・リモート接続アナライザのMicrosoft Exchange Web Services Connectivity Testsならびに<label for="testSelectWizard_ctl09_onPremSelectionList_radioAutoDiscOutlook">Outlook Autodiscover</label>の実行結果は如何でしょうか。

     →Microsoft Exchange Web Services Connectivity Tests の2項目にて、移行エンドポイントの設定で利用しているユーザー、EWS のURL でテストを行い、問題が無い事を確認致しました。

      また、<label for= ~ の部分はどの様なテストを行えばよろしいのでしょうか。

      検索をかけてもすぐにわからなかったため、お手数ですが、ご教示いただけますと幸いです。

    以上、よろしくお願い致します。

    ************ 15:58 追記 ************

    <label for= ~ の部分は、リモート接続アナライザー「Outlook Autodiscover」を実施することと認識致しました。

    確認が足りず申し訳ございません。

    先程「Outlook Autodiscover」を実行したのですが、いくつかエラーが出力されましたので、内容確認し再度更新致します。

    ************ 16:20 追記 ************

    現在はテスト環境のため、Outlook Autodiscover の結果キャプチャを下記に添付致します。

     ※分割されており見づらい点ご了承ください。

    • 編集済み kahoso 2017年3月27日 7:26
    2017年3月27日 6:28
  • 接続アナライザの結果を確認させて頂きましたが、外部DNSでautodiscoverのAレコードがOffice365側を向いていませんでしょうか?
    ハイブリッド構成の場合はautodiscoverはオンプレミス側を向ける必要があります。(合わせてautodiscoverをSANとするSSL証明書も必要です)

    https://technet.microsoft.com/ja-jp/library/hh534377(v=exchg.150).aspx

    自動検出 DNS レコード   社内の Exchange 2013 クライアント アクセス サーバーをポイントするように、既存の SMTP ドメイン向けに自動検出パブリック DNS レコードを構成します。

    • 回答としてマーク kahoso 2017年3月29日 1:08
    2017年3月27日 7:54
  • genki.w 様

    ご回答いただき誠にありがとうございます。

    ご指摘の通り、外部DNS でautodiscover がO365 のレコードを参照しておりました。

    レコードを内部のCAS に変更した結果、外部からEWS サービスを参照できるようになり、リモート接続アナライザーのエラーも検出されなくなりました。

    また、SSL 証明書についてもSAN ではありませんが、ワイルドカードを利用しておりますので、クリアできております。

    しかし、移行エンドポイントの構成は出来ず現在も警告が出ております。

    警告の内容ですが、リモート接続アナライザーでの確認をしてくださいから、以下のような警告文に変わりました。

    ****************** 警告内容抜粋 ******************

    サーバー設定を検出できませんでした。サーバー設定を入力してください。 ExchangeRemote エンドポイント設定を自動検出の応答から判断できませんでした。実行中の MRSProxy は、'<CAS FQDN>' に見つかりませんでした。

    ****************** 警告内容抜粋 ******************

    「Get-WebServicesVirtualDirectory」から「MRSProxyEnabled」がTrue となっていることを確認し、一度無効化→有効化も試してみたのですが、改善されませんでした。

    同様の事例や何かお気づきな点などございましたら、ご教示いただけますと幸いです。

    以上、よろしくお願い致します。

    2017年3月27日 14:57
  • 接続アナライザのEWSの試験で[Use Autodiscover to detect server settings]とした場合において、EWSの外部エンドポイントは検出されて接続可能な状態でしょうか?(すいません、五月雨で聞いてしまいまして)
    2017年3月28日 5:38
  • genki.w 様

    いつもご確認いただき誠にありがとうございます。

    接続アナライザーのEWSの試験で「Use Autodiscover to detect server settings」と設定した結果、両試験において以下警告が出力されました (EWS URLを指定すると表示されません)。

    ■Synchronization, Notification, Availability, and Automatic Replies

    ■Service Account Access (Developers)

    以上、よろしくお願い致します。

    2017年3月28日 7:01
  • 頂いた内容が接続アナライザーの結果の一部と思われますので確実ではないという前提ですが…。

    Autodiscoverで接続した際は証明書の警告(Windows Updateでルート証明書を更新していない端末では正しい証明書として認識されない旨、特定の3rdパーティの証明書では必ず出るものなのでこれ自体は問題ありません)がでて、EWSの外部証明書で接続した場合は証明書の警告が表示されないという状態です。

    Autodiscoverで検知した先のEWSのURLと、手動で接続したEWSのURLが異なる(=そもそも接続先サーバが違う)などという事は無いでしょうか?Autodiscover経由のEWSテストの結果を展開していくと、どのURLがAutodiscoverで検出されて接続に行っているかがわかると思いますので、確認できますでしょうか?

    2017年3月28日 13:05
  • genki.w 様

    早急なご回答誠にありがとうございます。

    上記の件ですが、一旦解決致しました。

    一旦というのは、現在も自動でMRSProxy サーバ(CAS)を検出出来ないのですが、手動にてCAS のFQDN を入力すると、認識されるようになりました。

    外部DNS にCAS を指定するAレコードを登録したところ、認識がされるようになりました。

     ※今までは、CNAME でCAS サーバーを見る様にしておりました。

    そのため、この状態にてメールボックスの移行などを進めさせていただきます。

    genki.w 様には長期間に渡りご質問に対応いただき誠にありがとうございました。

    2017年3月29日 1:08