none
[WHS2011] 自動インストールでcfg.iniを認識しない RRS feed

  • 質問

  • お世話になります。

    cfg.iniを使用してWHS2011で自動かつ64GBのSSDに無理やりWHS2011をインストールしようとしたところ、インストールディスク選択画面から先に進もうとするとエラーが発生してインストールが中断されてしまいました。

    はじめは要求スペック以下の容量のディスクを使用したのが問題かと思いましたが、ログをよくみるとcfg.iniが読み込めていないようで、cfg.iniの設定がまったく反映されていなことに気づきました。詳細は下記ログを参照してください。

    cfg.iniの内容を変えたり、ファイル名、設置場所を何度も確認したりしたのですが、問題は解決せず、このフォーラムに質問させていただくことにしました。よろしくお願い致します。

     

    インストールまでの手順

    1.DSP版インストールディスクからISOファイルを作製

    2.ISOファイルをWindows7 DVD/USB Download Toolを使って8GBのUSBメモリに書きこむ

    3.USBメモリのルートにcfg.iniを作製する

    4.USBからPCをブートしてインストーラを起動する

    5.インストールディスク選択画面でSSDを選択してインストールを開始する→エラー発生

     

    cfg.iniの内容

    [WinPE]

    ConfigDisk=1

    CheckReqs=0

    WindowsPartitionSize=MAX

     

    [InitialConfiguration]

    AcceptEula=true

    AcceptOEMEula=true

    ServerName=HomeServer

    PlainTextPassword=(パスワード)

    PasswordHint=(パスワードのヒント)

    Settings=All

     

    ログの内容

    [2011/05/22 20:39:13  2f4] INFO: Beginning execution from folder: X:\sources 

    [2011/05/22 20:39:13  2f4] WARNING: No Configuration file found

    //cfg.iniファイルが読み込めていない?

    [2011/05/22 20:39:13  2f4] INFO: Setup Running in UI mode

    [2011/05/22 20:39:13  2f4] starting the ui mode

    [2011/05/22 20:39:13  2f4] Initializing common controls

    [2011/05/22 20:39:13  2f4] Done initializing common controls

    [2011/05/22 20:39:13  2f4] Displaying the wizard

    [2011/05/22 20:39:13  2f4] Loading the logo for home server

    [2011/05/22 20:39:13  2f4] Setting the logo for home server

    [2011/05/22 20:39:19  2f4] Populating the disk listview

    [2011/05/22 20:39:19   e4] INFO: Ennumerating valid values for configuration setting InstallDisk for UI

    [2011/05/22 20:39:26   e4] Disk 1b8fe648-acf5-43e9-8710-c5640e49d492

    [2011/05/22 20:39:26   e4]     Name: \\?\PhysicalDrive1

    [2011/05/22 20:39:26   e4]     Friendly Name: UFD USB Flash Drive USB Device

    [2011/05/22 20:39:26   e4]     Device path: \\?\usbstor#disk&ven_ufd&prod_usb_flash_drive&rev_1100#unwa7nup6hvmmyt6k8r3&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}

    [2011/05/22 20:39:26   e4]     Adaptor: USB 大容量記憶装置

    [2011/05/22 20:39:26   e4]     Status: ONLINE

    [2011/05/22 20:39:26   e4]     Health: HEALTHY

    [2011/05/22 20:39:26   e4]     Device type: DISK

    [2011/05/22 20:39:26   e4]     Media type: 0x0000000b

    [2011/05/22 20:39:26   e4]     Size: 8027897856

    [2011/05/22 20:39:26   e4]     Bytes per sector: 512

    [2011/05/22 20:39:26   e4]     Sectors per track: 63

    [2011/05/22 20:39:26   e4]     Tracks per cylinder: 255

    [2011/05/22 20:39:26   e4]     Flags: 0x00001000

    [2011/05/22 20:39:26   e4]     Bus type: VDSBusTypeUsb

    [2011/05/22 20:39:26   e4]     Partition style: MBR

    [2011/05/22 20:39:26   e4]     Signature: 0xc3072e18

    [2011/05/22 20:39:26   e4]     Extent 0 type 0x00007fff size 24576 offset 0

    [2011/05/22 20:39:26   e4]     Extent 1 type 0x00000002 size 8027873280 offset 24576

    [2011/05/22 20:39:26   e4]     Pack (null) status 0x00000001 flags 0x00000000

    [2011/05/22 20:39:26   e4]         [Online]

    [2011/05/22 20:39:26   e4] Disk 9016dd24-9fbc-452c-b4dc-08a93bd3366a

    [2011/05/22 20:39:26   e4]     Name: \\?\PhysicalDrive0

    [2011/05/22 20:39:26   e4]     Friendly Name: 

    [2011/05/22 20:39:26   e4]     Address: Port0Path0Target0Lun0

    [2011/05/22 20:39:26   e4]     Device path: \\?\ide#diskc300-ctfddac064mag______________________0006____#5&3a954a5d&0&0.0.0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}

    [2011/05/22 20:39:26   e4]     Adaptor: ATA Channel 0

    [2011/05/22 20:39:26   e4]     Status: ONLINE

    [2011/05/22 20:39:26   e4]     Health: HEALTHY

    [2011/05/22 20:39:26   e4]     Device type: DISK

    [2011/05/22 20:39:26   e4]     Media type: 0x0000000c

    [2011/05/22 20:39:26   e4]     Size: 64023257088

    [2011/05/22 20:39:26   e4]     Bytes per sector: 512

    [2011/05/22 20:39:26   e4]     Sectors per track: 63

    [2011/05/22 20:39:26   e4]     Tracks per cylinder: 255

    [2011/05/22 20:39:26   e4]     Flags: 0x00005000

    [2011/05/22 20:39:26   e4]     Bus type: VDSBusTypeAta

    [2011/05/22 20:39:26   e4]     Partition style: UNKNOWN

    [2011/05/22 20:39:26   e4]     Extent 0 type 0x00007fff size 64023257088 offset 0

    [2011/05/22 20:39:26   e4]         [Unallocated]

    [2011/05/22 20:39:26   e4] INFO: BIOS requested boot disk is \Device\Harddisk0\Partition0

    [2011/05/22 20:39:26   e4] INFO: Adding the specified system disk \\?\PhysicalDrive0 to the top of the drive list

    [2011/05/22 20:39:26  2f4] Boot disk found. Loading default string

    [2011/05/22 20:39:26  2f4] Getting static control to display the string.

    [2011/05/22 20:39:26  2f4] Displaying the boot disk status message

    [2011/05/22 20:39:30  2f4] INFO: Setting chosen value for configuration setting InstallDisk from UI

    [2011/05/22 20:39:30  2f4] Launching Windows Setup

    [2011/05/22 20:39:30  2f4] INFO: Setup Collecting User Data -------------------------------------------

    //以下、cfg.iniの設定が反映されず、デフォルト値が使用されている。

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for DefaultLanguage

    [2011/05/22 20:39:30  2f4] INFO: No value supplied, using default value AUTO

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for DefaultKeyboard

    [2011/05/22 20:39:30  2f4] INFO: Skipping optional configuration, no value specified

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for DefaultLocale

    [2011/05/22 20:39:30  2f4] INFO: Skipping optional configuration, no value specified

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for DefaultTimeZone

    [2011/05/22 20:39:30  2f4] INFO: Skipping optional configuration, no value specified

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for DefaultServerName

    [2011/05/22 20:39:30  2f4] INFO: No value supplied, using default value Server

    [2011/05/22 20:39:30  2f4] WARNING: Unable to verify computer name availability due to network error 2136

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for Drivers

    [2011/05/22 20:39:30  2f4] INFO: Skipping optional configuration, no value specified

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for InstallDisk

    [2011/05/22 20:39:30  2f4] INFO: Using UI specified value

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for SystemPartitionType

    [2011/05/22 20:39:30  2f4] INFO: Populating internal setting from existing data

    [2011/05/22 20:39:30  2f4] INFO: MBR firmware detected

    [2011/05/22 20:39:30  2f4] INFO: GetFirmwareEnvironmentVariableW indicated required partition type 1 (Status: 1)

    [2011/05/22 20:39:30  2f4] WARNING: Changing partition type of system drive to 1 due to firmware requirements

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for SystemPartitionActive

    [2011/05/22 20:39:30  2f4] INFO: Populating internal setting from existing data

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for SystemPartitionFormat

    [2011/05/22 20:39:30  2f4] INFO: Populating internal setting from existing data

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for MSRPartitionType

    [2011/05/22 20:39:30  2f4] INFO: Populating internal setting from existing data

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for WindowsPartitionID

    [2011/05/22 20:39:30  2f4] INFO: No value supplied, using default value AUTO

    [2011/05/22 20:39:30  2f4] INFO: Getting configuration for WindowsPartitionSize

    [2011/05/22 20:39:30  2f4] INFO: No value supplied, using default value 61440

    //cfg.iniで設定した値(MAX)ではなくデフォルト値が使用されて、エラーが発生。MAXでなく具体的な値を入れても同じ。

    [2011/05/22 20:39:30  2f4] INFO: Calculated pre system partition remaining space as: 63917350912

    [2011/05/22 20:39:30  2f4] ERROR: Specified partition size is too large to support a data partition, maximum possible is: 50716 MB (Alternatively, use MAX to span the whole disk)

    [2011/05/22 20:39:30  2f4] ERROR: The value chosen for this setting is invalid

    [TRACE] UIBackend::Launch : Exited (0x80004005)

    [2011/05/22 20:39:30  2f4] Failed to launch Windows Setup

    以上

    2011年5月22日 13:47

回答

  • 鳩の谷の街です。お世話になります。

    こちらの方でも製品版DVDからUSBを作成してみました。

    このCfg.iniを使用して80GBのHDDにインストールしました。

    (ファイルのエンコードはUTF-16です)

    -------------------------------------------------------------------

    [WinPE]
    InstallSKU=SERVERHOMEPREMIUM
    ConfigDisk=1
    CheckReqs=0
    WindowsPartitionSize=MAX

    [InitialConfiguration]
    AcceptEula=true
    AcceptOEMEula=true
    ServerName=(ServerName)
    PlainTextPassword=(Password)
    PasswordHint=itumono(PassHint)
    Settings=All

    -------------------------------------------------------------------

    自動インストールの場合に何かしらの問い合わせがある場合は

    ファイルの設定情報を疑ってください。

    それと一度インストールすると、成功の是非に関係なく

    ”Processed=true”

    と付加されますので、再度インストールするときはこの一文を外してください。

     

    参考になれば幸いです。

    PS.一度回答したのですが、一部問題があるので修正しました。

     

    • 回答としてマーク mekajiki 2011年5月23日 9:54
    2011年5月22日 16:34
    回答者:

すべての返信

  • 鳩の谷の街です。お世話になります。

    こちらの方でも製品版DVDからUSBを作成してみました。

    このCfg.iniを使用して80GBのHDDにインストールしました。

    (ファイルのエンコードはUTF-16です)

    -------------------------------------------------------------------

    [WinPE]
    InstallSKU=SERVERHOMEPREMIUM
    ConfigDisk=1
    CheckReqs=0
    WindowsPartitionSize=MAX

    [InitialConfiguration]
    AcceptEula=true
    AcceptOEMEula=true
    ServerName=(ServerName)
    PlainTextPassword=(Password)
    PasswordHint=itumono(PassHint)
    Settings=All

    -------------------------------------------------------------------

    自動インストールの場合に何かしらの問い合わせがある場合は

    ファイルの設定情報を疑ってください。

    それと一度インストールすると、成功の是非に関係なく

    ”Processed=true”

    と付加されますので、再度インストールするときはこの一文を外してください。

     

    参考になれば幸いです。

    PS.一度回答したのですが、一部問題があるので修正しました。

     

    • 回答としてマーク mekajiki 2011年5月23日 9:54
    2011年5月22日 16:34
    回答者:
  • 早速の回答ありがとうございました。

    提示していただいたcfg.iniをメモ帳にコピーして、パスワードなどを編集してからunicode形式で保存し、再挑戦してみましたが全く同じエラーが発生しました。

    ”Processed=true”が付加されたことは今まで一度もありませんでした。


    どうしようもない凡ミスをしている可能性もあるので、もう一度設定を見なおしてみます・・・

    2011年5月22日 21:51
  • 試しに同じcfg.iniファイルを使って、300GBのHDDにインストールしたところ、問題なく自動インストールできました。

    恐らく、WindowsPartitionSizeのデフォルト値である61440MB(=60GB)未満のディスクにはインストールできないものと思われます。

     

    余談ですが、HDDに作成された60GBのパーティションをKnoppixのGaertedでSSDに入るサイズにリサイズし、EASEUS Disk Copyを使ってHDDからSSDにパーティションをコピーしたところ、一応SSDからWHS2011が起動しました。もちろん推奨される使い方ではなく、何が起こるか分かりませんので、しばらくV1と併用して様子を見ようと思います。

     

    • 回答の候補に設定 project-whs 2011年11月27日 16:15
    2011年5月23日 9:53
  • 今までの回答で、記載されていない以外な盲点があったので、記載しておきます。

    もしcfg.iniをOS上拡張子を表示していない状態で編集している場合、cfg.ini.txt※となっている場合があります。

    ※恥ずかしながらwindows7の標準状態でファイルを作成し、1日悩みました><

    その他、私が嵌った問題はUTF-16(BOMつき)になってたくらいです。

    実際、UTF-16(BOMなし)か、Shift-jisで、cfg.iniをUSBのルートに配置することさえ

    間違えなければ、さくっとインストールできるのではないでしょうか。

    私のようなミスはないかと思いますが、参考まで。

    2011年8月12日 14:51