none
HTTPS通信の代替アクセスマッピングについて RRS feed

  • 質問

  • 現在 SharePoint 2013 への負荷分散を検証しているのですが、期待している動作が確認できません。

    構成は下記の通りです。

    Client - ロードバランサ - SharePoint サーバ

    ここで、Client - ロードバランサ間が http の場合には、正しく SharePoint サーバのコンテンツが表示されるのですが、

    これを https の通信にすると、コンテンツが表示されません。(ロードバランサ - SharePoint 間はいずれも http です)

    この時、代替アクセスマッピングは下記のように設定しているのですが、設定に何か不備があるのでしょうか。

    "https://10.0.15.52" はロードバランサが Client からのアクセスを受け付けるアドレス (Client がブラウザに入力するアドレス)、"http://10.1.15.250" は SharePoint サーバのアドレスです。

    2018年11月7日 1:16

すべての返信

  • 画像が投稿できなかったので、テキストにて失礼します。

    代替アクセスマッピングは下記のように設定しています。

    内部URL                              領域               領域のパブリックURL

    https://10.0.15.52         ユーザー設定         https://10.0.15.52

    http://10.1.15.250         ユーザー設定         https//10.0.15.52

    2018年11月7日 1:20
  • 正常に動いていた http の場合の代替アクセスマッピングは

    内部URL                              領域               領域のパブリックURL

    http://10.0.15.52           ユーザー設定         http://10.0.15.52

    http://10.1.15.250         ユーザー設定         http//10.0.15.52

    ということですか?

    2018年11月7日 9:22
  • 返信ありがとうございます。

    >正常に動いていた http の場合の代替アクセスマッピングは

    >内部URL                              領域               領域のパブリックURL

    >http://10.0.15.52           ユーザー設定         http://10.0.15.52

    >http://10.1.15.250         ユーザー設定         http//10.0.15.52

    >ということですか?

    はい、その通りです。

    上記のように設定した状態でブラウザから http://10.0.15.52 にアクセスすると、SharePoint サーバのコンテンツ (http://10.1.15.250) が正しく表示されました。

    2018年11月8日 0:32
  • となると、ロードバランサーでのアドレス変換は上手くいってるんですね。
    また、既定のゾーンに指定されている URL でも上手く繋がるんですよね?

    トラブルシュートしようと思うと、あとは https 化後にちゃんとサーバーにアクセスが届いているか等からでしょうけど、もう確認されているでしょうし…、試してみるとしたら、領域を他のインターネットやイントラネットに変えてみるなどでしょうか?

    2018年11月8日 10:04