none
Windows 7 very slow logon, Waiting for the User Profile Service, winlogon event 6006

    質問

  • Hello,

    Every so often one of our Windows 7 clients which is not normally having any delay at logon will take a very long time to login. This may be 10 or 20 minutes or up to an hour in some cases.

    Typically the event log will contain entries like

    The winlogon notification subscriber <Profiles> took 572 second(s) to handle the notification event (Logon).

    There is no further information available from Event Log Online Help, nor any additional detail as to why the logon event was so slow. During the delay the user will just see "Waiting for the User Profile Service" on their screen.

    We first started seeing this problem with Windows Vista and if anything the situation has not improved since then. It has never happened with any of our Windows XP users.

    We are currently planning a migration of computers to Windows 7 but stuff like this which has not been resolved in Windows over a 2 year period will stall that migration. The least improvement is to increase the event notification to give a lot more information on why the user profile processing has stalled.

    2010年6月16日 22:41

回答

  •  

    Hi,

     

    When did the issue begin to occur? Did it occur after installing certain application or applying certain policy?

     

    To troubleshoot the issue, please perform the following step.

     

    1. Restart the machine in Safe Mode with Networking to check whether the system can login quicker.

     

    2. Type “gpedit.msc” in Search box and press Enter. Navigate to the following location:

     

    Computer Configuration->Administrative Templates->System->Logon

     

    Please double click “Always wait for the network at computer startup and logon” policy and disable it.

     

    3. Perform a Clean Boot to check the result.

     

    Thanks,

    Novak

    • 回答としてマーク Novak Wu 2010年6月21日 1:41
    2010年6月17日 5:47

すべての返信

  •  

    Hi,

     

    When did the issue begin to occur? Did it occur after installing certain application or applying certain policy?

     

    To troubleshoot the issue, please perform the following step.

     

    1. Restart the machine in Safe Mode with Networking to check whether the system can login quicker.

     

    2. Type “gpedit.msc” in Search box and press Enter. Navigate to the following location:

     

    Computer Configuration->Administrative Templates->System->Logon

     

    Please double click “Always wait for the network at computer startup and logon” policy and disable it.

     

    3. Perform a Clean Boot to check the result.

     

    Thanks,

    Novak

    • 回答としてマーク Novak Wu 2010年6月21日 1:41
    2010年6月17日 5:47
  • Hi,

    follow my guide here to make a boot trace [1] and compress the boot_BASE+CSWITCH+DRIVERS+POWER_1.etl as 7z or RAR and upload it to your Skydrive [2] and post the link here.

    I take a look at the trace, maybe I see what's wrong with your Windows.

    regards
    André

    [1] http://www.msfn.org/board/index.php?showtopic=140247
    [2] http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    2010年6月17日 14:53
  • Hi,

     

    I am having the same issue with alot of computers on our domain, pretty much any computer outside our central office can take from 1-30 minutes to load the users profile. We have this issue even after a computer has been freshly imaged. I wanted to know if you disable "Always wait for the network at computer startup and logon", will it affect group policy? If so, its not really a fix.

     

    Is there any other fix?

    Thanks


    2011年7月20日 1:11
  • Dave - I have the same issue when I enable Always wait for the network at computer startup and logon....when I am outside the network and am connected to cable the please wait sits there forever....I remove the cable connection and make sure wireless is off and it goes directly to the control-alt-delete. On the work network it boots up just fine...no delay.

     

    When I set it to not configured the PC logs in great on and off the network...no issues other then the group policy settings not being applied. Haven't found a solution but if you have that would be great.


    Help
    2011年9月9日 20:52
  • I have the same issue as well.  All machines when removed from the domian take a long time to get past the welcome screen. (2-5 min)

    Verbose mode indicates that it is the user profile service.  I beleive it is searching for the domain and waiting for a time out before loading the profile. It seems there should be a setting somewhere to control this behavior however I have yet to find it either in GPO or the registry.  I have disabled the  "Always wait for the network at computer startup and logon", This didn't seem to have any effect on the situation at all.  All machines have a jpeg. background so no it is not a solid color issue.  I am on a SBS2011 domain.  Any help troubleshooting this issue is greatly appreciated.

    -Brian

    2011年9月23日 15:49
  • Same problem here, worse on some sites than other. Stumbled across it being the home drive mapping in the user profile in AD. Still trying to work out why this is. Will post if do find the reason, probably some DNS thing I guess.

    2011年10月20日 8:46
  • Ok not sure but wanted to share these GP settings we use. So far so good in our environment. These are the only options set

    Computer Configuration>Admin Templates>System>Logon>Dont display the getting started welcome screen at logon - Enabled

     

    Computer Configuration>Admin Templates>System>Scripts>Maximum wait time for GP scripts - Enabled - 30

    Computer Configuration>Admin Templates>System>Scripts> Run logon scripts synchronously - Disabled

    Computer Configuration>Admin Templates>System>Group Policy>Startup policy processing wait time - 10

     

    Not sure if this helps....but just wanted to share since things seem to be as that where with XP now....finally.

     

     


    Help
    • 回答の候補に設定 MickeSwe 2012年4月2日 6:55
    • 回答の候補の設定解除 MickeSwe 2012年4月2日 6:55
    2011年10月20日 18:36
  • Hi!

    I’ve noticed that if you are running folder redirection and have disabled the automatic creation of an offline copy Windows will take forever to logon.

    So a tip would be to check and see if offline folders are disabled. (I would normally disable this for WinXp machines as I really don’t like the offline feature in XP but in 7 it’s rather decent).

    2012年4月2日 7:00
  • For us I had to manually delete the contents of these two directories. Both had thousands of files in them that doing clear temp files and cookies in IE or clean up computer wouldn't remove.  After these were cleaned out the logon went back to normal.  Hope it helps.

    c:\Users\username\AppData\Roaming\Microsoft\Windows\Cookies

    c:\Users\username\AppData\Local\Microsoft\Windows\Temporary Internet Files

    2013年5月29日 19:24
  • Hello,

    I try to check and do what you have instructed, but in windows 7 its not configured as default, is their differences between not configure and disable? correct me if Im wrong :)


    I have the same issue with a laptop 70% its fix(I remove an installed application), but somehow 30% doubted, their is a chance once a time it has normal booting and some other times problem occurs again(too long loading of user profile).
    • 編集済み Jayem626 2014年3月4日 20:06
    2014年3月4日 20:02
  • Problem with step  2  Type “gpedit.msc” in Search box and press Enter.

    if you type that on a windows home 7 64bit doesn't have that service or program. that's only on the pro version .



    2018年7月10日 19:19