locked
Service Manager Authoring Tool Error RRS feed

  • 質問

  • Dear All,

    When trying to edit a management pack i get the following error:

    Verification failed with 1 errors:
    -------------------------------------------------------
    Error 1:
    Found error in 2|UnknowMP|1.0.0.0|UnknowMP|| with message:
    XSD verification failed for the management pack. [Line: 0, Position: 0]
    System.Xml.Schema.XmlSchemaValidationException: 'test1' is already used as an ID.
       at System.Xml.Schema.XmlSchemaValidator.SendValidationEvent(XmlSchemaValidationException e, XmlSeverityType severity)
       at System.Xml.Schema.XmlSchemaValidator.SendValidationEvent(String code, String arg)
       at System.Xml.Schema.XmlSchemaValidator.ProcessTokenizedType(XmlTokenizedType ttype, String name, Boolean attrValue)
       at System.Xml.Schema.XmlSchemaValidator.CheckTokenizedTypes(XmlSchemaDatatype dtype, Object typedValue, Boolean attrValue)
       at System.Xml.Schema.XmlSchemaValidator.ValidateAttribute(String lName, String ns, XmlValueGetter attributeValueGetter, String attributeStringValue, XmlSchemaInfo schemaInfo)
       at System.Xml.Schema.XmlSchemaValidator.ValidateAttribute(String localName, String namespaceUri, XmlValueGetter attributeValue, XmlSchemaInfo schemaInfo)
       at System.Xml.XsdValidatingReader.ValidateAttributes()
       at System.Xml.XsdValidatingReader.ProcessElementEvent()
       at System.Xml.XsdValidatingReader.ProcessReaderEvent()
       at System.Xml.XsdValidatingReader.Read()
       at Microsoft.EnterpriseManagement.Configuration.XSDVerification.ValidateManagementPack(TextReader mpcontents, ManagementPack mp, Boolean throwError)
    -------------------------------------------------------
     XSD verification failed for the management pack. [Line: 0, Position: 0]

    Please help.

    IT

    2020年1月30日 15:07

回答

すべての返信

  • I have fixed my issue now
    2020年1月30日 16:01
  • Would you mind sharing the solution?
    2020年2月21日 14:15
  • Would you mind sharing the solution?

    Hi,

    If I ahve to gues it would be because of this:

    System.Xml.Schema.XmlSchemaValidationException: 'test1' is already used as an ID.

    So "test1" is used as an ID or part of an ID somewhere and that is why the XML schema cannot be verified. Would be happy to find out the real cause though.

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    2020年2月21日 14:22