none
windows server 2012 R2에서 remote desktop licensing mode is not configured 메시지가 뜹니다 RRS feed

  • 질문

  • windows server 2012 R2 설치된 서버에서 트레이 하단에 다음 이미지와 같은 메시지가 뜹니다.

    원격데스크톱을 사용하고 server 2012  R2와 RDS CAL 구매한 상태입니다.

    어떻게 조치해야 되는지 궁금합니다.

    Windows server 2012 R2 는 한글로 설치했다가 영문으로 바꾼 상태입니다.

    계정을 확인하기 전에는 본문에 이미지 또는 링크를 포함할 수 없다고 해서

    이미지 대신 텍스트로 내용 알려드립니다.

    Remote Desktop licensing mode is not configured.

    Remote Desktop Services will stop working in 1 days. On the RD

    Connection Broker server, use Server Mansger to specify the Remote

    Desktop licensing mode and the license server.

    2016년 6월 1일 수요일 오전 12:39

답변


  • 안녕하세요,

    우선 아래 링크의 내용을 참고하셔서 정상적으로 라이선스를 구성하셨는지 확인해주시기 바랍니다.

    ■ RD Licensing Configuration on Windows Server 2012
    https://blogs.technet.microsoft.com/askperf/2013/09/20/rd-licensing-configuration-on-windows-server-2012/

    만약 라이선스를 올바르게 구성하셨음에도 문제가 발생한다면 아래 과정을 진행해보시기 바랍니다.

    To fix the problem, run the following commands in powershell to set the licensing server properly on the rd session host using the WMI CIM provider:
    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting
    $obj. SetSpecifiedLicenseServerList("licserver.domain.local")

    Then, go into the registry and manually set the licensing mode:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core\LicensingMode

    You need to change the DWORD to 2 for Per Device or 4 for Per User.
    Licensing Mode in Registry Editor
    Next, reboot the system. The changes made previously will report everything properly and the RDS host will now recognize the licensing configuration.

    ■ How to fix RDS 2012r2 error: “Licensing mode for the Remote Desktop Session Host is not configured.”
    http://www.tbngconsulting.com/blog/bid/404182/Licensing-mode-for-the-Remote-Desktop-Session-Host-is-not-configured

    2016년 6월 1일 수요일 오전 5:14
    중재자